By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,574 Members | 2,966 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,574 IT Pros & Developers. It's quick & easy.

Setting up Postgresql on Linux

P: n/a
Hello,
I am trying to use the linux startup script in the contrib directory
of the distribution. I get the following error in the server log:

LOG: invalid secondary checkpoint record
PANIC: unable to locate a valid checkpoint record
LOG: startup process (pid 1480) was terminated by signal 6
LOG: aborting startup due to startup process failure

When I issue the this collamd I get an error:

[postgres@hardwoodthunder postgres]$ psql -- v
psql: could not connect to server: No such file or directory
Is the server running locally and accepting
connections on Unix domain socket "/tmp/.s.PGSQL.5432"?

I have added theses lines in postgresql.config:

tcpip_socket = true
port = 5432

If I isssue the command:
[postgres@hardwoodthunder postgres]$ /etc/init.d/postgres status
Password:
pg_ctl: postmaster or postgres is not running

Any ideas what I'm doing wrong?
thanks,
Phil


---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org

Nov 23 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Phil Campaigne wrote:
Hello,
I am trying to use the linux startup script in the contrib directory of
the distribution. I get the following error in the server log:

LOG: invalid secondary checkpoint record
PANIC: unable to locate a valid checkpoint record
LOG: startup process (pid 1480) was terminated by signal 6
LOG: aborting startup due to startup process failure

When I issue the this collamd I get an error:

[postgres@hardwoodthunder postgres]$ psql -- v
psql: could not connect to server: No such file or directory
Is the server running locally and accepting
connections on Unix domain socket "/tmp/.s.PGSQL.5432"?

I have added theses lines in postgresql.config:

tcpip_socket = true
port = 5432

If I isssue the command:
[postgres@hardwoodthunder postgres]$ /etc/init.d/postgres status
Password:
pg_ctl: postmaster or postgres is not running

Any ideas what I'm doing wrong?
thanks,
Phil


---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org


Opps! I fixed the above problems by re-initializing and creating a new
data directory. But as I continued I got another error, here's the
printout:

[postgres@hardwoodthunder postgres]$ psql testdb
Welcome to psql 7.3.2, the PostgreSQL interactive terminal.

Type: \copyright for distribution terms
\h for help with SQL commands
\? for help on internal slash commands
\g or terminate with semicolon to execute query
\q to quit

psql: relocation error: psql: undefined symbol: PQgetssl <?????????????

So I set these env variables:
[postgres@hardwoodthunder postgres]$ LD_LIBRARY_PATH=/usr/local/pgsql/lib
[postgres@hardwoodthunder postgres]$ export LD_LIBRARY_PATH
[postgres@hardwoodthunder postgres]$
[postgres@hardwoodthunder postgres]$ PATH=/usr/local/pgsql/bin:$PATH
[postgres@hardwoodthunder postgres]$ export PATH

And it works!

[postgres@hardwoodthunder postgres]$ psql testdb
Welcome to psql 7.3.4, the PostgreSQL interactive terminal.

Type: \copyright for distribution terms
\h for help with SQL commands
\? for help on internal slash commands
\g or terminate with semicolon to execute query
\q to quit

testdb=#

MY QUESTION:
These env varialbes are already set in .bash_profile for root and
postgres users. Why do I have to set them manually every time?
thanks,
Phil


---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend

Nov 23 '05 #2

P: n/a
Phil Campaigne <pc********@charter.net> writes:
So I set these env variables:
[postgres@hardwoodthunder postgres]$ LD_LIBRARY_PATH=/usr/local/pgsql/lib
[postgres@hardwoodthunder postgres]$ export LD_LIBRARY_PATH


You'd probably do better to mess with /etc/ld.so.conf. See "man ldconfig".

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 6: Have you searched our list archives?

http://archives.postgresql.org

Nov 23 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.