By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
464,705 Members | 1,279 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 464,705 IT Pros & Developers. It's quick & easy.

Setting up Postgres on Linux

P: n/a
scott.marlowe wrote:
On Thu, 4 Mar 2004, phil campaigne wrote:
Hello,
when I login to linux and check the env's I see:
PATH=/usr/local/pgsql/bin:/bin:/usr/bin:/usr/local/bin:/usr/bin/X11:/usr/X11R6/bin:/home/postgres/bin:/opt/IBMJava2-14/bin:/opt/IBMJava2-14/jre/bin:/usr/local/pgsql/bin

LD_LIBRARY_PATH=/usr/local/pgsql/lib

However after I successfully start postgresql using
/etc/init.d/postgres start
/etc/init.d/postgres status

I cannot execute the following:
psql testdb
psql: relocation error: psql: undefined symbol: PQgetssl

Then if I execute from the command line:
LD_LIBRARY_PATH=/usr/local/pgsql/lib
export LD_LIBRARY_PATH

PATH=/usr/local/pgsql/bin:$PATH
export PATH

then psql testdb works!

What's going on???

Are you exporting those same settings in your .bash_profile or
whatever is setting up your environ?

Yes Scott,
I tried exporting from /root/.bash_profile and /postgres/.bash_profile.
I also added the line

/usr/local/pgsql/lib

to /etc/ld.so.conf

I don't get it.
Phil

---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 23 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.