472,791 Members | 1,450 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 472,791 software developers and data experts.

[SECURITY] New set of PostgreSQL RPMS are available for download

Hash: SHA1
- ---------------------------------------------------------------------
PostgreSQL RPM Set Update

Version(s): 7.3.8, 7.4.6

New set labels: 7.3.8-2PGDG, 7.4.6-2PGDG
- ---------------------------------------------------------------------

- ---------------------------------------------------------------------
Update Info:

Due to a security bug in RPM sets, new RPM sets for 7.4.6 and 7.3.8 have
been released. They are available in FTP site and synched mirrors. Due to
the seriousness of the bug, it is strongly recommended that administrators
upgrade their database servers at their earliest convenience.

Also, some minor changes have been applied to the spec files.

It should be noted that, for those looking to upgrade from a 7.4.0/7.4.1
server to 7.4.6, that there a dump-n-reload is *recommended* (but not
required) to address a fix introduced between 7.4.1 and 7.4.2. Please
refer to the 7.4.6 HISTORY file for information on how this can be
accomplished without a dump-n-reload, as there are steps that can be
followed for this.

7.4.6-2 set also includes RPMs for RHAS 2.1, thanks to Gaetano Mendola for
the effort.

These sets include RPMs and SRPMs for Fedora Core 1, Fedore Core 2, Red
Hat Enterprise Linux 3.0, Red Hat Linux 9 and Red Hat Advanced Server 2.1.
md5sums are also provided with the packages.
- ---------------------------------------------------------------------

- ---------------------------------------------------------------------
Changes since 7.4.6-1PGDG and 7.3.8-1PGDG RPMs:

* Updated init script to preventa nefarious postgres user from obtaining
root privileges.(per Red Hat Bugzilla #136947, #136949)
* Updated kerbdir
* Updated PyGreSQL from 3.4 to 3.5 (only for 7.4.6-2PGDG)
* Updated spec file to correct permissions for PyGreSQL permissions (per
Red Hat RPMS) (for only 7.4.6-2PGDG)
* Updated doc files for PyGreSQL (only for 7.4.6-2PGDG)
* Modified if-endif lines for tcl&tcldevel prereq lines (per Red Hat RPMS)
* Applied getppid.patch as patch #4 (per Red Hat RPMS)
- - Updated preun and postun server scripts, per Red Hat RPMS
- ----------------------------------------------------------------------

Please download these from one of our FTP mirror sites:


or from Bittorrent (Thanks to David Fetter) :


As always, please report any bugs to pg********@postgresql.org

- --
devrim~gunduz.org devrim.gunduz~linux.org.tr
Version: GnuPG v1.2.1 (GNU/Linux)


---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?


Nov 23 '05 #1
1 2809
Devrim GUNDUZ wrote:
* Updated PyGreSQL from 3.4 to 3.5 (only for 7.4.6-2PGDG)

Given the fact that PyGreSQL is still affected by the unfamous
"idle in transaction" behaviour:
def __init__(self, cnx):
self.__cnx = cnx
self.__cache = pgdbTypeCache(cnx)
src = self.__cnx.source()
raise OperationalError, "invalid connection."

def close(self):

def commit(self):
src = self.__cnx.source()
raise OperationalError, "can't commit."

def rollback(self):
src = self.__cnx.source()
raise OperationalError, "can't rollback."

why do not distribute with next RPM the psycopg instead ?

Gaetano Mendola
Nov 23 '05 #2

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

by: Peter Eisentraut | last post by:
SuSE RPMs for PostgreSQL 7.4 are available at ftp://ftp.postgresql.org/pub/binary/v7.4/suse or a mirror http://www.postgresql.org/mirrors-www.html or at
by: Manuel Tejada | last post by:
Hello list This is my situation: My box: Pentium III, Red Hat 9.0 I was working fine with PostgreSQL 7.3.2. Recently I decided to upgrade it to PostgreSQL 7.4 installing the twelve rpms I...
by: Manuel Tejada | last post by:
Hi My box: RedHat 9.0, Pentium III Recently I upgraded from PostgreSQL 7.3.2 to PostgreSQL 7.4.1. The PostgreSQL 7.3.2's rpms were installed from RehHat CDs The PostgreSQL 7.4.1's rpms I used...
by: Shanmugasundaram Doraisamy | last post by:
Dear group, I would like to know where I could find rpms for Redhat 7.3. I have looked at the downloads page and I see only source rpms and rpms for Redhat 9 and FC1. I did download the src rpm...
by: Secrétariat | last post by:
Hello ! I use a PostgreSQL server 7.4 on Linux Mandrake 10 with IP, a database gestix is created. An PostegreSQL user "postgres" id defined on this server, I add in the...
by: Marc G. Fournier | last post by:
In order to address a recent security report from iDefence, we have released 3 new "point" releases: 7.2.6, 7.3.8 and 7.4.6 Although rated only a Medium risk, according to their web site: "A...
by: Devrim GUNDUZ | last post by:
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Hi, (S)RPMs for new point releases (per http://archives.postgresql.org/pgsql-announce/2004-10/msg00010.php) have been built for Fedora Core...
by: SmoothJazz | last post by:
Hi All! I am wanting to setup/run PostgreSQL on my server (a SuSE Linux 9.2 distro) but I'm not quite sure which way to go. I have a few books on PostgreSQL but they don't seem to match the...
by: rich | last post by:
I want to upgrade php 4.3.9 and postgresql 7.4.13 on Centos 4.3 to php 5.1.4 and postgresql 8.1.4 using rpms. Has anyone done this?
by: erikbower65 | last post by:
Using CodiumAI's pr-agent is simple and powerful. Follow these steps: 1. Install CodiumAI CLI: Ensure Node.js is installed, then run 'npm install -g codiumai' in the terminal. 2. Connect to...
by: erikbower65 | last post by:
Here's a concise step-by-step guide for manually installing IntelliJ IDEA: 1. Download: Visit the official JetBrains website and download the IntelliJ IDEA Community or Ultimate edition based on...
by: kcodez | last post by:
As a H5 game development enthusiast, I recently wrote a very interesting little game - Toy Claw ((http://claw.kjeek.com/))。Here I will summarize and share the development experience here, and hope it...
by: Taofi | last post by:
I try to insert a new record but the error message says the number of query names and destination fields are not the same This are my field names ID, Budgeted, Actual, Status and Differences ...
by: DJRhino1175 | last post by:
When I run this code I get an error, its Run-time error# 424 Object required...This is my first attempt at doing something like this. I test the entire code and it worked until I added this - If...
by: DJRhino | last post by:
Private Sub CboDrawingID_BeforeUpdate(Cancel As Integer) If = 310029923 Or 310030138 Or 310030152 Or 310030346 Or 310030348 Or _ 310030356 Or 310030359 Or 310030362 Or...
by: lllomh | last post by:
Define the method first this.state = { buttonBackgroundColor: 'green', isBlinking: false, // A new status is added to identify whether the button is blinking or not } autoStart=()=>{
by: lllomh | last post by:
How does React native implement an English player?
by: Mushico | last post by:
How to calculate date of retirement from date of birth

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.