469,602 Members | 1,793 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,602 developers. It's quick & easy.

Changing innodb log file size - errors?

Hi,

I am using MySQL version 5.0 on Linux Fedora Core 4.

I recently got this error message:

060609 11:06:29 InnoDB: ERROR: the age of the last checkpoint is
9433557,
InnoDB: which exceeds the log group capacity 9433498.
InnoDB: If you are using big BLOB or TEXT rows, you must set the
InnoDB: combined size of log files at least 10 times bigger than the
InnoDB: largest such row.

which I interpreted as my log files at /var/lib/mysql/ib_logfile0 and
/var/lib/mysql/ib_logfile1 being too small (still at default at 5M). I
looked up some resources and they recommended setting the log file size
to about 25% of my buffer size, which I had set to 256MB.

So I added the line in /etc/my.cnf :
innodb_log_file_size=50M

But on restart i get the error:
InnoDB: Error: log file ./ib_logfile0 is of different size 0 5242880
bytes
InnoDB: than specified in the .cnf file 0 52428800 bytes!

and my queries started failing too:
060609 12:05:39 [ERROR] /usr/sbin/mysqld: Incorrect information in
file: './db/available.frm'
060609 12:05:39 [ERROR] /usr/sbin/mysqld: Incorrect information in
file: './db/available.frm'
060609 12:05:39 [ERROR] /usr/sbin/mysqld: Incorrect information in
file: './db/site_info.frm'

I reverted my config back to a default log file size, and everything
went back to normal. Is there a proper procedure that I should follow
for changing the log file size?

Jun 9 '06 #1
1 40400
Fuzzy,

"fuzzybr80" <fu*******@gmail.com> kirjoitti
viestissä:11**********************@y43g2000cwc.goo glegroups.com...
Hi,

I am using MySQL version 5.0 on Linux Fedora Core 4.

I recently got this error message:

060609 11:06:29 InnoDB: ERROR: the age of the last checkpoint is
9433557,
InnoDB: which exceeds the log group capacity 9433498.
InnoDB: If you are using big BLOB or TEXT rows, you must set the
InnoDB: combined size of log files at least 10 times bigger than the
InnoDB: largest such row.

which I interpreted as my log files at /var/lib/mysql/ib_logfile0 and
/var/lib/mysql/ib_logfile1 being too small (still at default at 5M). I
looked up some resources and they recommended setting the log file size
to about 25% of my buffer size, which I had set to 256MB.

So I added the line in /etc/my.cnf :
innodb_log_file_size=50M

But on restart i get the error:
InnoDB: Error: log file ./ib_logfile0 is of different size 0 5242880
bytes
InnoDB: than specified in the .cnf file 0 52428800 bytes!

and my queries started failing too:
060609 12:05:39 [ERROR] /usr/sbin/mysqld: Incorrect information in
file: './db/available.frm'
060609 12:05:39 [ERROR] /usr/sbin/mysqld: Incorrect information in
file: './db/available.frm'
060609 12:05:39 [ERROR] /usr/sbin/mysqld: Incorrect information in
file: './db/site_info.frm'

I reverted my config back to a default log file size, and everything
went back to normal. Is there a proper procedure that I should follow
for changing the log file size?


yes, please see:

http://dev.mysql.com/doc/refman/5.0/...-removing.html

Best regards,

Heikki

Oracle Corp./Innobase Oy
InnoDB - transactions, row level locking, and foreign keys for MySQL

InnoDB Hot Backup - a hot backup tool for InnoDB which also backs up MyISAM
tables
http://www.innodb.com/order.php
Jun 12 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by Steve | last post: by
6 posts views Thread by Andrew Clark | last post: by
2 posts views Thread by Mike | last post: by
3 posts views Thread by Jefferis NoSpamme | last post: by
5 posts views Thread by Jefferis NoSpamme | last post: by
2 posts views Thread by somequestion | last post: by
reply views Thread by suresh191 | last post: by
4 posts views Thread by guiromero | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.