469,287 Members | 2,436 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,287 developers. It's quick & easy.

Not all archive (offline active) logs are getting backed up

Hi,
Im new to db2.

Im using db2 ese 9.1 (fix pack 1) on SLES 9.0 32 bit. I have single instance on three logical nodes 0,1,2. i have cofigured userexit - on, logretain - on, trackmod - on.

when i take full offline backup i observe that more number of archive logs are backed up on logical node 0. But the less logs are getting backed up on logical nodes 1,2. So when i drop the database those logs are lost.
when i restore the database and say rollforward to the end of logs and complete i get the error msg:
SQL4970N Roll-forward recovery on database "SAMPLE" cannot reach the specified stop point (end-of-log or point-in-time) because of missing or
corrupted log file(s) on database partition(s) "1,2". Roll-forward recovery
processing has halted on log file "S000002.LOG".

i need ur help regarding:
1. Is my observation is in line with the cause of the problem.
2. when we see current FIRST ACTIVE LOG FILE in the get db cfg, is that all the files previous to the one indicated are inactive offline active logs and should to backed up by userexit program.
3. how can i fix my problem.

I seek your help at the earliest.

Thanks
Prashanth
Jun 14 '07 #1
0 1446

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

1 post views Thread by DB2 Convert | last post: by
7 posts views Thread by William | last post: by
1 post views Thread by saramathi | last post: by
2 posts views Thread by =?Utf-8?B?ZGF2ZS5oYXJkeQ==?= | last post: by
10 posts views Thread by Michael Hoffmann | last post: by
3 posts views Thread by Kofa | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by suresh191 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.