By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,227 Members | 1,025 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,227 IT Pros & Developers. It's quick & easy.

Exclamation point in password irritates DB2 CC?

P: n/a
aj
DB2 WSE 8.1 FP5
Linux Red Hat 2.1 AS

I am using a new more secure password for my instance owner
account, one which has an exclamation point in it.

Using CC, when I try to import or export or use any of the
various automated functions, I get:

SQL0104N An unexpected token "!" was found following
"<identifier>". Expected tokens may include: "NEW".

Explanation:

A syntax error in the SQL statement was detected at the specified
token following the text "<text>". The "<text>" field indicates
the 20 characters of the SQL statement that preceded the token
that is not valid..... <snip>

If I press the 'Show Command' button, copy the command to a
cmd-line CLP script, and let DB2 ask me for the password on the
cmd line, all is fine. So the problem is that the exclamation
point in the password irritates CC.

This is slowing me down... Any ideas?

TIA

aj
Nov 12 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
I believe DB2 v8 fixpak 7 or later (also known as DB2 8.2) supports !
in authid's and passwords.

Nov 12 '05 #2

P: n/a
aj
ad******@ca.ibm.com wrote:
I believe DB2 v8 fixpak 7 or later (also known as DB2 8.2) supports !
in authid's and passwords.

Thanks Blair.

aj
Nov 12 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.