467,879 Members | 1,296 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 467,879 developers. It's quick & easy.

Exclamation point in password irritates DB2 CC?

aj
DB2 WSE 8.1 FP5
Linux Red Hat 2.1 AS

I am using a new more secure password for my instance owner
account, one which has an exclamation point in it.

Using CC, when I try to import or export or use any of the
various automated functions, I get:

SQL0104N An unexpected token "!" was found following
"<identifier>". Expected tokens may include: "NEW".

Explanation:

A syntax error in the SQL statement was detected at the specified
token following the text "<text>". The "<text>" field indicates
the 20 characters of the SQL statement that preceded the token
that is not valid..... <snip>

If I press the 'Show Command' button, copy the command to a
cmd-line CLP script, and let DB2 ask me for the password on the
cmd line, all is fine. So the problem is that the exclamation
point in the password irritates CC.

This is slowing me down... Any ideas?

TIA

aj
Nov 12 '05 #1
  • viewed: 2171
Share:
2 Replies
I believe DB2 v8 fixpak 7 or later (also known as DB2 8.2) supports !
in authid's and passwords.

Nov 12 '05 #2
aj
ad******@ca.ibm.com wrote:
I believe DB2 v8 fixpak 7 or later (also known as DB2 8.2) supports !
in authid's and passwords.

Thanks Blair.

aj
Nov 12 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

9 posts views Thread by Neil Varshneya | last post: by
2 posts views Thread by philhege | last post: by
8 posts views Thread by Dennis C. Drumm | last post: by
3 posts views Thread by rvanvolken | last post: by
reply views Thread by jack112 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.