469,366 Members | 2,408 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,366 developers. It's quick & easy.

InterDev VSS Integration

I am unable to get the VSS Integration with InterDev to work after reading the Microsoft support articles and searching through the usenet using Google groups. I have read MS Knowledge Base Article - 171116 and enabled FrontPage logging as described in 191289

I am still getting the 'User "" not found' message in the event log on the web server even after enableing the "Use Netwrk name for automatic login" in VSS Administrator

Here are the settings that I know to be relevant
IIS
Directory Security
Anonymous Access is off
Basic Authentication is on
Digest Authentication is off
Integrated Windows Authentication - I've tried it both ways.
In our environment we have it on in production.
I've turned it off to try to debug this as suggested in MSKB 171116
I've set the basic authentication domain to the domain for the login
that I am using (after trying it without that set first)
Server Extensions
The version control dropdown is only showing "None" and "Use built-in".
I don't have the "External" option showing up. I've tried both settings

My VSS is running on anothre server. I used "Regsvr32 \\vssbox\VSS\win32\SSAPI.DLL" to register the dll on the web server

Registry
\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\All Ports\LogInitialSourceControlErrors is set to "1

Under \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SourceSafe here are the settings shown as they appear in a regfile export
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SourceSafe
"API Current Database"="C:\\Program Files\\Microsoft Visual Studio\\VSS
"PromptForConnect"=dword:0000000
"SCCServerName"="Microsoft Visual SourceSafe
"SCCServerPath"="C:\\Program Files\\Microsoft Visual Studio\\VSS\\win32\\SSSCC.DLL
"Current Database"="\\\\vssbox\\vssshare\\

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SourceSafe\D atabases
"Microsoft Visual Studio"="C:\\Program Files\\Microsoft Visual Studio\\VSS
"D2Automation"="\\\\vssbox\\vssshare\\

SCCServerPath was set differently after the "Regsvr32 \\vssbox\VSS\win32\SSAPI.DLL", but after trying a reinstall, it was set to the setting above. Using Regsvr32 again doesn't seem to set it back anymore

In VSS Administrator on the vssbox machine under General, I have "Use network name for automatic user login" checked.
I've tried filling in appropriate things under the Web Projects tab

I've made sure that my username is added to the VSS Administrator with the same password as my network login

When I try to check in a solution in InterDev by right clicking on it in the Project Explorer, I get the following message

--------------------------
Microsoft Development Environmen
--------------------------
Cannot establish source control for the Web application. The server does not have a source control system installed on it, or the user name is not recognized
--------------------------
OK
--------------------------

The client and server are installed on both the web server and the vssbox

Any help would be appreciated

Jul 19 '05 #1
8 3988
My development client is running XP professional SP 1
The web server is running 2k Server
The VSS server is running 2k Server
InterDev is version 6.0
VSS is version 6.0
Internet Information Services 5.

Jul 19 '05 #2
Add the IUSR_ user to the VSS user database

Jeff

"Rick Kopnisky" <an*******@discussions.microsoft.com> wrote in message
news:21**********************************@microsof t.com...
I am unable to get the VSS Integration with InterDev to work after reading the Microsoft support articles and searching through the usenet using Google
groups. I have read MS Knowledge Base Article - 171116 and enabled
FrontPage logging as described in 191289.
I am still getting the 'User "" not found' message in the event log on the web server even after enableing the "Use Netwrk name for automatic login" in
VSS Administrator.
Here are the settings that I know to be relevant:
IIS:
Directory Security:
Anonymous Access is off.
Basic Authentication is on.
Digest Authentication is off.
Integrated Windows Authentication - I've tried it both ways.
In our environment we have it on in production.
I've turned it off to try to debug this as suggested in MSKB 171116. I've set the basic authentication domain to the domain for the login that I am using (after trying it without that set first).
Server Extensions:
The version control dropdown is only showing "None" and "Use built-in". I don't have the "External" option showing up. I've tried both settings.
My VSS is running on anothre server. I used "Regsvr32 \\vssbox\VSS\win32\SSAPI.DLL" to register the dll on the web server.
Registry:
\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\All Ports\LogInitialSourceControlErrors is set to "1"
Under \HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SourceSafe here are the settings shown as they appear in a regfile export: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SourceSafe]
"API Current Database"="C:\\Program Files\\Microsoft Visual Studio\\VSS"
"PromptForConnect"=dword:00000001
"SCCServerName"="Microsoft Visual SourceSafe"
"SCCServerPath"="C:\\Program Files\\Microsoft Visual Studio\\VSS\\win32\\SSSCC.DLL" "Current Database"="\\\\vssbox\\vssshare\\"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SourceSafe\D atabases]
"Microsoft Visual Studio"="C:\\Program Files\\Microsoft Visual Studio\\VSS" "D2Automation"="\\\\vssbox\\vssshare\\"

SCCServerPath was set differently after the "Regsvr32 \\vssbox\VSS\win32\SSAPI.DLL", but after trying a reinstall, it was set to
the setting above. Using Regsvr32 again doesn't seem to set it back
anymore.
In VSS Administrator on the vssbox machine under General, I have "Use network name for automatic user login" checked. I've tried filling in appropriate things under the Web Projects tab.

I've made sure that my username is added to the VSS Administrator with the same password as my network login.
When I try to check in a solution in InterDev by right clicking on it in the Project Explorer, I get the following message:
---------------------------
Microsoft Development Environment
---------------------------
Cannot establish source control for the Web application. The server does not have a source control system installed on it, or the user name is not
recognized. ---------------------------
OK
---------------------------

The client and server are installed on both the web server and the vssbox.

Any help would be appreciated.

Jul 19 '05 #3
First, thank you very much for posting an answer to my question. There are some things that I am not clear on about trying this

I thought you didn't need to add the iUSR_machine user if anonymous access was turned off. That's how I read MSKB 171116. But I am certainlly eager to give it a shot. I do, however, have some questions on how to try this

Here is what I am wondering about

1) Which machine's iUSR_machine user should I add,
via the VSS administrator, the web server's or the
VSS server's (iUSR_vssbox or iUSR_iisbox)
2) Does this user need to be added to a domain as a
network user and given access to the VSS serve
in addition to being added to VSS (assuming that
we are adding iUSR_iisbox)
3) Does this user need a local Windows account (if it's
the web server user)
4) What password should I give this user in VSS
5) Does the password need to be the same as the
OS or network user? If so, how do I find that?
If I change iUSR_machine's password, will that
break something else

Thank you again for your help. I hope that you or someone else might be able to help with these additional questions
Jul 19 '05 #4
Just add the web server iusr to the vss user list, no password.

However, I've always put VSS and IIS on the same box (because I could)

Jeff

"Rick Kopnisky" <an*******@discussions.microsoft.com> wrote in message
news:02**********************************@microsof t.com...
First, thank you very much for posting an answer to my question. There are some things that I am not clear on about trying this.
I thought you didn't need to add the iUSR_machine user if anonymous access was turned off. That's how I read MSKB 171116. But I am certainlly eager
to give it a shot. I do, however, have some questions on how to try this.
Here is what I am wondering about:

1) Which machine's iUSR_machine user should I add,
via the VSS administrator, the web server's or the
VSS server's (iUSR_vssbox or iUSR_iisbox)?
2) Does this user need to be added to a domain as a
network user and given access to the VSS server
in addition to being added to VSS (assuming that
we are adding iUSR_iisbox)?
3) Does this user need a local Windows account (if it's
the web server user)?
4) What password should I give this user in VSS?
5) Does the password need to be the same as the
OS or network user? If so, how do I find that?
If I change iUSR_machine's password, will that
break something else?

Thank you again for your help. I hope that you or someone else might be able to help with these additional questions.

Jul 19 '05 #5
OK, I tried adding IUSR_machine to VSS
I even put VSS on the same server as IIS
I'm still getting the same problems
Any help is appreciated

The "External" choice in the dropdown is still not showing. I only have the "None" and "Use built-in" showing up
I am still getting the following in the Application Event log on the web/VSS server

Event Type: Warnin
Event Source: FrontPage 4.
Event Category: Non
Event ID: 100
Date: 6/5/200
Time: 3:18:42 P
User: N/
Computer: MACHIN
Description
Microsoft FrontPage Server Extensions
Error #90017 Message: Source Control System failure: User "" not found

Event Type: Warnin
Event Source: FrontPage 4.
Event Category: Non
Event ID: 100
Date: 6/5/200
Time: 3:17:55 P
User: N/
Computer: MACHIN
Description
Microsoft FrontPage Server Extensions
(OS Error #-2147166526 Message: )

I am a getting this on the client in IntreDev

"Cannot establish source control for the Web application. The server does not have a source control system installed on it, or the user name is not recognized.
Jul 19 '05 #6
So I do have it working now

Here are the things that I did
1) I moved the database local
2) Restarted the serve
3) Refreshed the Internet Services Manage

At this point the "Use External" option appeared as a choice
I selected it and it took a long time
I stopped it and tried it again
On the third attempt it worked

I was still getting errors but I was clearly getting closer

I spotted that I had done a network installation from the original VSS server and a local VSS database had not been created. I tried to create a database, but got file access errors and such. It wasn't creating the ./users/admin/ss.ini file

So I went to add/remove programs and got rid of the entire VSS installation

I reinstalled VSS and the VSS server. I also installed InterDev on the server for good measure as well. I figured if the Visual Studio install knew that InterDev and VSS were both going to be there, it might do something to make sure that they worked together

It did. I was then able to create a test project on the server in InterDev and check it in

I then did the same on the client

I then backed up my real project that I was working on by zipping it up and saving it to disk

I then went into the IIS manager and changed the server extensions web into a folder. On the server I then created a new project in IntreDev and let that turn it back into a web

I was then able, on the server, to finally check in the project

I then went to my client and opened that project and that worked as well

I may at some point try to figure out how to get it working on a seperate folder. But not today
Jul 19 '05 #7
Oh, yeah, it wasn't necessary to add IUSR_Machine as a VSS user. I imagine that if I allow anonymous access in IIS, it'll need that user added

Also, I didn't have to uncheck "Integrated Windows Authentication" under Directory Security in the IIS manager program. It just worked and didn't prompt me for my Windows password

Jul 19 '05 #8
I restarted the web server and VSS integration started working again.
Jul 19 '05 #9

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by Alan | last post: by
21 posts views Thread by Bruce W...1 | last post: by
8 posts views Thread by James Baker | last post: by
4 posts views Thread by margaret | last post: by
3 posts views Thread by Wanjun Yu | last post: by
reply views Thread by zhoujie | last post: by
1 post views Thread by Marylou17 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.