By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,491 Members | 858 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,491 IT Pros & Developers. It's quick & easy.

Finding problems in reports where functions are involved

P: n/a
hi,
I'm finding this problem most frustrating. (It's probably my lack of
undersating of functions!) I want to fill a control in a report with the
result of a function. I'm calculating the average of a number of fields for
the current record. It all works .. to a point!! Using for and next I can
identify the fileds and get the data. All is fine until the fields are
empty or null (I'm not quite sure.) all I get back is 'error' in the
report, and that is not very helpful. (Even with on error etc in the
function. I've exhausted (probably not actually) all possible combinations
od Nz, iif etc!!

Thanks in advance
Nov 13 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
How about posting the relevant code?

"John M" <jo**@jmawer.demon.co.uk> wrote in message
news:ck*******************@news.demon.co.uk...
hi,
I'm finding this problem most frustrating. (It's probably my lack of
undersating of functions!) I want to fill a control in a report with the
result of a function. I'm calculating the average of a number of fields for the current record. It all works .. to a point!! Using for and next I can identify the fileds and get the data. All is fine until the fields are
empty or null (I'm not quite sure.) all I get back is 'error' in the
report, and that is not very helpful. (Even with on error etc in the
function. I've exhausted (probably not actually) all possible combinations od Nz, iif etc!!

Thanks in advance

Nov 13 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.