By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,247 Members | 871 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,247 IT Pros & Developers. It's quick & easy.

OpenGL Control Flickering Problem

P: n/a
I have a problem with my Visual Basic .NET 2003 application which I
have so far been unable to resolve.

I am trying to get an OpenGL control that I have created working
properly as a control on my main form in my VB.NET application. It does
work and render correctly but the problem is that there is an awful
flickering that happens on most PCs I try it on. The flickering is
reminiscent of the sort that you get on a TV when it is not tuned in
properly, i.e. portions of the background are visible in horizontal
bands that move up or down the control and make it pretty much
unusable.

Bizarrely though, on my laptop, if I Alt-Tab to another application
which moves in front of the flickering control and then Alt-Tab back to
my application then it is fine for a while. However, as soon as any
other dialog or message box appears in my application, or I resize it
then the flickering starts again. On two of my colleague's laptops
however, we get the flickering and no amount of moving things in front
of it makes any difference.

Also, when I remote desktop into my laptop from my PC, I do not see
this problem at all, i.e. the control behaves perfectly.

I am using an OpenGL wrapper library. I oringally tried using CsGL and
then I tried Tao (more recent and maintained library) for the control,
both have the same result.

The code I am using has a timer on the form which fires periodically to
force the refresh of the control. I have tried varying the periodicity
of this from 1ms right up to 1000ms but the flickering still happens.
With 1000ms it almost appears like as soon as the control is refreshed,
it disappears as with this periodicity it becomes almost invisible.

Does anyone have any ideas on this as it is driving me barmy now!

Thanks,

Mark.

May 10 '06 #1
Share this Question
Share on Google+
6 Replies


P: n/a
Hello Mark,

Probably you'll need to enable double buffering on your control during
its creation:

~
Me.SetStyle(ControlStyles.DoubleBuffer, True)
Me.SetStyle(ControlStyles.AllPaintingInWmPaint, True)
Me.SetStyle(ControlStyles.UserPaint, True)
~

Hope this helps,
Roman
May 11 '06 #2

P: n/a
Thanks Roman but I am pretty sure that's not it.

I probably should have mentioned that I had already eliminated lack of
Double Bufferring as the problem as I am already doing this. Also, it
isn't that sort of flickering that you get with the bufferring, it is
more like the entire control is disappearing every time it is
refreshed. It's just that I am refreshing so often that it is appearing
and disappearing several times a second.

Any further help from anyone would be appreciated.

Regards,

Mark.

May 11 '06 #3

P: n/a
You forgot to override OnPaintBackground so that it doesn't call the base
class didn't you... ;-)

--
Bob Powell [MVP]
Visual C#, System.Drawing

Ramuseco Limited .NET consulting
http://www.ramuseco.com

Find great Windows Forms articles in Windows Forms Tips and Tricks
http://www.bobpowell.net/tipstricks.htm

Answer those GDI+ questions with the GDI+ FAQ
http://www.bobpowell.net/faqmain.htm

All new articles provide code in C# and VB.NET.
Subscribe to the RSS feeds provided and never miss a new article.

"Mark Thompson" <ch****@dsl.pipex.com> wrote in message
news:11**********************@v46g2000cwv.googlegr oups.com...
I have a problem with my Visual Basic .NET 2003 application which I
have so far been unable to resolve.

I am trying to get an OpenGL control that I have created working
properly as a control on my main form in my VB.NET application. It does
work and render correctly but the problem is that there is an awful
flickering that happens on most PCs I try it on. The flickering is
reminiscent of the sort that you get on a TV when it is not tuned in
properly, i.e. portions of the background are visible in horizontal
bands that move up or down the control and make it pretty much
unusable.

Bizarrely though, on my laptop, if I Alt-Tab to another application
which moves in front of the flickering control and then Alt-Tab back to
my application then it is fine for a while. However, as soon as any
other dialog or message box appears in my application, or I resize it
then the flickering starts again. On two of my colleague's laptops
however, we get the flickering and no amount of moving things in front
of it makes any difference.

Also, when I remote desktop into my laptop from my PC, I do not see
this problem at all, i.e. the control behaves perfectly.

I am using an OpenGL wrapper library. I oringally tried using CsGL and
then I tried Tao (more recent and maintained library) for the control,
both have the same result.

The code I am using has a timer on the form which fires periodically to
force the refresh of the control. I have tried varying the periodicity
of this from 1ms right up to 1000ms but the flickering still happens.
With 1000ms it almost appears like as soon as the control is refreshed,
it disappears as with this periodicity it becomes almost invisible.

Does anyone have any ideas on this as it is driving me barmy now!

Thanks,

Mark.

May 11 '06 #4

P: n/a
Bob Powell [MVP] wrote:
You forgot to override OnPaintBackground so that it doesn't call the base
class didn't you... ;-)


Hi Bob,

Thanks for your help but unfortunately that does not fix it.

I had really high hopes that that would be it when I saw your post but
I have just spent the last hour trying it out. I have tried overriding
it in my OpenGL control. I have tried overriding it in the main form. I
have even tried overriding it in a Custom Panel class that I have which
is substituted for all the panels on the main form in case this was the
problem but to no avail in all cases.

I feel it has to be something simple like this though.

Any other ideas?

Thanks,

Mark.

May 12 '06 #5

P: n/a
I think that the best thing to do is concentrate on your OpenGL control.
Everything else is just noise.

Have you set the styes for AllPaintingInWMPaint and UserPaint ?

How are you drawing the OpenGL rendering. To the screen or to a bitmap?
Are you using double-buffering?

Are you using CreateGraphics anywhere?

The OnPaintBackground call in the OpenGL control should look like:

protected void OnPaintBackground(PaintEventArgs pe)
{
//Do nothing here...
}

Do not call base.OnPaintBackground in any part of your control.

If you like, e-mail me the OpenGL control source and I'll look it over.

--
Bob Powell [MVP]
Visual C#, System.Drawing

Ramuseco Limited .NET consulting
http://www.ramuseco.com

Find great Windows Forms articles in Windows Forms Tips and Tricks
http://www.bobpowell.net/tipstricks.htm

Answer those GDI+ questions with the GDI+ FAQ
http://www.bobpowell.net/faqmain.htm

All new articles provide code in C# and VB.NET.
Subscribe to the RSS feeds provided and never miss a new article.

"Mark Thompson" <ch****@dsl.pipex.com> wrote in message
news:11**********************@y43g2000cwc.googlegr oups.com...
Bob Powell [MVP] wrote:
You forgot to override OnPaintBackground so that it doesn't call the base
class didn't you... ;-)


Hi Bob,

Thanks for your help but unfortunately that does not fix it.

I had really high hopes that that would be it when I saw your post but
I have just spent the last hour trying it out. I have tried overriding
it in my OpenGL control. I have tried overriding it in the main form. I
have even tried overriding it in a Custom Panel class that I have which
is substituted for all the panels on the main form in case this was the
problem but to no avail in all cases.

I feel it has to be something simple like this though.

Any other ideas?

Thanks,

Mark.

May 12 '06 #6

P: n/a
Hi Bob,

I have tried to e-mail you at the one on your profile but that just
bounces back. Could you let me know what address to use?

I am at ch****@dsl.pipex.com by the way.

Thanks,

Mark.

May 15 '06 #7

This discussion thread is closed

Replies have been disabled for this discussion.