By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,244 Members | 1,772 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,244 IT Pros & Developers. It's quick & easy.

Timeout Calling Web Service

P: n/a
Timeout Calling Web Service

I am calling a .NET 1.1 web service from an aspx page. The web service can
take several minutes to complete its tasks before returning a message to the
aspx page.

If the web service is taking a long time to complete, the aspx page returns
a ‘The operation has timed-out.’ Message to the web browser after 100 seconds.

I’ve added: <httpRuntime executionTimeout="300" /> to the web.config files
of both the web application and web service, and set Server.ScriptTimeout
=300, but neither setting prevents the timeout.

My machine.config has executionTimeout="90".

Any thoughts on a solution would be appreciated

--
Mike
Nov 23 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Hi Mike,

Welcome to MSDN newsgroup.
From your description, you're calling an ASP.NET webservice from another
ASP.NET web application's aspx page. Since the WebService's method will
take long time to finish, you'll encounter timeout exception in the aspx
page. However, after you've configued the HttpRuntime executionTimeout and
ScriptTimeout property in web.config and code, you're stilling suffer this
timeout problem, yes?

As for this problem, here are two things we may check first:

1. For .net webservice , the client proxy (which derived from
SoapHttpClientProtocol) also contains a property named "Timeout" , have you
also configured this property in your code? If not, you can also try it (it
is in milliseconds...)

2. As for the ASP.NET page's HttpRuntime executionTimeout setting, it will
works as the configued value ( in machine.config or web.config...) when the
application is not under debug mode (<compilation debug="false" ...>) .
While in debug mode, the executionTimeout won't obey the configuration
setting. So please also verify this ...

Hope helps. Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


--------------------
| Thread-Topic: Timeout Calling Web Service
| thread-index: AcXo9FrV6RvfrvlYTxCerEOfYdtKdg==
| X-WBNR-Posting-Host: 80.6.93.157
| From: "=?Utf-8?B?TWlrZQ==?=" <op*****@newsgroups.nospam>
| Subject: Timeout Calling Web Service
| Date: Mon, 14 Nov 2005 00:21:04 -0800
| Lines: 19
| Message-ID: <36**********************************@microsoft.co m>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 8bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.public.dotnet.languages.vb
| NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGXA03.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl microsoft.public.dotnet.languages.vb:303882
| X-Tomcat-NG: microsoft.public.dotnet.languages.vb
|
| Timeout Calling Web Service
|
| I am calling a .NET 1.1 web service from an aspx page. The web service
can
| take several minutes to complete its tasks before returning a message to
the
| aspx page.
|
| If the web service is taking a long time to complete, the aspx page
returns
| a ‘The operation has timed-out.?Message to the web browser after 100
seconds.
|
| I’ve added: <httpRuntime executionTimeout="300" /> to the web.config
files
| of both the web application and web service, and set Server.ScriptTimeout
| =300, but neither setting prevents the timeout.
|
| My machine.config has executionTimeout="90".
|
| Any thoughts on a solution would be appreciated
|
| --
| Mike
|

Nov 23 '05 #2

P: n/a
Steven,

Increasing the timeout for the client proxy resolved the problem.

Thanks for your help.

--
Mike
"Steven Cheng[MSFT]" wrote:
Hi Mike,

Welcome to MSDN newsgroup.
From your description, you're calling an ASP.NET webservice from another
ASP.NET web application's aspx page. Since the WebService's method will
take long time to finish, you'll encounter timeout exception in the aspx
page. However, after you've configued the HttpRuntime executionTimeout and
ScriptTimeout property in web.config and code, you're stilling suffer this
timeout problem, yes?

As for this problem, here are two things we may check first:

1. For .net webservice , the client proxy (which derived from
SoapHttpClientProtocol) also contains a property named "Timeout" , have you
also configured this property in your code? If not, you can also try it (it
is in milliseconds...)

2. As for the ASP.NET page's HttpRuntime executionTimeout setting, it will
works as the configued value ( in machine.config or web.config...) when the
application is not under debug mode (<compilation debug="false" ...>) .
While in debug mode, the executionTimeout won't obey the configuration
setting. So please also verify this ...

Hope helps. Thanks,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)


--------------------
| Thread-Topic: Timeout Calling Web Service
| thread-index: AcXo9FrV6RvfrvlYTxCerEOfYdtKdg==
| X-WBNR-Posting-Host: 80.6.93.157
| From: "=?Utf-8?B?TWlrZQ==?=" <op*****@newsgroups.nospam>
| Subject: Timeout Calling Web Service
| Date: Mon, 14 Nov 2005 00:21:04 -0800
| Lines: 19
| Message-ID: <36**********************************@microsoft.co m>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 8bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.public.dotnet.languages.vb
| NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGXA03.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl microsoft.public.dotnet.languages.vb:303882
| X-Tomcat-NG: microsoft.public.dotnet.languages.vb
|
| Timeout Calling Web Service
|
| I am calling a .NET 1.1 web service from an aspx page. The web service
can
| take several minutes to complete its tasks before returning a message to
the
| aspx page.
|
| If the web service is taking a long time to complete, the aspx page
returns
| a ‘The operation has timed-out.�Message to the web browser after 100
seconds.
|
| I’ve added: <httpRuntime executionTimeout="300" /> to the web.config
files
| of both the web application and web service, and set Server.ScriptTimeout
| =300, but neither setting prevents the timeout.
|
| My machine.config has executionTimeout="90".
|
| Any thoughts on a solution would be appreciated
|
| --
| Mike
|

Nov 23 '05 #3

P: n/a
You're welcome Mike,

Good luck!

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)
--------------------
| Thread-Topic: Timeout Calling Web Service
| thread-index: AcXpKvtLqHnOQV/SRoi+nCnYi8y4ZQ==
| X-WBNR-Posting-Host: 80.6.93.157
| From: "=?Utf-8?B?TWlrZQ==?=" <op*****@newsgroups.nospam>
| References: <36**********************************@microsoft.co m>
<Wj**************@TK2MSFTNGXA02.phx.gbl>
| Subject: RE: Timeout Calling Web Service
| Date: Mon, 14 Nov 2005 06:52:06 -0800
| Lines: 98
| Message-ID: <95**********************************@microsoft.co m>
| MIME-Version: 1.0
| Content-Type: text/plain;
| charset="Utf-8"
| Content-Transfer-Encoding: 8bit
| X-Newsreader: Microsoft CDO for Windows 2000
| Content-Class: urn:content-classes:message
| Importance: normal
| Priority: normal
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| Newsgroups: microsoft.public.dotnet.languages.vb
| NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGXA03.phx.gbl
| Xref: TK2MSFTNGXA02.phx.gbl microsoft.public.dotnet.languages.vb:303942
| X-Tomcat-NG: microsoft.public.dotnet.languages.vb
|
| Steven,
|
| Increasing the timeout for the client proxy resolved the problem.
|
| Thanks for your help.
|
| --
| Mike
|
|
| "Steven Cheng[MSFT]" wrote:
|
| > Hi Mike,
| >
| > Welcome to MSDN newsgroup.
| > From your description, you're calling an ASP.NET webservice from
another
| > ASP.NET web application's aspx page. Since the WebService's method will
| > take long time to finish, you'll encounter timeout exception in the
aspx
| > page. However, after you've configued the HttpRuntime executionTimeout
and
| > ScriptTimeout property in web.config and code, you're stilling suffer
this
| > timeout problem, yes?
| >
| > As for this problem, here are two things we may check first:
| >
| > 1. For .net webservice , the client proxy (which derived from
| > SoapHttpClientProtocol) also contains a property named "Timeout" , have
you
| > also configured this property in your code? If not, you can also try it
(it
| > is in milliseconds...)
| >
| > 2. As for the ASP.NET page's HttpRuntime executionTimeout setting, it
will
| > works as the configued value ( in machine.config or web.config...) when
the
| > application is not under debug mode (<compilation debug="false" ...>) .
| > While in debug mode, the executionTimeout won't obey the configuration
| > setting. So please also verify this ...
| >
| > Hope helps. Thanks,
| >
| > Steven Cheng
| > Microsoft Online Support
| >
| > Get Secure! www.microsoft.com/security
| > (This posting is provided "AS IS", with no warranties, and confers no
| > rights.)
| >
| >
| >
| >
| > --------------------
| > | Thread-Topic: Timeout Calling Web Service
| > | thread-index: AcXo9FrV6RvfrvlYTxCerEOfYdtKdg==
| > | X-WBNR-Posting-Host: 80.6.93.157
| > | From: "=?Utf-8?B?TWlrZQ==?=" <op*****@newsgroups.nospam>
| > | Subject: Timeout Calling Web Service
| > | Date: Mon, 14 Nov 2005 00:21:04 -0800
| > | Lines: 19
| > | Message-ID: <36**********************************@microsoft.co m>
| > | MIME-Version: 1.0
| > | Content-Type: text/plain;
| > | charset="Utf-8"
| > | Content-Transfer-Encoding: 8bit
| > | X-Newsreader: Microsoft CDO for Windows 2000
| > | Content-Class: urn:content-classes:message
| > | Importance: normal
| > | Priority: normal
| > | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
| > | Newsgroups: microsoft.public.dotnet.languages.vb
| > | NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
| > | Path: TK2MSFTNGXA02.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFT NGXA03.phx.gbl
| > | Xref: TK2MSFTNGXA02.phx.gbl
microsoft.public.dotnet.languages.vb:303882
| > | X-Tomcat-NG: microsoft.public.dotnet.languages.vb
| > |
| > | Timeout Calling Web Service
| > |
| > | I am calling a .NET 1.1 web service from an aspx page. The web
service
| > can
| > | take several minutes to complete its tasks before returning a message
to
| > the
| > | aspx page.
| > |
| > | If the web service is taking a long time to complete, the aspx page
| > returns
| > | a ‘The operation has timed-out.â?Message to the web browser
after 100
| > seconds.
| > |
| > | I’ve added: <httpRuntime executionTimeout="300" /> to the
web.config
| > files
| > | of both the web application and web service, and set
Server.ScriptTimeout
| > | =300, but neither setting prevents the timeout.
| > |
| > | My machine.config has executionTimeout="90".
| > |
| > | Any thoughts on a solution would be appreciated
| > |
| > | --
| > | Mike
| > |
| >
| >
|

Nov 23 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.