By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,033 Members | 1,952 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,033 IT Pros & Developers. It's quick & easy.

Replacing RPM with Source Install

P: n/a
I've got a machine running Yellow Dog Linux (a PPC version of Red Hat) which has
Python 1.5.2-35a and I'd like to update.

I'd prefer to install from sources rather than depend on other people to release
RPMs but I have a little question.

My first instinct was to remove the RPM version of Python but I got a whole
screenful of dependency warnings (see below). How should I proceed? Should I go
ahead and yank the RPM-based Python and then compile/install the new version or
should I try to keep both installations?

--Richard

[root@g3server ~] rpm -e python
error: removing these packages would break dependencies:
python = 1.5.2 is needed by python-devel-1.5.2-35a
python >= 1.5.2 is needed by pygtk-0.6.8-3
python = 1.5.2 is needed by python-tools-1.5.2-35a
python is needed by PyXML-0.6.5-4
python is needed by 4Suite-0.11-2
python = 1.5.2 is needed by tkinter-1.5.2-35a
python >= 1.5.2-27 is needed by python-xmlrpc-1.5.1-7.x.3
python is needed by dateconfig-0.7.4-6
python is needed by mx-2.0.1-1
python is needed by postgresql-python-7.2-2a
python >= 1.5.2 is needed by rpm-python-4.0.3-1.03a
python >= 1.5.2 is needed by yup-0.7.6-8a
python >= 1.5.2 is needed by apacheconf-0.8.1-1
python >= 1.5.2 is needed by bindconf-1.6.1-1
python is needed by fetchmailconf-5.9.0-11
python is needed by printconf-0.3.61-4.1
/usr/bin/python is needed by gettext-0.10.40-4
/usr/bin/python is needed by PyXML-0.6.5-4
/usr/bin/python is needed by 4Suite-0.11-2
/usr/bin/python is needed by alchemist-1.0.18-1
/usr/bin/python is needed by yup-0.7.6-8a
/usr/bin/python is needed by gnome-core-1.4.0.4-38a
/usr/bin/python is needed by bindconf-1.6.1-1
/usr/bin/python is needed by kdelibs-2.2.2-2a
/usr/bin/python is needed by printconf-0.3.61-4.1
/usr/bin/python is needed by printconf-gui-0.3.61-4.1
Jul 18 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Richard Petty <re**********@austin.rr.com> writes:
My first instinct was to remove the RPM version of Python but I got
a whole screenful of dependency warnings (see below). How should I
proceed? Should I go ahead and yank the RPM-based Python and then
compile/install the new version or should I try to keep both
installations?


I'd recommended installing the new version separately, setting your
PATH variable to use it, and leaving the system version of python
unchanged.

You can compile and install new versions of python in independent
directories, such as /opt/python-2.3.3, with a command like:

./configure --prefix=/opt/python-2.3.3

See the README in the source for details.

--
Brian Gough

Network Theory Ltd,
Publishing the Python Manuals --- http://www.network-theory.co.uk/
Jul 18 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.