473,706 Members | 2,393 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

Install problem on AIX

I am installing Python 2.3.2 on AIX 4.3.3

I get to the point where I'm ready to "make install" and I get an
error, with no idea how to get around it.

Here's the tail end of the output:

Compiling /usr/local/lib/python2.3/xml/sax/saxutils.py ...
Compiling /usr/local/lib/python2.3/xml/sax/xmlreader.py ...
Compiling /usr/local/lib/python2.3/xmllib.py ...
Compiling /usr/local/lib/python2.3/xmlrpclib.py ...
Compiling /usr/local/lib/python2.3/zipfile.py ...
make: 1254-004 The error code from the last command is 1.

We tracked it down to a script called compileall.py or something close
to that which seems to be doing the "Compiling"
Jul 18 '05 #1
2 2068
In article <a3************ **************@ posting.google. com>,
ch********@yaho o.com (Chris Hadley) wrote:
I am installing Python 2.3.2 on AIX 4.3.3

I get to the point where I'm ready to "make install" and I get an
error, with no idea how to get around it.

Here's the tail end of the output:

Compiling /usr/local/lib/python2.3/xml/sax/saxutils.py ...
Compiling /usr/local/lib/python2.3/xml/sax/xmlreader.py ...
Compiling /usr/local/lib/python2.3/xmllib.py ...
Compiling /usr/local/lib/python2.3/xmlrpclib.py ...
Compiling /usr/local/lib/python2.3/zipfile.py ...
make: 1254-004 The error code from the last command is 1.

We tracked it down to a script called compileall.py or something close
to that which seems to be doing the "Compiling"


Have no idea.

Was that output redirected to disk? Python's build
software can buffer a lot of output, and on exit due
to error, that output all comes out and kind of obscures
the issue, because it's out of order. It follows
external output that was not buffered. I note that
zipfile.py just happens to be the last of the .py files,
and it probably didn't have a thing to do with the failure.
More likely you have some C component like curses that
never built and you couldn't see it.

When it's feasible, I try to suppress my normal reflex to
redirect build output, and just paste it into a disk file
afterwards. Configure with CC=cc, --with-cxx=no.

Donn Cave, do**@u.washingt on.edu
Jul 18 '05 #2
Hi Donn,

Thanks for your reply.

I thought that having the 2.3b2 already installed may be causing
problems so I modified the makefile version to be 2.3.2 instead of 2.3
which caused the make install to go to the /usr/local/lib/python2.3.2
directory. This seems to have worked. The make install completed.
Jul 18 '05 #3

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

0
1471
by: Yun Guan | last post by:
Hello mysql gurus, I am trying to run perl on mysql database on Red Hat box. I want to install DBI and DBD:mysql using CPAN: perl -MCPAN -e shell cpan>install DBI The above succeeded, but cpan>install DBD::mysql
1
1864
by: Peter Hartmann | last post by:
How do I influence the platform type during install? Could you look at this and tell me what I'm doing wrong? It's still using information from get_platform instead of using my preference. # python setup.py install --install-purelib=lib.linux=i686-2.3 --install-lib=/usr/lib/python2.3/site-packages running install running build running build_py
3
56997
by: Jeremy S. | last post by:
On my dev machine (XP/Pro with VS.NET 2003) I have been developing a Windows Service and installing it on the local machine by opening the Visual Studio Command Prompt and then executing . Now I want to test this service on a Windows Server 2003 box that doesn't have the Visual Studio Command prompt. How do I go about installing the service on the Windows Server 2003 box? Thanks!
7
5014
by: p | last post by:
WE had a Crystal 8 WebApp using vs 2002 which we upgraded to VS2003. I also have Crystal 9 pro on my development machine. The web app runs fine on my dev machine but am having problems deploying. I created the websetup and built the MSI, have the bundled version. Copied to webserver and ran Websetup.msi. Said I had to remove old version, which I did, then reran WebSetup.msi and keeps giving me this error. "The installer was interrupted...
12
1588
by: Matt Fielder | last post by:
I tried to install SP1, and it appears to have just stopped somewhere part way through. It was "collecting information" (for a long time, slow progress bar) --- then suddenly it stopped.... no indication that either something went wrong, it completed, or still running in the background. I let it sit for another 30 minutes in case it was chugging along with no UI, which I didn't think likely without as cpu usage stayed near zero as did...
5
7710
by: Ajith Menon | last post by:
I have to install .NET framework 3.0. I already have .NET Framework 1.1 installed on my machine. I don't want to remove framework 1.1 since some of the critical applications are using it. While installing .NET framework 3.0 I got the error: "Microsoft .NET Framework 3.0 x86 has encountered a problem during setup. Setup did not complete correctly." Error Signature:
3
4261
by: Jason Madison | last post by:
My SP1 install seemed to want to keep repeating the install. I spent 4 hours running the install, then it ran again (I got the message up saying it had finished, then it started again). I didn't realise what it was doing until after about 30 minutes, and at that point I thought cancelling might actually undo the original install, so I let it run again (total install time at this point 8 hours!), I got the install finished message and when...
1
3458
by: Sorin Schwimmer | last post by:
Hi All, After a disaster in which I lost my whole harddrive, I decided to install the newest everything that I use. I put the latest Gentoo Linux, with gcc 4.1.1, installed tcl/tk 8.4.14 and tried Python 2.5. I tried with and without the suggested -fwrapv compiler option, and make gave me the same:
1
20380
by: =?Utf-8?B?Qi5BaGxzdGVkdA==?= | last post by:
Hi all, This is something that I have been toying with for about a week now. What I want to achieve is Install a Service with Customised parameters (using InstallUtil.exe) for User Name. Example (C#); public class MyServiceInstaller : System.Configuration.Install.Installer { private System.ServiceProcess.ServiceProcessInstaller serviceProcessInstaller;
3
11370
by: Jean-Marc Blaise | last post by:
Hi, I've been trying for 2 hours to install in silent mode a DB2 9 runtime client. Why didn't you make this process as simple as for the CLIENT install ? It is not the same setup command, you can download a setup from the support site, but unfortunately, the setup does not allow you to create a response file. Neither the db2rspgn utility, after the graphical setup has been done. Very disapointing ... maybe can someone highlight the...
0
8697
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language synchronization. With a Microsoft account, language settings sync across devices. To prevent any complications,...
0
9286
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
0
8997
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
1
6615
isladogs
by: isladogs | last post by:
The next Access Europe User Group meeting will be on Wednesday 1 May 2024 starting at 18:00 UK time (6PM UTC+1) and finishing by 19:30 (7.30PM). In this session, we are pleased to welcome a new presenter, Adolph Dupré who will be discussing some powerful techniques for using class modules. He will explain when you may want to use classes instead of User Defined Types (UDT). For example, to manage the data in unbound forms. Adolph will...
0
5939
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert into image. Globals.ThisAddIn.Application.ActiveDocument.Select();...
0
4453
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in the same network. But I'm wondering if it's possible to do the same thing, with 2 Pfsense firewalls...
1
3149
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system
2
2502
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.
3
2095
bsmnconsultancy
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating effective websites that not only look great but also perform exceptionally well. In this comprehensive...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.