473,698 Members | 2,274 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

Solaris 9, problem building Python 2.1.1

Ok before I start, please dont mail me telling me to use a more recent version of Python, I _would_ use 2.2.x but due to an existing framework all based on using 2.1.1 I have been specifically told to use 2.1.1 to avoid any crossover issues/problems.
Thanks ;-)

So ...

Using gcc Im compiling Python2.1.1, and it configures quite reasonably,
the ./configure is trascribed at the bottom of this email.

now once I have done that I compile it using make and it compiles just fine.
But once I start up the interpreter and 'import socket' I get the following error :
Traceback (most recent call last):
File "<stdin>", line 1, in ?
File "/usr/local/lib/python2.1/socket.py", line 41, in ?
from _socket import *
ImportError: ld.so.1: python2.1: fatal: libssl.so.0.9.6 : open failed: No such file or directory

Now Ive looked through comp.lang.pytho n for anything matching this, or solaris, etc but have come up pretty blank.

Has anyone got any good news or ideas for me on this ?
Cheers
Dave

Transcription of ./configure
*************** *************** ***********
creating cache ./config.cache
checking MACHDEP... sunos5
checking for --without-gcc... no
checking for --with-cxx=<compiler>. .. no
checking for c++... c++
checking whether the C++ compiler (c++ ) works... yes
checking whether the C++ compiler (c++ ) is a cross-compiler... no
checking for gcc... gcc
checking whether the C compiler (gcc ) works... yes
checking whether the C compiler (gcc ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for Cygwin environment... no
checking for mingw32 environment... no
checking for executable suffix... no
checking for --with-suffix...
checking LIBRARY... libpython$(VERS ION).a
checking LINKCC... $(PURIFY) $(CC)
checking LDLIBRARY... libpython$(VERS ION).a
checking for ranlib... ranlib
checking for ar... ar
checking for a BSD compatible install... /usr/local/bin/install -c
checking how to run the C preprocessor... gcc -E
checking for AIX... no
checking for minix/config.h... no
checking whether gcc accepts -OPT:Olimit=0... no
checking whether gcc accepts -Olimit 1500... no
checking for ANSI C header files... yes
checking for dlfcn.h... yes
checking for fcntl.h... yes
checking for limits.h... yes
checking for locale.h... yes
checking for ncurses.h... yes
checking for poll.h... yes
checking for pthread.h... yes
checking for signal.h... yes
checking for stdarg.h... yes
checking for stddef.h... yes
checking for stdlib.h... yes
checking for thread.h... yes
checking for unistd.h... yes
checking for utime.h... yes
checking for termios.h... yes
checking for sys/audioio.h... yes
checking for sys/file.h... yes
checking for sys/lock.h... yes
checking for sys/modem.h... no
checking for db_185.h... no
checking for db.h... no
checking for sys/param.h... yes
checking for sys/poll.h... yes
checking for sys/select.h... yes
checking for sys/socket.h... yes
checking for sys/time.h... yes
checking for sys/times.h... yes
checking for sys/un.h... yes
checking for sys/utsname.h... yes
checking for sys/wait.h... yes
checking for pty.h... no
checking for libutil.h... no
checking for ndbm.h... yes
checking for db1/ndbm.h... no
checking for gdbm/ndbm.h... no
checking for sys/resource.h... yes
checking for dirent.h that defines DIR... yes
checking for opendir in -ldir... no
checking for clock_t in time.h... yes
checking for mode_t... yes
checking for off_t... yes
checking for pid_t... yes
checking return type of signal handlers... void
checking for size_t... yes
checking for uid_t in sys/types.h... yes
checking size of int... 4
checking size of long... 4
checking size of void *... 4
checking size of char... 1
checking size of short... 2
checking size of float... 4
checking size of double... 8
checking size of fpos_t... 4
checking for long long support... yes
checking size of long long... 8
checking for uintptr_t support... no
checking size of off_t... 4
checking whether to enable large file support... no
checking size of time_t... 4
checking for pthread_t... yes
checking size of pthread_t... 4
checking for --with-next-framework... no
checking for --with-dyld... no
checking SO... .so
checking LDSHARED... $(CC) -shared
checking CCSHARED... -fPIC
checking LINKFORSHARED.. .
checking CFLAGSFORSHARED ...
checking for dlopen in -ldl... yes
checking for shl_load in -ldld... no
checking for --with-pydebug... no
checking for t_open in -lnsl... yes
checking for socket in -lsocket... yes
checking for --with-libs... no
checking for --with-signal-module... yes
checking for --with-dec-threads... no
checking for --with-threads... yes
checking for mach/cthreads.h... no
checking for --with-pth... no
checking for pthread_create in -lpthread... yes
checking for usconfig in -lmpc... no
checking for thr_create in -lthread... yes
checking for --with-cycle-gc... yes
checking for --with-pymalloc... no
checking for --with-wctype-functions... no
checking for --with-sgi-dl... no
checking for --with-dl-dld... no
checking for dlopen... yes
checking DYNLOADFILE... dynload_shlib.o
checking for alarm... yes
checking for chown... yes
checking for clock... yes
checking for confstr... yes
checking for ctermid... yes
checking for ctermid_r... yes
checking for execv... yes
checking for flock... no
checking for fork... yes
checking for fsync... yes
checking for fdatasync... no
checking for fpathconf... yes
checking for ftime... yes
checking for ftruncate... yes
checking for getgroups... yes
checking for getlogin... yes
checking for getpeername... yes
checking for getpid... yes
checking for getpwent... yes
checking for getwd... yes
checking for kill... yes
checking for link... yes
checking for lstat... yes
checking for mkfifo... yes
checking for mktime... yes
checking for mremap... no
checking for nice... yes
checking for pathconf... yes
checking for pause... yes
checking for plock... yes
checking for poll... yes
checking for pthread_init... no
checking for putenv... yes
checking for readlink... yes
checking for select... yes
checking for setegid... yes
checking for seteuid... yes
checking for setgid... yes
checking for setlocale... yes
checking for setregid... yes
checking for setreuid... yes
checking for setsid... yes
checking for setpgid... yes
checking for setuid... yes
checking for setvbuf... yes
checking for sigaction... yes
checking for siginterrupt... yes
checking for sigrelse... yes
checking for strftime... yes
checking for strptime... yes
checking for symlink... yes
checking for sysconf... yes
checking for tcgetpgrp... yes
checking for tcsetpgrp... yes
checking for tempnam... yes
checking for timegm... no
checking for times... yes
checking for tmpfile... yes
checking for tmpnam... yes
checking for tmpnam_r... yes
checking for truncate... yes
checking for uname... yes
checking for waitpid... yes
checking for _getpty... no
checking for getpriority... yes
checking for openpty... no
checking for openpty in -lutil... no
checking for forkpty... no
checking for forkpty in -lutil... no
checking for fseek64... no
checking for fseeko... yes
checking for fstatvfs... yes
checking for ftell64... no
checking for ftello... yes
checking for statvfs... yes
checking for dup2... yes
checking for getcwd... yes
checking for strdup... yes
checking for strerror... yes
checking for memmove... yes
checking for getpgrp... yes
checking for setpgrp... yes
checking for gettimeofday... yes
checking whether time.h and sys/time.h may both be included... yes
checking whether struct tm is in sys/time.h or time.h... time.h
checking for tm_zone in struct tm... no
checking for tzname... yes
checking for time.h that defines altzone... yes
checking whether sys/select.h and sys/time.h may both be included... yes
checking whether char is unsigned... no
checking for working const... yes
checking for working volatile... yes
checking for working signed char... yes
checking for prototypes... yes
checking for variable length prototypes and stdarg.h... yes
checking for bad exec* prototypes... no
checking for bad static forward... no
checking whether va_list is an array... no
checking for gethostbyname_r ... yes
checking gethostbyname_r with 6 args... no
checking gethostbyname_r with 5 args... yes
checking for __fpu_control.. . no
checking for __fpu_control in -lieee... no
checking for --with-fpectl... no
checking for --with-libm=STRING... default LIBM="-lm"
checking for --with-libc=STRING... default LIBC=""
checking for hypot... yes
checking what malloc(0) returns... null
checking for wchar.h... yes
checking for usable wchar_t... no
checking whether byte ordering is bigendian... yes
checking whether right shift extends the sign bit... yes
checking for getc_unlocked() and friends... yes
checking for rl_completion_m atches in -lreadline... no
checking for broken nice()... no
checking for socklen_t... yes
checking for build directories... done
updating cache ./config.cache
creating ./config.status
creating Makefile.pre
creating Modules/Setup.config
creating config.h
creating Setup
creating Setup.local
creating Makefile
*************** *************** ***********

Jul 18 '05 #1
0 2100

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

1
2390
by: Mark Nelson | last post by:
Hi I'm trying to build Imaging 1.1.4 in Solaris 9, I get passwd the first step i.e the building of libImging. However when I execute a python setup.py build I get the following error - gcc -shared build/temp.solaris-2.9-sun4u-2.2/_imaging.o build/temp.solaris-2.9-s un4u-2.2/decode.o build/temp.solaris-2.9-sun4u-2.2/encode.o build/temp.solaris-2 ..9-sun4u-2.2/map.o build/temp.solaris-2.9-sun4u-2.2/display.o build/temp.solaris...
2
2594
by: Skip Montanaro | last post by:
I'm trying to build the released version of Python 2.3 on Solaris 8 for the first time. It has problems when building _ssl.so. The command generated is gcc -shared build/temp.solaris-2.8-sun4u-2.3/_ssl.o \ -L/usr/local/ssl/lib -L/usr/local/lib -lssl -lcrypto \ -o build/lib.solaris-2.8-sun4u-2.3/_ssl.so
2
2215
by: John Ky | last post by:
Hello: Building Python works fine. Now I am trying to build my own python module on Solaris 9, but I'm getting the following conflict: In file included from /wrk/src/test/tools/local/include/python2.2/Python.h:62, from elxml.cpp:20: /wrk/src/test/tools/local/include/python2.2/pyport.h:333: declaration of C function `int gethostname(char*, int)' conflicts with
0
1147
by: Rob Boyd | last post by:
Hi, I am having problems building Python 2.3.3 on Solaris 9, on a SunFire SPARC. I am using gcc 3.3.2, and apparently don't have binutils (but have ld, as, ar, and the like). I have set LD_RUN_PATH appropriately. During 'make', I get many warnings such as: "WARNING: renaming "regex" since importing it failed: ld.so.1: ./python: fatal: libgcc_s.so.1: open failed:
0
2001
by: Bob Swerdlow | last post by:
I'm trying to install MySQLdb 0.9.2 so I can access my MySQL database from python under Solaris 8. I found the notes on changing the include and lib paths and it seems to find them okay, but when I run 'python setup.py build', I get these errors: .... building '_mysql' extension creating build/temp.solaris-2.8-sun4u-2.3 gcc -fno-strict-aliasing -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -fPIC -I/ usr/include/mysql...
1
2725
by: Bob Swerdlow | last post by:
I'm having trouble getting Python 2.3.4 installed properly on Solaris 8. First some configuration stuff: bash-2.05# export . . . declare -x HOSTTYPE="sparc" declare -x MACHTYPE="sparc-sun-solaris2.8" declare -x OSTYPE="solaris2.8" I copied Python-2.3.4.tgz to /var/tmp, ran gunzip and tar xvf then
3
3711
by: skip | last post by:
I'm having no success building the curses module on Solaris 8 (yes, I know it's ancient - advancing the state-of-the-art is not yet an option) for Python 2.4. Sun provides an apparently ancient version of curses in /usr/lib, so I downloaded and installed ncurses 5.5, both using default settings and using --with-shared. When the curses module is linked against libcurses.so I get some strange error about acs32map being undefined (which...
2
2156
by: kepioo | last post by:
Hi all, I am trying to install PIL with python 2.3 on solaris X86, but I get this error message : building '_imaging' extension creating build/temp.solaris-2.10-i86pc-2.3 creating build/temp.solaris-2.10-i86pc-2.3/libImaging /sgnome/tools/x86-solaris/forte/SOS8/SUNWspro/bin/cc -i -xO4 -xspace -xstrconst -xpentium -mr -DANSICPP -D__STDC_VERSION__=199409L -DNDEBUG
7
4345
by: plumb and tree | last post by:
I've been trying for days to build 64 bit python with Solaris 10 + Sun Studio 12. Can anyone helpl please. This is how I tried to do build: # ./configure --prefix=/opt/python2.4 --without-gcc --enable-shared checking MACHDEP... sunos5 checking EXTRAPLATDIR...
0
1801
by: mg | last post by:
When make gets to the _ctypes section, I am getting the following in my output: building '_ctypes' extension creating build/temp.solaris-2.10-i86pc-2.5/home/ecuser/Python-2.5.1/ Modules/_ctypes creating build/temp.solaris-2.10-i86pc-2.5/home/ecuser/Python-2.5.1/ Modules/_ctypes/libffi creating build/temp.solaris-2.10-i86pc-2.5/home/ecuser/Python-2.5.1/ Modules/_ctypes/libffi/src
0
8672
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main usage, and What is the difference between ONU and Router. Let’s take a closer look ! Part I. Meaning of...
0
8600
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language synchronization. With a Microsoft account, language settings sync across devices. To prevent any complications,...
0
9021
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that captivates audiences and drives business growth. The Art of Business Website Design Your website is...
1
8892
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
0
8860
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
0
7712
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project—planning, coding, testing, and deployment—without human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then launch it, all on its own.... Now, this would greatly impact the work of software developers. The idea...
1
3038
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system
2
2323
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.
3
1998
bsmnconsultancy
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating effective websites that not only look great but also perform exceptionally well. In this comprehensive...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.