By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,287 Members | 1,644 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,287 IT Pros & Developers. It's quick & easy.

rpm problem

P: 13
I have run the following rpm command:

rpm -ivh php-gd-5.2.6-2.i386.rpm

I got these errors:

error: Failed dependencies:

libc.so.6 (GLIBC_2.4) is needed by php-gd-5.2.6-2.i386.rpm
libpng12.so.0 (PNG12_0) is needed by php-gd-5.2.6-2.i386.rpm
php-common = 5.2.6-2 is needed by php-gd-5.2.6-2.i386.rpm
rtld (GNU_HAS) is needed by php-gd-5.2.6-2.i386.rpm

BUT I am sure that libc.so.6 and libpng12.so.0 are located in the same directory where I ran the rpm command. How come rpm cannot recognize the dependencies files even though they are in the same location? Please help to solve the problem. Thanks a lot.


Regards,
Apr 28 '10 #1
Share this Question
Share on Google+
1 Reply


chathura86
100+
P: 227
i think those files should be installed in the lib /usr/lib folder

you can use
yum install php-gd-5.2.6-2.i386.rpm to install the rpm with yum
if that also failed search for rpms which contains those missing so files and install them

you can also try
yum install php-gd also to install it with repo

Regards
Apr 28 '10 #2

Post your reply

Sign in to post your reply or Sign up for a free account.