By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,747 Members | 2,039 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,747 IT Pros & Developers. It's quick & easy.

File uploads with PHP

P: n/a
I'm writing an uploading page for a website I'm working on. This
website will hopefully allow users to upload files of up to 100MB in
size. The web administrator has increased all the limiting variablies
in php.ini such as:

post_max_size = 150M
upload_max_filesize = 150M
max_execution_time = 600

MAX_FILE_SIZE within the uploading form is also set to 150MB.

However if I try to upload a file greater then 20MB from a PC within
my companys office i get an error message saying that the request is
too large for our web cache. I'm also told that if other users have a
web cache between them and their internet connection they could
experience the same problem.

Does anyone know a way round this problem? Is it possible to bypass
the web cache somehow so that this dosent happen?
Jul 17 '05 #1
Share this Question
Share on Google+
7 Replies


P: n/a

"Gefster" <ge*****@msn.com> wrote in message
news:e8**************************@posting.google.c om...
I'm writing an uploading page for a website I'm working on. This
website will hopefully allow users to upload files of up to 100MB in
size. The web administrator has increased all the limiting variablies
in php.ini such as:

post_max_size = 150M
upload_max_filesize = 150M
max_execution_time = 600

MAX_FILE_SIZE within the uploading form is also set to 150MB.

However if I try to upload a file greater then 20MB from a PC within
my companys office i get an error message saying that the request is
too large for our web cache. I'm also told that if other users have a
web cache between them and their internet connection they could
experience the same problem.

Does anyone know a way round this problem? Is it possible to bypass
the web cache somehow so that this dosent happen?


You need to tell your web cache to increase its upload limit.

If it's Squid, go change your squid.conf (if that's what you use) and alter
request_body_max_size to 0.

HTH
Garp
Jul 17 '05 #2

P: n/a
"Gefster" <ge*****@msn.com> schrieb im Newsbeitrag
news:e8**************************@posting.google.c om...
I'm writing an uploading page for a website I'm working on. This
website will hopefully allow users to upload files of up to 100MB in
size. The web administrator has increased all the limiting variablies
in php.ini such as:

post_max_size = 150M
upload_max_filesize = 150M
max_execution_time = 600

MAX_FILE_SIZE within the uploading form is also set to 150MB.

However if I try to upload a file greater then 20MB from a PC within
my companys office i get an error message saying that the request is
too large for our web cache. I'm also told that if other users have a
web cache between them and their internet connection they could
experience the same problem.

Does anyone know a way round this problem? Is it possible to bypass
the web cache somehow so that this dosent happen?


I don't think that HTTP POST is a good way to upload big files, as it does
not give any status bar or whatever and confuses the user even if you manage
to pass the whole files through all the bottlenecks.

I would suggest you to provide an FTP link to the target directory and tell
your users to use Internet Explorer as an FTP client to upload the files
(this is very easy).

HTH
Markus
Jul 17 '05 #3

P: n/a
> You need to tell your web cache to increase its upload limit.

If it's Squid, go change your squid.conf (if that's what you use) and alter
request_body_max_size to 0.

HTH
Garp


Ok that sounds good for my situation from within the company network
but what about users who are behind their own web cache? Is there
anything I can do to bypass their cache or are all types of upload
made them limited by their cache size?
Jul 17 '05 #4

P: n/a
That would be a good solution... there's only one problem. The files
for uploading need to be secure so ftp is not secure enough. A 3rd
party sftp client is needed as IE etc doesnt support this as far as i
know. Also the users dont have administrator rights on thier PCs so
they are unable to install the sftp client!! It's a tricky one this.

Unfortunatly https seems to me to be the only way to do it. Unless
someone knows of another.
Jul 17 '05 #5

P: n/a
"Gefster" <ge*****@msn.com> wrote in message
news:e8**************************@posting.google.c om...
That would be a good solution... there's only one problem. The files
for uploading need to be secure so ftp is not secure enough. A 3rd
party sftp client is needed as IE etc doesnt support this as far as i
know. Also the users dont have administrator rights on thier PCs so
they are unable to install the sftp client!! It's a tricky one this.

Unfortunatly https seems to me to be the only way to do it. Unless
someone knows of another.


See www.webdav.org.
Jul 17 '05 #6

P: n/a
WEBDAV could be the answer then. I've heard that this approach may
also suffer from the web cache upload limit. Is that the case?
Jul 17 '05 #7

P: n/a
On Mon, 19 Jul 2004 04:30:56 -0700, Gefster wrote:
WEBDAV could be the answer then. I've heard that this approach may
also suffer from the web cache upload limit. Is that the case?

No, the answer is Apples _obviously_!

Confused? ;)

Regards,

Ian
PS: Here's a free clue.... learn how to snip and post correctly.

--
Ian.H
digiServ Network
London, UK
http://digiserv.net/

Jul 17 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.