470,870 Members | 1,396 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,870 developers. It's quick & easy.

form errors between php/html

I have a page that people (without technical knowledge) can upload and
change news web links (via the php script) dynamically. It has worked fine
on our other server, but this week we changed servers and now it doesnt.
What it is doing is replicating the links (in no order - its not like my var
is just getting duplicated) so that there are many duplicate links, but not
all of them are. The links are stored in a textarea and when the form is
submitted, the links get messed up. i have 2 other pages that are doing the
same thing. (they arent links. they are just text) if i click submit,(it
submits to it's self) it takes the good links and runs it through a php
function where the are recorded in a database. then the form is refreashed
and the links go bad. when i comment out the recording part, just going to
an empty function still makes it do it. If i just hit the refreash button in
the browser, it doesnot occur. i am stumped as to why this is occuring. it
is not a special char in the list itself. i think the problem has to do with
when the form is submitted, the data is changed.
Jul 17 '05 #1
2 1412
In article <c7**********@news-int.gatech.edu>, Brad Esclavon wrote:

[snip story on a problem]

I'm affraid nobody will be able to help you if you don't code...

--
http://home.mysth.be/~timvw
Jul 17 '05 #2
http://host107.ipowerweb.com/~madpundi/bad.php
here is the link to the source. i made a submit button that does nothing,
other than submit and refreash the form. when you click it, it makes the
"link1" textarea data go bad.

"Brad Esclavon" <gt*****@mail.gatech.edu> wrote in message
news:c7**********@news-int.gatech.edu...
I have a page that people (without technical knowledge) can upload and
change news web links (via the php script) dynamically. It has worked fine
on our other server, but this week we changed servers and now it doesnt.
What it is doing is replicating the links (in no order - its not like my var is just getting duplicated) so that there are many duplicate links, but not all of them are. The links are stored in a textarea and when the form is
submitted, the links get messed up. i have 2 other pages that are doing the same thing. (they arent links. they are just text) if i click submit,(it
submits to it's self) it takes the good links and runs it through a php
function where the are recorded in a database. then the form is refreashed
and the links go bad. when i comment out the recording part, just going to
an empty function still makes it do it. If i just hit the refreash button in the browser, it doesnot occur. i am stumped as to why this is occuring. it
is not a special char in the list itself. i think the problem has to do with when the form is submitted, the data is changed.

Jul 17 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by R. Rajesh Jeba Anbiah | last post: by
9 posts views Thread by julie.siebel | last post: by
9 posts views Thread by whisher | last post: by
2 posts views Thread by bcanter | last post: by
3 posts views Thread by underground | last post: by
1 post views Thread by William Gill | last post: by
12 posts views Thread by Geoff Cox | last post: by
1 post views Thread by Lelu | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.