By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,204 Members | 1,161 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,204 IT Pros & Developers. It's quick & easy.

Installation problem: apxs not found

P: n/a
Hi

I'm new to PHP. I have a RHLinux 9 box running Apache httpd 2.0.40 and MySQL
Ver 12.18 Distrib 4.0.12.

I downloaded PHP 4.3.4 (tar.gz) [4,522Kb] - 03 November 200 and tried

$ ./configure --with-mysql --with-apxs

mod_so.c is present and "compiled-in".

This is what I get:

[root@linux php-4.3.4]# ./configure --with-mysql --with-apxs
loading cache ./config.cache
checking host system type... i686-pc-linux-gnu
checking for gcc... gcc
checking whether the C compiler (gcc ) works... yes
checking whether the C compiler (gcc ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking whether gcc and cc understand -c and -o together... yes
checking how to run the C preprocessor... gcc -E
checking for AIX... no
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking for re2c... exit 0;
checking for ranlib... ranlib
checking whether ln -s works... yes
checking for gawk... gawk
checking for bison... bison -y
checking bison version... 1.35 (ok)
checking for flex... flex
checking for yywrap in -lfl... yes
checking lex output file root... lex.yy
checking whether yytext is a pointer... yes
checking for working const... yes
checking flex version... 2.5.4 (ok)
checking for pthreads_cflags... -pthread
checking for pthreads_lib...

Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS...

Sorry, I was not able to successfully run APXS. Possible reasons:

1. Perl is not installed;
2. Apache was not compiled with DSO support (--enable-module=so);
3. 'apxs' is not in your path. Try to use --with-apxs=/path/to/apxs
The output of apxs follows
../configure: line 3169: apxs: command not found
configure: error: Aborting
Perl is installed. Neither 'whereis' or 'Find files' reveals any path to
apxs, so I guess I don't have it installed. What should I do to install
PHP?

Thanks for your patience,

JR
Jul 17 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
jon rogers <jo********@tv.tu> wrote:
Hi

I'm new to PHP. I have a RHLinux 9 box running Apache httpd 2.0.40 and
MySQL Ver 12.18 Distrib 4.0.12.

I downloaded PHP 4.3.4 (tar.gz) [4,522Kb] - 03 November 200 and tried

$ ./configure --with-mysql --with-apxs


../configure --with-mysql --with-apxs2=/path/to/apxs2

http://uk.php.net/manual/en/install.apache2.php

HTH;
JOn
Jul 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.