473,695 Members | 2,148 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

MySql 4.1.1 Password problem - client can't connect

Hello,

Newbie here..... Searching and working this for a week now.

We too are having the same problems.

Using MySql 4.0.14 and there are "no problems" at all.

However when we went to MySql 4.1.1

we cannot connect using clients (such as PhpMyAdmin or PhpAdsNew) if
there is any password.

Remove the password and 4.1.1 is fine.

I have also tried to start the database using both

bin/mysqld_safe &

bin/mysqld_safe --old-passwords &

with no luck

We have added users via telnet....

*************** ***********

INSERT INTO user VALUES
('localhost,'te st','','Y','Y', 'Y','Y','Y','Y' ,'Y','Y','Y','Y ','Y','Y','Y',' Y','Y','Y','Y', 'Y','Y','Y','Y' ,'','','','',0, 0,0);

Then we can get in using PhpMyAdmin

If we do...

UPDATE user SET PASSWORD=PASSWO RD ('test123') WHERE User='test' and
host='localhost ';

FLUSH PRIVILEGES;

Then we can no longer connect using PhpMyAdmin

*************** ************

If we then run... (removing the password) it again will connect fine.

UPDATE user SET PASSWORD=PASSWO RD ('') WHERE User='test' and
host='localhost ';

FLUSH PRIVILEGES;

also using the GRANT command does not work...

GRANT ALL PRIVILEGES ON *.* to 'test'@'localho st' IDENTIFIED BY
'test123';

FLUSH PRIVILEGES;

*************** *************** *

Logging into PhpAdmin as root (without a password) let's me in.

From the GUI I get the same exact results.

Add a user such as test@localhost without password and I can log into
that

user/database just fine. As soon as I add a password (via the GUI,
PhpAdmin) the user now longer connect.

Here is the error....

Welcome to phpMyAdmin 2.6.0-alpha1
phpMyAdmin tried to connect to the MySQL server, and the server
rejected the connection. You should check the host, username and
password in config.inc.php and make sure that they correspond to the
information given by the administrator of the MySQL server.

Error

MySQL said:

Cannot connect: invalid settings.
*************** **********

Here is the config.inc.php settings....

$i++;

$cfg['Servers'][$i]['host'] = 'localhost';

$cfg['Servers'][$i]['port'] = '';

$cfg['Servers'][$i]['socket'] = '';

$cfg['Servers'][$i]['connect_type'] = 'tcp';

$cfg['Servers'][$i]['extension'] = 'mysql';

$cfg['Servers'][$i]['compress'] = FALSE;

$cfg['Servers'][$i]['controluser'] = '';

$cfg['Servers'][$i]['controlpass'] = '';

$cfg['Servers'][$i]['auth_type'] = 'config';

$cfg['Servers'][$i]['user'] = 'test';

$cfg['Servers'][$i]['password'] = 'test123';

$cfg['Servers'][$i]['only_db'] = '';

$cfg['Servers'][$i]['verbose'] = '';

$cfg['Servers'][$i]['pmadb'] = ''; // 'phpmyadmin' - see
scripts/create_tables.s ql

$cfg['Servers'][$i]['bookmarktable'] = ''; // 'pma_bookmark'

$cfg['Servers'][$i]['relation'] = ''; // 'pma_relation'

$cfg['Servers'][$i]['table_info'] = ''; // 'pma_table_info '

$cfg['Servers'][$i]['table_coords'] = ''; // 'pma_table_coor ds'

$cfg['Servers'][$i]['pdf_pages'] = ''; // 'pma_pdf_pages'

$cfg['Servers'][$i]['column_info'] = ''; // 'pma_column_inf o'

$cfg['Servers'][$i]['history'] = ''; // 'pma_history'

$cfg['Servers'][$i]['verbose_check'] = TRUE;

$cfg['Servers'][$i]['AllowDeny']['order']

= '';

$cfg['Servers'][$i]['AllowDeny']['rules']

= array();

We have even tried a complete fresh reinstall of 4.1.1 and having the
same results.

Any help appreciated.... ..

Thanks

Marc
Jul 17 '05 #1
1 3316
Marc wrote:
(snip)
Any help appreciated.... ..


http://dev.mysql.com/doc/mysql/en/Up...-from-4.0.html

--
USENET would be a better place if everybody read: : mail address :
http://www.catb.org/~esr/faqs/smart-questions.html : is valid for :
http://www.netmeister.org/news/learn2quote2.html : "text/plain" :
http://www.expita.com/nomime.html : to 10K bytes :
Jul 17 '05 #2

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

2
7946
by: yzzzzz | last post by:
Hi I just upgraded from MySQL 4.0.something to 4.1.1 (alpha). When I try to connect to MySQL in a PHP script, I get the following error: "mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client in file.php on line 130"
2
2585
by: Marc | last post by:
Hello, Newbie here..... Searching and working this for a week now. We too are having the same problems. Using MySql 4.0.14 and there are "no problems" at all.
0
3943
by: Mike Chirico | last post by:
Interesting Things to Know about MySQL Mike Chirico (mchirico@users.sourceforge.net) Copyright (GPU Free Documentation License) 2004 Last Updated: Mon Jun 7 10:37:28 EDT 2004 The latest version of this document can be found at: http://prdownloads.sourceforge.net/souptonuts/README_mysql.txt?download
4
8415
by: Ian Davies | last post by:
Hello all The following code allows me to connect to a local MySQL database on my pc from a VB6 project. **************************************************************************** ** Dim conn As ADODB.Connection Dim cs As String Dim MyServer As String
5
5087
by: smatta | last post by:
I have just installed MySql version 5.0-18 on Red Hat Fedora Core 4. It is running but I cant connect to it using MySql Query Browser running on my pc. >From my pc, I can telnet to the sql server / port. I get back a garbled message: 5.0.18-standard§}WxyuadT,☻V6F?J5i1YMT= Should this be garbled ? or is there a problem ?
5
4567
by: news.telia.net | last post by:
Hi! I have a question. I have installed php and mysql on an apache-server on windows and I can't connect to the server. I tried to create a database (since I am trying to learn howto). My manual said I should write this at the shell: c:\mysql\bin>mysqladmin -u root creare mindb I did this and got this error:
4
5361
by: Richard | last post by:
Hi All, I've been trying to build a Ruby-on-Rails plus MySQL application. I'm running Ruby 1.8.2, Rails 1.1.4 and MySQL 5.0.15-nt over WinXP-Pro/SP2. I run under an Administrative account. I tried building the first example from Agile Web Development with Rails, 1st ed. Somehow the DB got corrupted and I couldn't recover. Instead of retrying that, I tried building the first example from Ruby For Rails, which worked fine.
4
7394
jepler
by: jepler | last post by:
I find myself in a circular reference loop that I can't seem to resolve. I recently upgraded from MySQL 4.0.x to MySQL 4.1.21 on OS 10.3.9 Server. Then, I *thought* I set my open master root password correctly using usr/local/mysql/bin/mysqladmin -u root password new_password and /usr/local/mysql/bin/mysqladmin -u root -h `hostname` password "newpasswd" . After setting my master root password I then connected via phpMyAdmin 2.5.4 as...
0
8586
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language synchronization. With a Microsoft account, language settings sync across devices. To prevent any complications,...
0
9004
jinu1996
by: jinu1996 | last post by:
In today's digital age, having a compelling online presence is paramount for businesses aiming to thrive in a competitive landscape. At the heart of this digital strategy lies an intricately woven tapestry of website design and digital marketing. It's not merely about having a website; it's about crafting an immersive digital experience that captivates audiences and drives business growth. The Art of Business Website Design Your website is...
1
8864
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
0
8838
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
1
6510
isladogs
by: isladogs | last post by:
The next Access Europe User Group meeting will be on Wednesday 1 May 2024 starting at 18:00 UK time (6PM UTC+1) and finishing by 19:30 (7.30PM). In this session, we are pleased to welcome a new presenter, Adolph Dupr who will be discussing some powerful techniques for using class modules. He will explain when you may want to use classes instead of User Defined Types (UDT). For example, to manage the data in unbound forms. Adolph will...
0
4351
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in the same network. But I'm wondering if it's possible to do the same thing, with 2 Pfsense firewalls...
0
4597
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?
1
3025
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system
3
1987
bsmnconsultancy
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating effective websites that not only look great but also perform exceptionally well. In this comprehensive...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.