By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,587 Members | 1,070 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,587 IT Pros & Developers. It's quick & easy.

Element 'Element Name Here' is not a known element. This can occur if there is a compilation error in the Web

P: n/a
I'm unable to build a web project that has a custom .NET control that I
downloaded

(from: http://blogs.msdn.com/dmitryr/archiv...26/561200.aspx)

I'm running VS 2005, ASP.NET 2.0 on my local development box. I created a
new web site with a single test page in it. I also right-clicked the
project added a Bin folder. Then I added the DLL that I downloaded to that
Bin folder. Then I copy/pasted the sample code included from the download
into a new .aspx page which included a Register Assembly directive:

<%@ Register Assembly="RssToolkit, Version=1.0.0.0, Culture=neutral,
PublicKeyToken=d9202816019f11ea" Namespace="RssToolkit" TagPrefix="cc1" %>

But when I try to build I get two errors

Error 2 Element 'rssdatasource' is not a known element. This can occur if
there is a compilation error in the Web site. \\oicpfp1\home\e000082\My
Documents\Visual Studio 2005\WebSites\WebSite3\Default.aspx 27 29
\\oicpfp1\home\...\WebSite3\

Error 3 Request for the permission of type
'System.Web.AspNetHostingPermission, System, Version=2.0.0.0,
Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.
\\oicpfp1\home\e000082\My Documents\Visual Studio
2005\WebSites\WebSite3\Default.aspx 27
Any suggestions on what to do would be greatly appreciated.

-- Margo

(FWIW, the doc file that also came w/ the download said:

"... RSS Toolkit works in Medium Trust (RssToolkit.dll Assembly either in
GAC or in 'bin' ..."

)

So I thought just by copying the .dll file into the Bin directory of my
project, it should work...
Apr 11 '06 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Hi Margo,

Thanks for your post!

For the current issue, I have performed the test. However, I can not repro
the problem. I add the dll file in the Bin folder and copy all html source
code from the scenario5.aspx file to the new web form page. All seems work
fine.

As far as I know, the error message indicates the issue is related to
permission. It seems your ASP.NET applications run in partial trust. This
is configured through the <trust level="xxx" /> setting in web.config or
machine.config. Please change the "xxx" to medium and try again to figure
out whether the problem still occurs.

Regards,

Yuan Ren
Microsoft Online Community Support
==================================================
When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.
==================================================
This posting is provided "AS IS" with no warranties, and confers no rights.

Apr 12 '06 #2

P: n/a
I believe I stumbled onto something here, although I honestly do not
understand the *Exact* details of why... When I was creating my web projects
in Visual Studio 2005, I was accepting the default location for them, which,
in my case, happens to be a network share.

So, I created a new web project and changed the location to a folder on my
local hard drive, and that seemed to fix it.

Apr 14 '06 #3

P: n/a
Hi Noreen,

Thanks for your reply!

I'm glad to hear the issue has been resolved. Actually, as I mentioned
before, the issue is caused by the permission setting of the current
machine. I think there are some restrictions in the specific folder you
create before. So, after you choose the default creation, the issue has
been resolved.

Regards,

Yuan Ren
Microsoft Online Community Support
==================================================
When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.
==================================================
This posting is provided "AS IS" with no warranties, and confers no rights.

Apr 17 '06 #4

This discussion thread is closed

Replies have been disabled for this discussion.