By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,032 Members | 825 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,032 IT Pros & Developers. It's quick & easy.

Deploytool-Problem using J2EE 1.4

P: n/a
Hi folks,

I'm having a problem with the J2EE-SDK 1.4 (WindowsXP). I have
installed j2sdk-1_4_2_02 as required by the J2EE-SDK. Pre-packaged
Applications of the Tutorial (such as the Bookstore-Sample) work fine.

Now I'm trying to package the Converter-Sample-Application of the
Tutorial using deploytool. Creating the ConverterApp.ear-File is no
problem. But when I create the Appliction-Client using the Wizard (as
described in the Tutorial), the client simply is not created in the
Application (no entry in the Tree is shown). Creating a
Standalone-Client in the same way works (it produces a Tree-entry),
but when I try to save the Application-JAR, I receive a Popup-Window
reporting a "SaxParseException: Premature end of File" and a corrupt
Application-JAR. I have the feeling that deploytool produces an empty
Deployment-Descriptor...

Has anybody dealt with the same Problem? What should I do? Thanks for
your answers in advance.
Jul 17 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
The same occured to me -- so you're not the only one

loomax
Jul 17 '05 #2

P: n/a
This seems to be a bug -- I occurences on my system also j2EE 1.4 with
jdk1.4.2_04 on a win2000 system
Jul 17 '05 #3

P: n/a
According to the java.sun.forum this is a problem of the localized
settings

So the deploytool works on english systems but not on german ones

There is a proposal to insert the options -Duser.country="US"
-Duser.language="en" -Duser.region="US" in the deploytool.bat but for
me it didn't work
Jul 17 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.