473,842 Members | 1,619 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

HELP Connection error on Release mode

I have no idea what is going on. I have a Login screen where someone types
in their login information and this populates a datagrid based off of the
login. Works great in debug and test through VS, however, when I change to
release and put it out on the web it fails giving me the following error
message

The underlying connection was closed. Could not establish a trust
relationship with the remote server.
How on earth do I fix this? I read a little on it and it says that you
usually get this when using SSL but I am not using SSL.
Nov 16 '05 #1
10 2731
Brian,

Is this an ASP.NET application, or is this an EXE that is downloaded
from the web? If it is an EXE that is downloaded from the web, then the exe
runs with a reduced permission set, which definitely restricts network
access (considering that it is from the internet zone).

You will have to download the EXE to your machine, or you will have to
set the permissions for the EXE in the .NET configuration manager in order
to grant rights to that EXE.

Hope this helps.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard. caspershouse.co m

"Brian Conway" <Br**********@q west.com> wrote in message
news:Ox******** ******@TK2MSFTN GP10.phx.gbl...
I have no idea what is going on. I have a Login screen where someone types in their login information and this populates a datagrid based off of the
login. Works great in debug and test through VS, however, when I change to release and put it out on the web it fails giving me the following error
message

The underlying connection was closed. Could not establish a trust
relationship with the remote server.
How on earth do I fix this? I read a little on it and it says that you
usually get this when using SSL but I am not using SSL.

Nov 16 '05 #2
This is an ASP.NET application. I am using the installer program to deploy
though. I built one other ASP.NET application the same way and it works
fine, different database server though than this one.

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote in
message news:Oa******** ******@tk2msftn gp13.phx.gbl...
Brian,

Is this an ASP.NET application, or is this an EXE that is downloaded
from the web? If it is an EXE that is downloaded from the web, then the exe runs with a reduced permission set, which definitely restricts network
access (considering that it is from the internet zone).

You will have to download the EXE to your machine, or you will have to
set the permissions for the EXE in the .NET configuration manager in order
to grant rights to that EXE.

Hope this helps.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard. caspershouse.co m

"Brian Conway" <Br**********@q west.com> wrote in message
news:Ox******** ******@TK2MSFTN GP10.phx.gbl...
I have no idea what is going on. I have a Login screen where someone

types
in their login information and this populates a datagrid based off of the login. Works great in debug and test through VS, however, when I change

to
release and put it out on the web it fails giving me the following error
message

The underlying connection was closed. Could not establish a trust
relationship with the remote server.
How on earth do I fix this? I read a little on it and it says that you
usually get this when using SSL but I am not using SSL.


Nov 16 '05 #3
Brian,

Is the database on the machine that IIS is on or is it on another
machine? If it is on the local machine, is the database configured to allow
the user account that is accessing it? Most likely, this is the ASPNET
account, which is local to the machine that IIS is running on. If the
database is on another machine, then you need to change the account (for the
duration of the database access) to an account that has access to the
network and the database.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard. caspershouse.co m

"Brian Conway" <Br**********@q west.com> wrote in message
news:O5******** ******@TK2MSFTN GP12.phx.gbl...
This is an ASP.NET application. I am using the installer program to deploy
though. I built one other ASP.NET application the same way and it works
fine, different database server though than this one.

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote in message news:Oa******** ******@tk2msftn gp13.phx.gbl...
Brian,

Is this an ASP.NET application, or is this an EXE that is downloaded
from the web? If it is an EXE that is downloaded from the web, then the

exe
runs with a reduced permission set, which definitely restricts network
access (considering that it is from the internet zone).

You will have to download the EXE to your machine, or you will have to
set the permissions for the EXE in the .NET configuration manager in order to grant rights to that EXE.

Hope this helps.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard. caspershouse.co m

"Brian Conway" <Br**********@q west.com> wrote in message
news:Ox******** ******@TK2MSFTN GP10.phx.gbl...
I have no idea what is going on. I have a Login screen where someone

types
in their login information and this populates a datagrid based off of the login. Works great in debug and test through VS, however, when I change to
release and put it out on the web it fails giving me the following

error message

The underlying connection was closed. Could not establish a trust
relationship with the remote server.
How on earth do I fix this? I read a little on it and it says that you usually get this when using SSL but I am not using SSL.



Nov 16 '05 #4
The database is on another machine (same as with my other application that
works fine) I am not sure what you mean by changing the account to an
account that has access to the network. I thought that this was already
established within the webconfig file in the connection string. My
development computer is setup fairly identical to the test server, and it
runs perfectly fine on my computer.

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote in
message news:uv******** ******@TK2MSFTN GP10.phx.gbl...
Brian,

Is the database on the machine that IIS is on or is it on another
machine? If it is on the local machine, is the database configured to allow the user account that is accessing it? Most likely, this is the ASPNET
account, which is local to the machine that IIS is running on. If the
database is on another machine, then you need to change the account (for the duration of the database access) to an account that has access to the
network and the database.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard. caspershouse.co m

"Brian Conway" <Br**********@q west.com> wrote in message
news:O5******** ******@TK2MSFTN GP12.phx.gbl...
This is an ASP.NET application. I am using the installer program to deploy
though. I built one other ASP.NET application the same way and it works
fine, different database server though than this one.

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote in
message news:Oa******** ******@tk2msftn gp13.phx.gbl...
Brian,

Is this an ASP.NET application, or is this an EXE that is downloaded from the web? If it is an EXE that is downloaded from the web, then the
exe
runs with a reduced permission set, which definitely restricts network
access (considering that it is from the internet zone).

You will have to download the EXE to your machine, or you will hav
e to set the permissions for the EXE in the .NET configuration manager in order to grant rights to that EXE.

Hope this helps.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard. caspershouse.co m

"Brian Conway" <Br**********@q west.com> wrote in message
news:Ox******** ******@TK2MSFTN GP10.phx.gbl...
> I have no idea what is going on. I have a Login screen where
someone types
> in their login information and this populates a datagrid based off

of the
> login. Works great in debug and test through VS, however, when I

change to
> release and put it out on the web it fails giving me the following error > message
>
> The underlying connection was closed. Could not establish a trust
> relationship with the remote server.
>
>
> How on earth do I fix this? I read a little on it and it says that you > usually get this when using SSL but I am not using SSL.
>
>



Nov 16 '05 #5
Brian,

The connection string only has the credientials. However, ASP.NET runs
locally using ASPNET, which can't access the network. If the page runs
under an account that can't access the network, then it can't even get to
the point where it passes credentials.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard. caspershouse.co m

"Brian Conway" <Br**********@q west.com> wrote in message
news:uq******** ******@TK2MSFTN GP12.phx.gbl...
The database is on another machine (same as with my other application that
works fine) I am not sure what you mean by changing the account to an
account that has access to the network. I thought that this was already
established within the webconfig file in the connection string. My
development computer is setup fairly identical to the test server, and it
runs perfectly fine on my computer.

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote in message news:uv******** ******@TK2MSFTN GP10.phx.gbl...
Brian,

Is the database on the machine that IIS is on or is it on another
machine? If it is on the local machine, is the database configured to allow
the user account that is accessing it? Most likely, this is the ASPNET
account, which is local to the machine that IIS is running on. If the
database is on another machine, then you need to change the account (for

the
duration of the database access) to an account that has access to the
network and the database.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard. caspershouse.co m

"Brian Conway" <Br**********@q west.com> wrote in message
news:O5******** ******@TK2MSFTN GP12.phx.gbl...
This is an ASP.NET application. I am using the installer program to deploy though. I built one other ASP.NET application the same way and it works fine, different database server though than this one.

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote
in
message news:Oa******** ******@tk2msftn gp13.phx.gbl...
> Brian,
>
> Is this an ASP.NET application, or is this an EXE that is downloaded > from the web? If it is an EXE that is downloaded from the web, then the exe
> runs with a reduced permission set, which definitely restricts
network > access (considering that it is from the internet zone).
>
> You will have to download the EXE to your machine, or you will
hav e
to
> set the permissions for the EXE in the .NET configuration manager in

order
> to grant rights to that EXE.
>
> Hope this helps.
>
>
> --
> - Nicholas Paldino [.NET/C# MVP]
> - mv*@spam.guard. caspershouse.co m
>
> "Brian Conway" <Br**********@q west.com> wrote in message
> news:Ox******** ******@TK2MSFTN GP10.phx.gbl...
> > I have no idea what is going on. I have a Login screen where

someone > types
> > in their login information and this populates a datagrid based off of the
> > login. Works great in debug and test through VS, however, when I

change
> to
> > release and put it out on the web it fails giving me the following

error
> > message
> >
> > The underlying connection was closed. Could not establish a trust
> > relationship with the remote server.
> >
> >
> > How on earth do I fix this? I read a little on it and it says

that you
> > usually get this when using SSL but I am not using SSL.
> >
> >
>
>



Nov 16 '05 #6
I would assume that the account can, since my other application accesses a
database not on that server and is located elsewhere on the network. How do
I try to check and see if this is the problem and how do I resolve it?

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote in
message news:u$******** ******@TK2MSFTN GP10.phx.gbl...
Brian,

The connection string only has the credientials. However, ASP.NET runs locally using ASPNET, which can't access the network. If the page runs
under an account that can't access the network, then it can't even get to
the point where it passes credentials.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard. caspershouse.co m

"Brian Conway" <Br**********@q west.com> wrote in message
news:uq******** ******@TK2MSFTN GP12.phx.gbl...
The database is on another machine (same as with my other application that
works fine) I am not sure what you mean by changing the account to an
account that has access to the network. I thought that this was already
established within the webconfig file in the connection string. My
development computer is setup fairly identical to the test server, and it runs perfectly fine on my computer.

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote

in
message news:uv******** ******@TK2MSFTN GP10.phx.gbl...
Brian,

Is the database on the machine that IIS is on or is it on another
machine? If it is on the local machine, is the database configured to

allow
the user account that is accessing it? Most likely, this is the ASPNET account, which is local to the machine that IIS is running on. If the
database is on another machine, then you need to change the account (for
the
duration of the database access) to an account that has access to the
network and the database.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard. caspershouse.co m

"Brian Conway" <Br**********@q west.com> wrote in message
news:O5******** ******@TK2MSFTN GP12.phx.gbl...
> This is an ASP.NET application. I am using the installer program to

deploy
> though. I built one other ASP.NET application the same way and it works > fine, different database server though than this one.
>
>
>
> "Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote in
> message news:Oa******** ******@tk2msftn gp13.phx.gbl...
> > Brian,
> >
> > Is this an ASP.NET application, or is this an EXE that is

downloaded
> > from the web? If it is an EXE that is downloaded from the web,
then the
> exe
> > runs with a reduced permission set, which definitely restricts network > > access (considering that it is from the internet zone).
> >
> > You will have to download the EXE to your machine, or you will hav
e
to
> > set the permissions for the EXE in the .NET configuration manager

in order
> > to grant rights to that EXE.
> >
> > Hope this helps.
> >
> >
> > --
> > - Nicholas Paldino [.NET/C# MVP]
> > - mv*@spam.guard. caspershouse.co m
> >
> > "Brian Conway" <Br**********@q west.com> wrote in message
> > news:Ox******** ******@TK2MSFTN GP10.phx.gbl...
> > > I have no idea what is going on. I have a Login screen where

someone
> > types
> > > in their login information and this populates a datagrid based off of
> the
> > > login. Works great in debug and test through VS, however, when

I change
> > to
> > > release and put it out on the web it fails giving me the following error
> > > message
> > >
> > > The underlying connection was closed. Could not establish a trust > > > relationship with the remote server.
> > >
> > >
> > > How on earth do I fix this? I read a little on it and it says

that you
> > > usually get this when using SSL but I am not using SSL.
> > >
> > >
> >
> >
>
>



Nov 16 '05 #7
Brian,

Is your other application configured differently? I would imagine that
this is the case. Can you post the web.config file for your current app?

You can test this by changing the account that the app runs under by
setting the <identity> element and setting the impersonate attribute to a
value of "true". This will allow you to specify an account which can access
the network (through the username and password attributes).
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard. caspershouse.co m

"Brian Conway" <Br**********@q west.com> wrote in message
news:Od******** ******@tk2msftn gp13.phx.gbl...
I would assume that the account can, since my other application accesses a
database not on that server and is located elsewhere on the network. How do I try to check and see if this is the problem and how do I resolve it?

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote in message news:u$******** ******@TK2MSFTN GP10.phx.gbl...
Brian,

The connection string only has the credientials. However, ASP.NET runs
locally using ASPNET, which can't access the network. If the page runs
under an account that can't access the network, then it can't even get to
the point where it passes credentials.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard. caspershouse.co m

"Brian Conway" <Br**********@q west.com> wrote in message
news:uq******** ******@TK2MSFTN GP12.phx.gbl...
The database is on another machine (same as with my other application that works fine) I am not sure what you mean by changing the account to an
account that has access to the network. I thought that this was already established within the webconfig file in the connection string. My
development computer is setup fairly identical to the test server, and it runs perfectly fine on my computer.

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote in
message news:uv******** ******@TK2MSFTN GP10.phx.gbl...
> Brian,
>
> Is the database on the machine that IIS is on or is it on
another > machine? If it is on the local machine, is the database configured to allow
> the user account that is accessing it? Most likely, this is the ASPNET > account, which is local to the machine that IIS is running on. If the > database is on another machine, then you need to change the account (for the
> duration of the database access) to an account that has access to the > network and the database.
>
>
> --
> - Nicholas Paldino [.NET/C# MVP]
> - mv*@spam.guard. caspershouse.co m
>
> "Brian Conway" <Br**********@q west.com> wrote in message
> news:O5******** ******@TK2MSFTN GP12.phx.gbl...
> > This is an ASP.NET application. I am using the installer program to deploy
> > though. I built one other ASP.NET application the same way and it

works
> > fine, different database server though than this one.
> >
> >
> >
> > "Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om>

wrote
> in
> > message news:Oa******** ******@tk2msftn gp13.phx.gbl...
> > > Brian,
> > >
> > > Is this an ASP.NET application, or is this an EXE that is
downloaded
> > > from the web? If it is an EXE that is downloaded from the web, then the
> > exe
> > > runs with a reduced permission set, which definitely restricts

network
> > > access (considering that it is from the internet zone).
> > >
> > > You will have to download the EXE to your machine, or you
will hav
e
> to
> > > set the permissions for the EXE in the .NET configuration

manager in > order
> > > to grant rights to that EXE.
> > >
> > > Hope this helps.
> > >
> > >
> > > --
> > > - Nicholas Paldino [.NET/C# MVP]
> > > - mv*@spam.guard. caspershouse.co m
> > >
> > > "Brian Conway" <Br**********@q west.com> wrote in message
> > > news:Ox******** ******@TK2MSFTN GP10.phx.gbl...
> > > > I have no idea what is going on. I have a Login screen where
someone
> > > types
> > > > in their login information and this populates a datagrid based off of
> > the
> > > > login. Works great in debug and test through VS, however,
when
I > change
> > > to
> > > > release and put it out on the web it fails giving me the following > error
> > > > message
> > > >
> > > > The underlying connection was closed. Could not establish a trust > > > > relationship with the remote server.
> > > >
> > > >
> > > > How on earth do I fix this? I read a little on it and it says

that
> you
> > > > usually get this when using SSL but I am not using SSL.
> > > >
> > > >
> > >
> > >
> >
> >
>
>



Nov 16 '05 #8
This is the web config for the one that does not work, below this one is the
web config for the one that does work.

<?xml version="1.0" encoding="utf-8" ?>

<configuratio n>

<appSettings>

<add key="FleetConne ctionString" value="Data
Source=fletws01 ;Password=upgra de;User ID=fleet;provid er=OraOLEDB.Ora cle.1"/>

</appSettings>

<system.web>

<!-- DYNAMIC DEBUG COMPILATION

Set compilation debug="true" to enable ASPX debugging. Otherwise, setting
this value to

false will improve runtime performance of this application.

Set compilation debug="true" to insert debugging symbols (.pdb information)

into the compiled page. Because this creates a larger file that executes

more slowly, you should set this value to true only when debugging and to

false at all other times. For more information, refer to the documentation
about

debugging ASP.NET files.

-->

<compilation

defaultLanguage ="c#"

debug="true"

/>

<!-- CUSTOM ERROR MESSAGES

Set customErrors mode="On" or "RemoteOnly " to enable custom error messages,
"Off" to disable.

Add <error> tags for each of the errors you want to handle.

"On" Always display custom (friendly) messages.

"Off" Always display detailed ASP.NET error information.

"RemoteOnly " Display custom (friendly) messages only to users not running

on the local Web server. This setting is recommended for security purposes,
so

that you do not display application detail information to remote clients.

-->

<customErrors

mode="RemoteOnl y"

/>

<!-- AUTHENTICATION

This section sets the authentication policies of the application. Possible
modes are "Windows",

"Forms", "Passport" and "None"

"None" No authentication is performed.

"Windows" IIS performs authentication (Basic, Digest, or Integrated Windows)
according to

its settings for the application. Anonymous access must be disabled in IIS.

"Forms" You provide a custom form (Web page) for users to enter their
credentials, and then

you authenticate them in your application. A user credential token is stored
in a cookie.

"Passport" Authentication is performed via a centralized authentication
service provided

by Microsoft that offers a single logon and core profile services for member
sites.

-->

<authenticati on mode="Windows" />

<!-- AUTHORIZATION

This section sets the authorization policies of the application. You can
allow or deny access

to application resources by user or role. Wildcards: "*" mean everyone, "?"
means anonymous

(unauthenticate d) users.

-->

<authorizatio n>

<allow users="*" /> <!-- Allow all users -->

<!-- <allow users="[comma separated list of users]"

roles="[comma separated list of roles]"/>

<deny users="[comma separated list of users]"

roles="[comma separated list of roles]"/>

-->

</authorization>

<!-- APPLICATION-LEVEL TRACE LOGGING

Application-level tracing enables trace log output for every page within an
application.

Set trace enabled="true" to enable application trace logging. If
pageOutput="tru e", the

trace information will be displayed at the bottom of each page. Otherwise,
you can view the

application trace log by browsing the "trace.axd" page from your web
application

root.

-->

<trace

enabled="false"

requestLimit="1 0"

pageOutput="fal se"

traceMode="Sort ByTime"

localOnly="true "

/>

<!-- SESSION STATE SETTINGS

By default ASP.NET uses cookies to identify which requests belong to a
particular session.

If cookies are not available, a session can be tracked by adding a session
identifier to the URL.

To disable cookies, set sessionState cookieless="tru e".

-->

<sessionState

mode="InProc"

stateConnection String="tcpip=1 27.0.0.1:42424"

sqlConnectionSt ring="data source=127.0.0. 1;Trusted_Conne ction=yes"

cookieless="fal se"

timeout="20"

/>

<!-- GLOBALIZATION

This section sets the globalization settings of the application.

-->

<globalizatio n

requestEncoding ="utf-8"

responseEncodin g="utf-8"

/>
</system.web>

</configuration>

<<<<<<<<<<<<<<< <<<<<<<<<<<<<<< <<<<<<<<<<Thi s is for the one that does work

<?xml version="1.0" encoding="utf-8" ?>

<configuratio n>

<appSettings>

<add key="Conference ConnectionStrin g" value="Data
Source=ntdrp001 .world;Password =conf00;User
ID=conference;p rovider=OraOLED B.Oracle.1"/>

</appSettings>

<system.web>

<!-- DYNAMIC DEBUG COMPILATION

Set compilation debug="true" to enable ASPX debugging. Otherwise, setting
this value to

false will improve runtime performance of this application.

Set compilation debug="true" to insert debugging symbols (.pdb information)

into the compiled page. Because this creates a larger file that executes

more slowly, you should set this value to true only when debugging and to

false at all other times. For more information, refer to the documentation
about

debugging ASP.NET files.

-->

<compilation

defaultLanguage ="c#"

debug="true"

/>

<!-- CUSTOM ERROR MESSAGES

Set customErrors mode="On" or "RemoteOnly " to enable custom error messages,
"Off" to disable.

Add <error> tags for each of the errors you want to handle.

"On" Always display custom (friendly) messages.

"Off" Always display detailed ASP.NET error information.

"RemoteOnly " Display custom (friendly) messages only to users not running

on the local Web server. This setting is recommended for security purposes,
so

that you do not display application detail information to remote clients.

-->

<customErrors

mode="RemoteOnl y"

/>

<!-- AUTHENTICATION

This section sets the authentication policies of the application. Possible
modes are "Windows",

"Forms", "Passport" and "None"

"None" No authentication is performed.

"Windows" IIS performs authentication (Basic, Digest, or Integrated Windows)
according to

its settings for the application. Anonymous access must be disabled in IIS.

"Forms" You provide a custom form (Web page) for users to enter their
credentials, and then

you authenticate them in your application. A user credential token is stored
in a cookie.

"Passport" Authentication is performed via a centralized authentication
service provided

by Microsoft that offers a single logon and core profile services for member
sites.

-->

<authenticati on mode="Windows" />

<!-- AUTHORIZATION

This section sets the authorization policies of the application. You can
allow or deny access

to application resources by user or role. Wildcards: "*" mean everyone, "?"
means anonymous

(unauthenticate d) users.

-->

<authorizatio n>

<allow users="*" /> <!-- Allow all users -->

<!-- <allow users="[comma separated list of users]"

roles="[comma separated list of roles]"/>

<deny users="[comma separated list of users]"

roles="[comma separated list of roles]"/>

-->

</authorization>

<!-- APPLICATION-LEVEL TRACE LOGGING

Application-level tracing enables trace log output for every page within an
application.

Set trace enabled="true" to enable application trace logging. If
pageOutput="tru e", the

trace information will be displayed at the bottom of each page. Otherwise,
you can view the

application trace log by browsing the "trace.axd" page from your web
application

root.

-->

<trace

enabled="false"

requestLimit="1 0"

pageOutput="fal se"

traceMode="Sort ByTime"

localOnly="true "

/>

<!-- SESSION STATE SETTINGS

By default ASP.NET uses cookies to identify which requests belong to a
particular session.

If cookies are not available, a session can be tracked by adding a session
identifier to the URL.

To disable cookies, set sessionState cookieless="tru e".

-->

<sessionState

mode="InProc"

stateConnection String="tcpip=1 27.0.0.1:42424"

sqlConnectionSt ring="data source=127.0.0. 1;Trusted_Conne ction=yes"

cookieless="fal se"

timeout="20"

/>

<!-- GLOBALIZATION

This section sets the globalization settings of the application.

-->

<globalizatio n

requestEncoding ="utf-8"

responseEncodin g="utf-8"

/>
</system.web>

</configuration>

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote in
message news:u9******** ******@TK2MSFTN GP11.phx.gbl...
Brian,

Is your other application configured differently? I would imagine that this is the case. Can you post the web.config file for your current app?

You can test this by changing the account that the app runs under by
setting the <identity> element and setting the impersonate attribute to a
value of "true". This will allow you to specify an account which can access the network (through the username and password attributes).
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard. caspershouse.co m

"Brian Conway" <Br**********@q west.com> wrote in message
news:Od******** ******@tk2msftn gp13.phx.gbl...
I would assume that the account can, since my other application accesses a
database not on that server and is located elsewhere on the network. How
do
I try to check and see if this is the problem and how do I resolve it?

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote in
message news:u$******** ******@TK2MSFTN GP10.phx.gbl...
Brian,

The connection string only has the credientials. However, ASP.NET

runs
locally using ASPNET, which can't access the network. If the page runs under an account that can't access the network, then it can't even get

to the point where it passes credentials.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard. caspershouse.co m

"Brian Conway" <Br**********@q west.com> wrote in message
news:uq******** ******@TK2MSFTN GP12.phx.gbl...
> The database is on another machine (same as with my other application that
> works fine) I am not sure what you mean by changing the account to
an > account that has access to the network. I thought that this was already > established within the webconfig file in the connection string. My
> development computer is setup fairly identical to the test server, and it
> runs perfectly fine on my computer.
>
> "Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote in
> message news:uv******** ******@TK2MSFTN GP10.phx.gbl...
> > Brian,
> >
> > Is the database on the machine that IIS is on or is it on another > > machine? If it is on the local machine, is the database
configured to > allow
> > the user account that is accessing it? Most likely, this is the

ASPNET
> > account, which is local to the machine that IIS is running on. If the > > database is on another machine, then you need to change the
account
(for
> the
> > duration of the database access) to an account that has access to the > > network and the database.
> >
> >
> > --
> > - Nicholas Paldino [.NET/C# MVP]
> > - mv*@spam.guard. caspershouse.co m
> >
> > "Brian Conway" <Br**********@q west.com> wrote in message
> > news:O5******** ******@TK2MSFTN GP12.phx.gbl...
> > > This is an ASP.NET application. I am using the installer program to > deploy
> > > though. I built one other ASP.NET application the same way and
it works
> > > fine, different database server though than this one.
> > >
> > >
> > >
> > > "Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote
> > in
> > > message news:Oa******** ******@tk2msftn gp13.phx.gbl...
> > > > Brian,
> > > >
> > > > Is this an ASP.NET application, or is this an EXE that is
> downloaded
> > > > from the web? If it is an EXE that is downloaded from the web, then
> the
> > > exe
> > > > runs with a reduced permission set, which definitely restricts
network
> > > > access (considering that it is from the internet zone).
> > > >
> > > > You will have to download the EXE to your machine, or you will hav
> e
> > to
> > > > set the permissions for the EXE in the .NET configuration

manager
in
> > order
> > > > to grant rights to that EXE.
> > > >
> > > > Hope this helps.
> > > >
> > > >
> > > > --
> > > > - Nicholas Paldino [.NET/C# MVP]
> > > > - mv*@spam.guard. caspershouse.co m
> > > >
> > > > "Brian Conway" <Br**********@q west.com> wrote in message
> > > > news:Ox******** ******@TK2MSFTN GP10.phx.gbl...
> > > > > I have no idea what is going on. I have a Login screen

where > someone
> > > > types
> > > > > in their login information and this populates a datagrid based off
> of
> > > the
> > > > > login. Works great in debug and test through VS, however,

when
I
> > change
> > > > to
> > > > > release and put it out on the web it fails giving me the

following
> > error
> > > > > message
> > > > >
> > > > > The underlying connection was closed. Could not establish a

trust
> > > > > relationship with the remote server.
> > > > >
> > > > >
> > > > > How on earth do I fix this? I read a little on it and it

says that
> > you
> > > > > usually get this when using SSL but I am not using SSL.
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> >
> >
>
>



Nov 16 '05 #9
I tried this string after the authorization section in the webconfig file

<identity impersonate="tr ue" userName="edqa" password="admin 40!"/>

and it still returned the same error message.

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote in
message news:u9******** ******@TK2MSFTN GP11.phx.gbl...
Brian,

Is your other application configured differently? I would imagine that this is the case. Can you post the web.config file for your current app?

You can test this by changing the account that the app runs under by
setting the <identity> element and setting the impersonate attribute to a
value of "true". This will allow you to specify an account which can access the network (through the username and password attributes).
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard. caspershouse.co m

"Brian Conway" <Br**********@q west.com> wrote in message
news:Od******** ******@tk2msftn gp13.phx.gbl...
I would assume that the account can, since my other application accesses a
database not on that server and is located elsewhere on the network. How
do
I try to check and see if this is the problem and how do I resolve it?

"Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote in
message news:u$******** ******@TK2MSFTN GP10.phx.gbl...
Brian,

The connection string only has the credientials. However, ASP.NET

runs
locally using ASPNET, which can't access the network. If the page runs under an account that can't access the network, then it can't even get

to the point where it passes credentials.
--
- Nicholas Paldino [.NET/C# MVP]
- mv*@spam.guard. caspershouse.co m

"Brian Conway" <Br**********@q west.com> wrote in message
news:uq******** ******@TK2MSFTN GP12.phx.gbl...
> The database is on another machine (same as with my other application that
> works fine) I am not sure what you mean by changing the account to
an > account that has access to the network. I thought that this was already > established within the webconfig file in the connection string. My
> development computer is setup fairly identical to the test server, and it
> runs perfectly fine on my computer.
>
> "Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote in
> message news:uv******** ******@TK2MSFTN GP10.phx.gbl...
> > Brian,
> >
> > Is the database on the machine that IIS is on or is it on another > > machine? If it is on the local machine, is the database
configured to > allow
> > the user account that is accessing it? Most likely, this is the

ASPNET
> > account, which is local to the machine that IIS is running on. If the > > database is on another machine, then you need to change the
account
(for
> the
> > duration of the database access) to an account that has access to the > > network and the database.
> >
> >
> > --
> > - Nicholas Paldino [.NET/C# MVP]
> > - mv*@spam.guard. caspershouse.co m
> >
> > "Brian Conway" <Br**********@q west.com> wrote in message
> > news:O5******** ******@TK2MSFTN GP12.phx.gbl...
> > > This is an ASP.NET application. I am using the installer program to > deploy
> > > though. I built one other ASP.NET application the same way and
it works
> > > fine, different database server though than this one.
> > >
> > >
> > >
> > > "Nicholas Paldino [.NET/C# MVP]" <mv*@spam.guard .caspershouse.c om> wrote
> > in
> > > message news:Oa******** ******@tk2msftn gp13.phx.gbl...
> > > > Brian,
> > > >
> > > > Is this an ASP.NET application, or is this an EXE that is
> downloaded
> > > > from the web? If it is an EXE that is downloaded from the web, then
> the
> > > exe
> > > > runs with a reduced permission set, which definitely restricts
network
> > > > access (considering that it is from the internet zone).
> > > >
> > > > You will have to download the EXE to your machine, or you will hav
> e
> > to
> > > > set the permissions for the EXE in the .NET configuration

manager
in
> > order
> > > > to grant rights to that EXE.
> > > >
> > > > Hope this helps.
> > > >
> > > >
> > > > --
> > > > - Nicholas Paldino [.NET/C# MVP]
> > > > - mv*@spam.guard. caspershouse.co m
> > > >
> > > > "Brian Conway" <Br**********@q west.com> wrote in message
> > > > news:Ox******** ******@TK2MSFTN GP10.phx.gbl...
> > > > > I have no idea what is going on. I have a Login screen

where > someone
> > > > types
> > > > > in their login information and this populates a datagrid based off
> of
> > > the
> > > > > login. Works great in debug and test through VS, however,

when
I
> > change
> > > > to
> > > > > release and put it out on the web it fails giving me the

following
> > error
> > > > > message
> > > > >
> > > > > The underlying connection was closed. Could not establish a

trust
> > > > > relationship with the remote server.
> > > > >
> > > > >
> > > > > How on earth do I fix this? I read a little on it and it

says that
> > you
> > > > > usually get this when using SSL but I am not using SSL.
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> >
> >
>
>



Nov 16 '05 #10

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

8
5486
by: baustin75 | last post by:
Posted: Mon Oct 03, 2005 1:41 pm Post subject: cannot mail() in ie only when debugging in php designer 2005 -------------------------------------------------------------------------------- Hello, I have a very simple problem but cannot seem to figure it out. I have a very simple php script that sends a test email to myself. When I debug it in PHP designer, it works with no problems, I get the test email. If
9
10691
by: Robert Schneider | last post by:
Hi to all, I don't understand that: I try to delete a record via JDBC. But I always get the error SQL7008 with the error code 3. It seems that this has something to do with journaling, since the table from which I want to delete has two foreign keys that references two other tables and it is also referenced by another table. But this shouldn't be a problem, since I set the commit mode to none (or *none) at all places where this makes...
1
4246
by: Rohit Raghuwanshi | last post by:
Hello all, we are running a delphi application with DB2 V8.01 which is causing deadlocks when rows are being inserted into a table. Attaching the Event Monitor Log (DEADLOCKS WITH DETAILS) here. From the log it looks like the problem happens when 2 threads insert 1 record each in the same table and then try to aquire a NS (Next Key Share) lock on the record inserterd by the other thread. Thanks Rohit
15
2111
by: DavidS | last post by:
Have Visual Studio.NET installed on MS 2000 Professional OS laptop. No issue ever with web development and SQL connections. Purchased new laptop with XP Professional SP2!!!!!!!! & Visual Studio.NET installed. Nothing but headaches. Continually getting System.Data.SqlClient.SqlException : Timeout expired message - The timeout period elapsed prior to completion of the operation or the server is not responding. Can anyone help with...
1
7301
by: sharmadeep1980 | last post by:
Hi All, I am facing a very unique problem while compling my project in "Release" build. The project is building in DEBUG mode but giving linking error on Release build. Here is the error: Creating library Release/fnimqcmd.lib and object Release/fnimqcmd.exp CoIMQCmd.obj : error LNK2001: unresolved external symbol
2
9816
by: JoeSep | last post by:
Hi! Is it correct/safe to define a connection pool in the string "sqlConnectionString" of the "sessionState" section of Web.config? - The application is developed using AspNet 1.1 in a Windows Server 2003. - The AspState DB is defined in a Sql Server 2000 DB on another server. I have added this definition to the Web.config file: <sessionState mode="SQLServer"
0
5580
by: gunimpi | last post by:
http://www.vbforums.com/showthread.php?p=2745431#post2745431 ******************************************************** VB6 OR VBA & Webbrowser DOM Tiny $50 Mini Project Programmer help wanted ******************************************************** For this teeny job, please refer to: http://feeds.reddit.com/feed/8fu/?o=25
3
2639
by: k.rollman | last post by:
I am having a problem using cURL to create an https connection on a non-standard port (440). Using curl_setopt to set the port to 440 has no effect, and I get the following from curl's verbose output. * About to connect() to xxx.xxx.xxx.xxx port 443 * Connected to xxx.xxx.xxx.xxx (xxx.xxx.xxx.xxx) port 443 If I put ':440' in the url, I get the following and an error code of 7. * About to connect() to xxx.xxx.xxx.xxx port 440
6
2889
by: priyajohal | last post by:
#include<fstream.h> #include<process.h> #include<stdlib.h> #include<conio.h> #include<string.h> #include<dos.h> #include<ctype.h> #include<stdio.h> void setup() void help();
0
9875
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main usage, and What is the difference between ONU and Router. Let’s take a closer look ! Part I. Meaning of...
0
10945
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
0
10317
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
0
9454
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project—planning, coding, testing, and deployment—without human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then launch it, all on its own.... Now, this would greatly impact the work of software developers. The idea...
1
7859
isladogs
by: isladogs | last post by:
The next Access Europe User Group meeting will be on Wednesday 1 May 2024 starting at 18:00 UK time (6PM UTC+1) and finishing by 19:30 (7.30PM). In this session, we are pleased to welcome a new presenter, Adolph Dupré who will be discussing some powerful techniques for using class modules. He will explain when you may want to use classes instead of User Defined Types (UDT). For example, to manage the data in unbound forms. Adolph will...
0
7040
by: conductexam | last post by:
I have .net C# application in which I am extracting data from word file and save it in database particularly. To store word all data as it is I am converting the whole word file firstly in HTML and then checking html paragraph one by one. At the time of converting from word file to html my equations which are in the word document file was convert into image. Globals.ThisAddIn.Application.ActiveDocument.Select();...
0
5886
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?
1
4500
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system
3
3146
bsmnconsultancy
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating effective websites that not only look great but also perform exceptionally well. In this comprehensive...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.