By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,971 Members | 900 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,971 IT Pros & Developers. It's quick & easy.

Unable to Debug because Integrated Windows Authentication is notEnabled

P: n/a
I've been having a problem debugging an ASP.NET 1.1 application on an
existing Windows XP/Visual Studio 2003 workstation that I've inherited
from somebody else. The application builds fine, but when I try to
debug, it gives me the message: Error When Trying to Run Project:
Unable to Start Debugging on the Web Server. Debugging failed because
integrated Windows authentication is not enabled.

Now, the obvious solution for this of course is to check the "Enable
Integrated Windows Authentication" box in IIS under Anonymous Access
and Authentication Control in the Directory Security Tab. The option
is checked, yet the error message is still appearing. I've checked it
for both the website itself and the virtual directory.

I think this may be project-related, it is an MCMS application, and
when I try to debug small test applications, they debug just fine,
only this particular large project gives me the debugging error. Any
ideas of what can cause this error, besides that checkbox being left
empty?
Feb 12 '08 #1
Share this Question
Share on Google+
11 Replies


P: n/a
Are you sure that it's (Integrated Windows Authentication) checked for all
folders/subfolders....
the easiest way is to check it at the root level and IIS management will ask
if you want it to apply to subfolders...
If it's checked already uncheck it hit apply then check it and hit apply.

George.

<be*****@gmail.comwrote in message
news:9b**********************************@e10g2000 prf.googlegroups.com...
I've been having a problem debugging an ASP.NET 1.1 application on an
existing Windows XP/Visual Studio 2003 workstation that I've inherited
from somebody else. The application builds fine, but when I try to
debug, it gives me the message: Error When Trying to Run Project:
Unable to Start Debugging on the Web Server. Debugging failed because
integrated Windows authentication is not enabled.

Now, the obvious solution for this of course is to check the "Enable
Integrated Windows Authentication" box in IIS under Anonymous Access
and Authentication Control in the Directory Security Tab. The option
is checked, yet the error message is still appearing. I've checked it
for both the website itself and the virtual directory.

I think this may be project-related, it is an MCMS application, and
when I try to debug small test applications, they debug just fine,
only this particular large project gives me the debugging error. Any
ideas of what can cause this error, besides that checkbox being left
empty?

Feb 12 '08 #2

P: n/a
Thanks for the quick reply. I've unchecked the box, applied the
changes to all subfolders, then checked it again and applied to all
subfolders, and the error is still appearing: Error When Trying to Run
Project:Unable to Start Debugging on the Web Server. Debugging failed
because integrated Windows authentication is not enabled.

Thank you for the suggestion though. Any other ideas?

On Feb 12, 4:46 pm, "George Ter-Saakov" <gt-...@cardone.comwrote:
Are you sure that it's (Integrated Windows Authentication) checked for all
folders/subfolders....
the easiest way is to check it at the root level and IIS management will ask
if you want it to apply to subfolders...
If it's checked already uncheck it hit apply then check it and hit apply.

George.

<beno...@gmail.comwrote in message

news:9b**********************************@e10g2000 prf.googlegroups.com...
I've been having a problem debugging an ASP.NET 1.1 application on an
existing Windows XP/Visual Studio 2003 workstation that I've inherited
from somebody else. The application builds fine, but when I try to
debug, it gives me the message: Error When Trying to Run Project:
Unable to Start Debugging on the Web Server. Debugging failed because
integrated Windows authentication is not enabled.
Now, the obvious solution for this of course is to check the "Enable
Integrated Windows Authentication" box in IIS under Anonymous Access
and Authentication Control in the Directory Security Tab. The option
is checked, yet the error message is still appearing. I've checked it
for both the website itself and the virtual directory.
I think this may be project-related, it is an MCMS application, and
when I try to debug small test applications, they debug just fine,
only this particular large project gives me the debugging error. Any
ideas of what can cause this error, besides that checkbox being left
empty?
Feb 12 '08 #3

P: n/a
Well, try to uncheck Anonymous so only Integrated is checked there.
Other than that try to Google this error cause I am out of suggestions....

PS: Is you project running without debugging? If you simply open it in the
browser?
George.
<be*****@gmail.comwrote in message
news:f0**********************************@i72g2000 hsd.googlegroups.com...
Thanks for the quick reply. I've unchecked the box, applied the
changes to all subfolders, then checked it again and applied to all
subfolders, and the error is still appearing: Error When Trying to Run
Project:Unable to Start Debugging on the Web Server. Debugging failed
because integrated Windows authentication is not enabled.

Thank you for the suggestion though. Any other ideas?

On Feb 12, 4:46 pm, "George Ter-Saakov" <gt-...@cardone.comwrote:
>Are you sure that it's (Integrated Windows Authentication) checked for
all
folders/subfolders....
the easiest way is to check it at the root level and IIS management will
ask
if you want it to apply to subfolders...
If it's checked already uncheck it hit apply then check it and hit apply.

George.

<beno...@gmail.comwrote in message

news:9b**********************************@e10g200 0prf.googlegroups.com...
I've been having a problem debugging an ASP.NET 1.1 application on an
existing Windows XP/Visual Studio 2003 workstation that I've inherited
from somebody else. The application builds fine, but when I try to
debug, it gives me the message: Error When Trying to Run Project:
Unable to Start Debugging on the Web Server. Debugging failed because
integrated Windows authentication is not enabled.
Now, the obvious solution for this of course is to check the "Enable
Integrated Windows Authentication" box in IIS under Anonymous Access
and Authentication Control in the Directory Security Tab. The option
is checked, yet the error message is still appearing. I've checked it
for both the website itself and the virtual directory.
I think this may be project-related, it is an MCMS application, and
when I try to debug small test applications, they debug just fine,
only this particular large project gives me the debugging error. Any
ideas of what can cause this error, besides that checkbox being left
empty?

Feb 12 '08 #4

P: n/a
Another suggestion....
Make sure that you have ASP.NET 1.1 version set for this application and not
2.0

It's in the IIS Management console (additional tab and it's there only if
you have ASP.NET 2.0 installed)

George.
<be*****@gmail.comwrote in message
news:f0**********************************@i72g2000 hsd.googlegroups.com...
Thanks for the quick reply. I've unchecked the box, applied the
changes to all subfolders, then checked it again and applied to all
subfolders, and the error is still appearing: Error When Trying to Run
Project:Unable to Start Debugging on the Web Server. Debugging failed
because integrated Windows authentication is not enabled.

Thank you for the suggestion though. Any other ideas?

On Feb 12, 4:46 pm, "George Ter-Saakov" <gt-...@cardone.comwrote:
>Are you sure that it's (Integrated Windows Authentication) checked for
all
folders/subfolders....
the easiest way is to check it at the root level and IIS management will
ask
if you want it to apply to subfolders...
If it's checked already uncheck it hit apply then check it and hit apply.

George.

<beno...@gmail.comwrote in message

news:9b**********************************@e10g200 0prf.googlegroups.com...
I've been having a problem debugging an ASP.NET 1.1 application on an
existing Windows XP/Visual Studio 2003 workstation that I've inherited
from somebody else. The application builds fine, but when I try to
debug, it gives me the message: Error When Trying to Run Project:
Unable to Start Debugging on the Web Server. Debugging failed because
integrated Windows authentication is not enabled.
Now, the obvious solution for this of course is to check the "Enable
Integrated Windows Authentication" box in IIS under Anonymous Access
and Authentication Control in the Directory Security Tab. The option
is checked, yet the error message is still appearing. I've checked it
for both the website itself and the virtual directory.
I think this may be project-related, it is an MCMS application, and
when I try to debug small test applications, they debug just fine,
only this particular large project gives me the debugging error. Any
ideas of what can cause this error, besides that checkbox being left
empty?

Feb 12 '08 #5

P: n/a
Thanks again for suggestions, but it is set to the correct ASP.NET
version. The project runs perfectly well if you simply open it in the
browser.

On Feb 12, 5:11 pm, "George Ter-Saakov" <gt-...@cardone.comwrote:
Another suggestion....
Make sure that you have ASP.NET 1.1 version set for this application and not
2.0

It's in the IIS Management console (additional tab and it's there only if
you have ASP.NET 2.0 installed)

George.

<beno...@gmail.comwrote in message

news:f0**********************************@i72g2000 hsd.googlegroups.com...
Thanks for the quick reply. I've unchecked the box, applied the
changes to all subfolders, then checked it again and applied to all
subfolders, and the error is still appearing: Error When Trying to Run
Project:Unable to Start Debugging on the Web Server. Debugging failed
because integrated Windows authentication is not enabled.
Thank you for the suggestion though. Any other ideas?
On Feb 12, 4:46 pm, "George Ter-Saakov" <gt-...@cardone.comwrote:
Are you sure that it's (Integrated Windows Authentication) checked for
all
folders/subfolders....
the easiest way is to check it at the root level and IIS management will
ask
if you want it to apply to subfolders...
If it's checked already uncheck it hit apply then check it and hit apply.
George.
<beno...@gmail.comwrote in message
>news:9b**********************************@e10g200 0prf.googlegroups.com...
I've been having a problem debugging an ASP.NET 1.1 application on an
existing Windows XP/Visual Studio 2003 workstation that I've inherited
from somebody else. The application builds fine, but when I try to
debug, it gives me the message: Error When Trying to Run Project:
Unable to Start Debugging on the Web Server. Debugging failed because
integrated Windows authentication is not enabled.
Now, the obvious solution for this of course is to check the "Enable
Integrated Windows Authentication" box in IIS under Anonymous Access
and Authentication Control in the Directory Security Tab. The option
is checked, yet the error message is still appearing. I've checked it
for both the website itself and the virtual directory.
I think this may be project-related, it is an MCMS application, and
when I try to debug small test applications, they debug just fine,
only this particular large project gives me the debugging error. Any
ideas of what can cause this error, besides that checkbox being left
empty?
Feb 12 '08 #6

P: n/a
Open up the .csproj / .vbproj file in Notepad.exe and look at the url that
is specified for the project. It may be wrong.
-- Peter
Site: http://www.eggheadcafe.com
UnBlog: http://petesbloggerama.blogspot.com
MetaFinder: http://www.blogmetafinder.com
"be*****@gmail.com" wrote:
Thanks again for suggestions, but it is set to the correct ASP.NET
version. The project runs perfectly well if you simply open it in the
browser.

On Feb 12, 5:11 pm, "George Ter-Saakov" <gt-...@cardone.comwrote:
Another suggestion....
Make sure that you have ASP.NET 1.1 version set for this application and not
2.0

It's in the IIS Management console (additional tab and it's there only if
you have ASP.NET 2.0 installed)

George.

<beno...@gmail.comwrote in message

news:f0**********************************@i72g2000 hsd.googlegroups.com...
Thanks for the quick reply. I've unchecked the box, applied the
changes to all subfolders, then checked it again and applied to all
subfolders, and the error is still appearing: Error When Trying to Run
Project:Unable to Start Debugging on the Web Server. Debugging failed
because integrated Windows authentication is not enabled.
Thank you for the suggestion though. Any other ideas?
On Feb 12, 4:46 pm, "George Ter-Saakov" <gt-...@cardone.comwrote:
>Are you sure that it's (Integrated Windows Authentication) checked for
>all
>folders/subfolders....
>the easiest way is to check it at the root level and IIS management will
>ask
>if you want it to apply to subfolders...
>If it's checked already uncheck it hit apply then check it and hit apply.
>George.
><beno...@gmail.comwrote in message
>>news:9b**********************************@e10g20 00prf.googlegroups.com...
I've been having a problem debugging an ASP.NET 1.1 application on an
existing Windows XP/Visual Studio 2003 workstation that I've inherited
from somebody else. The application builds fine, but when I try to
debug, it gives me the message: Error When Trying to Run Project:
Unable to Start Debugging on the Web Server. Debugging failed because
integrated Windows authentication is not enabled.
Now, the obvious solution for this of course is to check the "Enable
Integrated Windows Authentication" box in IIS under Anonymous Access
and Authentication Control in the Directory Security Tab. The option
is checked, yet the error message is still appearing. I've checked it
for both the website itself and the virtual directory.
I think this may be project-related, it is an MCMS application, and
when I try to debug small test applications, they debug just fine,
only this particular large project gives me the debugging error. Any
ideas of what can cause this error, besides that checkbox being left
empty?

Feb 13 '08 #7

P: n/a
Another good idea, but the information in the CSPROJ file looks
correct. I appreciate all the suggestions though, anybody else have
any ideas?

On Feb 12, 8:15 pm, Peter Bromberg [C# MVP]
<pbromb...@yahoo.NoSpamMaam.comwrote:
Open up the .csproj / .vbproj file in Notepad.exe and look at the url that
is specified for the project. It may be wrong.
-- Peter
Site:http://www.eggheadcafe.com
UnBlog:http://petesbloggerama.blogspot.com
MetaFinder:http://www.blogmetafinder.com

"beno...@gmail.com" wrote:
Thanks again for suggestions, but it is set to the correct ASP.NET
version. The project runs perfectly well if you simply open it in the
browser.
On Feb 12, 5:11 pm, "George Ter-Saakov" <gt-...@cardone.comwrote:
Another suggestion....
Make sure that you have ASP.NET 1.1 version set for this application and not
2.0
It's in the IIS Management console (additional tab and it's there only if
you have ASP.NET 2.0 installed)
George.
<beno...@gmail.comwrote in message
>news:f0**********************************@i72g200 0hsd.googlegroups.com...
Thanks for the quick reply. I've unchecked the box, applied the
changes to all subfolders, then checked it again and applied to all
subfolders, and the error is still appearing: Error When Trying to Run
Project:Unable to Start Debugging on the Web Server. Debugging failed
because integrated Windows authentication is not enabled.
Thank you for the suggestion though. Any other ideas?
On Feb 12, 4:46 pm, "George Ter-Saakov" <gt-...@cardone.comwrote:
Are you sure that it's (Integrated Windows Authentication) checked for
all
folders/subfolders....
the easiest way is to check it at the root level and IIS management will
ask
if you want it to apply to subfolders...
If it's checked already uncheck it hit apply then check it and hit apply.
George.
<beno...@gmail.comwrote in message
>news:9b**********************************@e10g200 0prf.googlegroups.com...
I've been having a problem debugging an ASP.NET 1.1 application on an
existing Windows XP/Visual Studio 2003 workstation that I've inherited
from somebody else. The application builds fine, but when I try to
debug, it gives me the message: Error When Trying to Run Project:
Unable to Start Debugging on the Web Server. Debugging failed because
integrated Windows authentication is not enabled.
Now, the obvious solution for this of course is to check the "Enable
Integrated Windows Authentication" box in IIS under Anonymous Access
and Authentication Control in the Directory Security Tab. The option
is checked, yet the error message is still appearing. I've checked it
for both the website itself and the virtual directory.
I think this may be project-related, it is an MCMS application, and
when I try to debug small test applications, they debug just fine,
only this particular large project gives me the debugging error. Any
ideas of what can cause this error, besides that checkbox being left
empty?
Feb 13 '08 #8

P: n/a
if you have an impersonation account in the web config, it must be a local
admin and added to the debuggers users group.

you can also try disabling anonymous.

-- bruce (sqlwork.com)
"be*****@gmail.com" wrote:
I've been having a problem debugging an ASP.NET 1.1 application on an
existing Windows XP/Visual Studio 2003 workstation that I've inherited
from somebody else. The application builds fine, but when I try to
debug, it gives me the message: Error When Trying to Run Project:
Unable to Start Debugging on the Web Server. Debugging failed because
integrated Windows authentication is not enabled.

Now, the obvious solution for this of course is to check the "Enable
Integrated Windows Authentication" box in IIS under Anonymous Access
and Authentication Control in the Directory Security Tab. The option
is checked, yet the error message is still appearing. I've checked it
for both the website itself and the virtual directory.

I think this may be project-related, it is an MCMS application, and
when I try to debug small test applications, they debug just fine,
only this particular large project gives me the debugging error. Any
ideas of what can cause this error, besides that checkbox being left
empty?
Feb 13 '08 #9

P: n/a
Haha I wish one of these times I could reply with better news. The
web.config doesn't use impersonation, the user is a member of the
debugger's group, and the problem persists whether or not anonymous
access is checked. You can see why this is such an annoying problem.
I hope the answer doesn't turn out to be anything too ridiculous. Any
other ideas would be greatly appreciated.

On Feb 13, 12:12 pm, bruce barker
<brucebar...@discussions.microsoft.comwrote:
if you have an impersonation account in the web config, it must be a local
admin and added to the debuggers users group.

you can also try disabling anonymous.

-- bruce (sqlwork.com)

"beno...@gmail.com" wrote:
I've been having a problem debugging an ASP.NET 1.1 application on an
existing Windows XP/Visual Studio 2003 workstation that I've inherited
from somebody else. The application builds fine, but when I try to
debug, it gives me the message: Error When Trying to Run Project:
Unable to Start Debugging on the Web Server. Debugging failed because
integrated Windows authentication is not enabled.
Now, the obvious solution for this of course is to check the "Enable
Integrated Windows Authentication" box in IIS under Anonymous Access
and Authentication Control in the Directory Security Tab. The option
is checked, yet the error message is still appearing. I've checked it
for both the website itself and the virtual directory.
I think this may be project-related, it is an MCMS application, and
when I try to debug small test applications, they debug just fine,
only this particular large project gives me the debugging error. Any
ideas of what can cause this error, besides that checkbox being left
empty?
Feb 13 '08 #10

P: n/a
Haha I wish one of these times I could reply with better news. The
web.config doesn't use impersonation, the user is a member of the
debugger's group, and the problem persists whether or not anonymous
access is checked. You can see why this is such an annoying problem.
I hope the answer doesn't turn out to be anything too ridiculous. Any
other ideas would be greatly appreciated.

On Feb 13, 12:12 pm, bruce barker
<brucebar...@discussions.microsoft.comwrote:
if you have an impersonation account in the web config, it must be a local
admin and added to the debuggers users group.

you can also try disabling anonymous.

-- bruce (sqlwork.com)

"beno...@gmail.com" wrote:
I've been having a problem debugging an ASP.NET 1.1 application on an
existing Windows XP/Visual Studio 2003 workstation that I've inherited
from somebody else. The application builds fine, but when I try to
debug, it gives me the message: Error When Trying to Run Project:
Unable to Start Debugging on the Web Server. Debugging failed because
integrated Windows authentication is not enabled.
Now, the obvious solution for this of course is to check the "Enable
Integrated Windows Authentication" box in IIS under Anonymous Access
and Authentication Control in the Directory Security Tab. The option
is checked, yet the error message is still appearing. I've checked it
for both the website itself and the virtual directory.
I think this may be project-related, it is an MCMS application, and
when I try to debug small test applications, they debug just fine,
only this particular large project gives me the debugging error. Any
ideas of what can cause this error, besides that checkbox being left
empty?
Feb 13 '08 #11

P: n/a
Haha I wish one of these times I could reply with better news. The
web.config doesn't use impersonation, the user is a member of the
debugger's group, and the problem persists whether or not anonymous
access is checked. You can see why this is such an annoying problem.
I hope the answer doesn't turn out to be anything too ridiculous. Any
other ideas would be greatly appreciated.

On Feb 13, 12:12 pm, bruce barker
<brucebar...@discussions.microsoft.comwrote:
if you have an impersonation account in the web config, it must be a local
admin and added to the debuggers users group.

you can also try disabling anonymous.

-- bruce (sqlwork.com)

"beno...@gmail.com" wrote:
I've been having a problem debugging an ASP.NET 1.1 application on an
existing Windows XP/Visual Studio 2003 workstation that I've inherited
from somebody else. The application builds fine, but when I try to
debug, it gives me the message: Error When Trying to Run Project:
Unable to Start Debugging on the Web Server. Debugging failed because
integrated Windows authentication is not enabled.
Now, the obvious solution for this of course is to check the "Enable
Integrated Windows Authentication" box in IIS under Anonymous Access
and Authentication Control in the Directory Security Tab. The option
is checked, yet the error message is still appearing. I've checked it
for both the website itself and the virtual directory.
I think this may be project-related, it is an MCMS application, and
when I try to debug small test applications, they debug just fine,
only this particular large project gives me the debugging error. Any
ideas of what can cause this error, besides that checkbox being left
empty?
Feb 13 '08 #12

This discussion thread is closed

Replies have been disabled for this discussion.