469,076 Members | 1,305 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,076 developers. It's quick & easy.

Famous error - Unable to start debugging on the webserver: Details inside

Hi,

I made the unfortunate mistake of installing Windows 2000 Service Pack
4 and .NET Framework 1.0 Service Pack 2 on a development machine
(1.0.3705.288). This broke the Visual Studio .NET IDE. However, the
Fixxml.exe at Microsoft.com fixed that issue. We developed without
issue for the rest of the day (mostly javascript/related client side
code) but then the famous "Error trying to run project: Unable to
start debugging on the web server: Would you like to disable...."
cropped up.

These are the following steps that we have taken to resolve this
problem, all of which were unsuccessful (Debugging worked prior to
SP4/.Net SP2):

Verified web.config debug=true in the specific application
Verified no syntax errors in web.config
Verified users in Debugger Users/Administrators
Verified project creation was by NetBIOS name rather than IP address
Verified Anonymous ACcess/Integrated Windows Authentication enabled
Verified DEBUG keywords in configuration for .aspx, .asax, .asmx

Virtual folders for the applications were assigned, but the
application name dialog boxes were blank. Assigned names to the
applications corresponding to the actual project names.

Ran aspnet_regiis.exe -r. This enabled the new 1.0.3705.288
aspnet_wp.exe to be assigned to all scriptmappings.

Ran regsvr32
%SYSTEMROOT$\Microsoft.NET\Framework\v1.0.3705\asp net_isapi.dll

Ran iisreset multiple times.

I cannot verify that vs.net remote components are installed for this
version of .net (.288). I also have not of course rebuilt the .net
framework yet, as my boss has asked me not to until I get some
responses to this news post.

Can anyone advise on best way to solve this?

Nov 17 '05 #1
3 2214
I also just added the ASPNET user to the Administrators group and
Debuggers group. Still doesn't work.
On Thu, 07 Aug 2003 11:43:24 -0500, loser <lo***@loser.com> wrote:
Hi,

I made the unfortunate mistake of installing Windows 2000 Service Pack
4 and .NET Framework 1.0 Service Pack 2 on a development machine
(1.0.3705.288). This broke the Visual Studio .NET IDE. However, the
Fixxml.exe at Microsoft.com fixed that issue. We developed without
issue for the rest of the day (mostly javascript/related client side
code) but then the famous "Error trying to run project: Unable to
start debugging on the web server: Would you like to disable...."
cropped up.

These are the following steps that we have taken to resolve this
problem, all of which were unsuccessful (Debugging worked prior to
SP4/.Net SP2):

Verified web.config debug=true in the specific application
Verified no syntax errors in web.config
Verified users in Debugger Users/Administrators
Verified project creation was by NetBIOS name rather than IP address
Verified Anonymous ACcess/Integrated Windows Authentication enabled
Verified DEBUG keywords in configuration for .aspx, .asax, .asmx

Virtual folders for the applications were assigned, but the
application name dialog boxes were blank. Assigned names to the
applications corresponding to the actual project names.

Ran aspnet_regiis.exe -r. This enabled the new 1.0.3705.288
aspnet_wp.exe to be assigned to all scriptmappings.

Ran regsvr32
%SYSTEMROOT$\Microsoft.NET\Framework\v1.0.3705\as pnet_isapi.dll

Ran iisreset multiple times.

I cannot verify that vs.net remote components are installed for this
version of .net (.288). I also have not of course rebuilt the .net
framework yet, as my boss has asked me not to until I get some
responses to this news post.

Can anyone advise on best way to solve this?


Nov 17 '05 #2
Hi,

I made the unfortunate mistake of installing Windows 2000 Service Pack
4 and .NET Framework 1.0 Service Pack 2 on a development machine
(1.0.3705.288). This broke the Visual Studio .NET IDE. However, the
Fixxml.exe at Microsoft.com fixed that issue. We developed without
issue for the rest of the day (mostly javascript/related client side
code) but then the famous "Error trying to run project: Unable to
start debugging on the web server: Would you like to disable...."
cropped up.

These are the following steps that we have taken to resolve this
problem, all of which were unsuccessful (Debugging worked prior to
SP4/.Net SP2):

Verified web.config debug=true in the specific application
Verified no syntax errors in web.config
Verified users in Debugger Users/Administrators
Verified project creation was by NetBIOS name rather than IP address
Verified Anonymous ACcess/Integrated Windows Authentication enabled
Verified DEBUG keywords in configuration for .aspx, .asax, .asmx

Virtual folders for the applications were assigned, but the
application name dialog boxes were blank. Assigned names to the
applications corresponding to the actual project names.

Ran aspnet_regiis.exe -r. This enabled the new 1.0.3705.288
aspnet_wp.exe to be assigned to all scriptmappings.

Ran regsvr32
%SYSTEMROOT$\Microsoft.NET\Framework\v1.0.3705\as pnet_isapi.dll

Ran iisreset multiple times.

I cannot verify that vs.net remote components are installed for this
version of .net (.288). I also have not of course rebuilt the .net
framework yet, as my boss has asked me not to until I get some
responses to this news post.

Can anyone advise on best way to solve this?


Nov 17 '05 #3

I have now reinstalled .net framework according to the "rebuild"
instructions...it still doesn't work.

I am nearing the end of my rope here.

On Thu, 07 Aug 2003 11:43:24 -0500, loser <lo***@loser.com> wrote:
Hi,

I made the unfortunate mistake of installing Windows 2000 Service Pack
4 and .NET Framework 1.0 Service Pack 2 on a development machine
(1.0.3705.288). This broke the Visual Studio .NET IDE. However, the
Fixxml.exe at Microsoft.com fixed that issue. We developed without
issue for the rest of the day (mostly javascript/related client side
code) but then the famous "Error trying to run project: Unable to
start debugging on the web server: Would you like to disable...."
cropped up.

These are the following steps that we have taken to resolve this
problem, all of which were unsuccessful (Debugging worked prior to
SP4/.Net SP2):

Verified web.config debug=true in the specific application
Verified no syntax errors in web.config
Verified users in Debugger Users/Administrators
Verified project creation was by NetBIOS name rather than IP address
Verified Anonymous ACcess/Integrated Windows Authentication enabled
Verified DEBUG keywords in configuration for .aspx, .asax, .asmx

Virtual folders for the applications were assigned, but the
application name dialog boxes were blank. Assigned names to the
applications corresponding to the actual project names.

Ran aspnet_regiis.exe -r. This enabled the new 1.0.3705.288
aspnet_wp.exe to be assigned to all scriptmappings.

Ran regsvr32
%SYSTEMROOT$\Microsoft.NET\Framework\v1.0.3705\as pnet_isapi.dll

Ran iisreset multiple times.

I cannot verify that vs.net remote components are installed for this
version of .net (.288). I also have not of course rebuilt the .net
framework yet, as my boss has asked me not to until I get some
responses to this news post.

Can anyone advise on best way to solve this?


Nov 17 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Matt | last post: by
5 posts views Thread by Bruce Schechter | last post: by
4 posts views Thread by mcwooq | last post: by
1 post views Thread by CARIGAR | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.