By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
443,652 Members | 1,335 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 443,652 IT Pros & Developers. It's quick & easy.

How to Avoid Dynamic Port in VS 2005.

P: n/a
BSM
I have created one Web Service in VS 2005 Team Edition. In the Website
Creation Template, I chose "HTTP".

When I run the application, the URL was like this

http://localhost:1245/WebServ1/Service.asmx

When I try to include this WebService in another app, I was in the
situation to include the Port number. Then only it works. Othewise it
doesn't sense the web service.

Anybody please help me.

Senthil

Mar 14 '07 #1
Share this Question
Share on Google+
4 Replies


P: n/a

There are two way to solve this issue.

1. In properties of your website, uncheck "Auto Assign port" and check
"Specific port" and give any port like 1235. And then from your other
project, you can refer your webservice using fixed port.

2. Or use IIS instead of visual studio own development server. IIS always
run on port 80 means no port in url.

Thanks
Shahzad Godil

"BSM" <se************@angleritech.comwrote in message
news:11**********************@y66g2000hsf.googlegr oups.com...
>I have created one Web Service in VS 2005 Team Edition. In the Website
Creation Template, I chose "HTTP".

When I run the application, the URL was like this

http://localhost:1245/WebServ1/Service.asmx

When I try to include this WebService in another app, I was in the
situation to include the Port number. Then only it works. Othewise it
doesn't sense the web service.

Anybody please help me.

Senthil

Mar 14 '07 #2

P: n/a
On Mar 14, 7:05 am, "BSM" <senthilmuru...@angleritech.comwrote:
I have created one Web Service in VS 2005 Team Edition. In the Website
Creation Template, I chose "HTTP".

When I run the application, the URL was like this

http://localhost:1245/WebServ1/Service.asmx

When I try to include this WebService in another app, I was in the
situation to include the Port number. Then only it works. Othewise it
doesn't sense the web service.

Anybody please help me.

Senthil
In the project properties, choose the Web Tab and hard-code a Specific
Port to launch the web under.

Hope this helps,

Mar 14 '07 #3

P: n/a
On 14 Mar., 07:05, "BSM" <senthilmuru...@angleritech.comwrote:
http://localhost:1245/WebServ1/Service.asmx
When I try to include this WebService in another app, I was in the
situation to include the Port number. Then only it works. Othewise it
doesn't sense the web service.
Anybody please help me.
Take a look at
http://weblogs.asp.net/scottgu/archi...-2005-sp1.aspx

Mar 14 '07 #4

P: n/a
BSM
Hi,

Thanks to ALL.

As you said, I changed the settings and its working fine.

Regards
Senthil

On Mar 14, 1:57 pm, "Henrik Stidsen" <henrikstid...@gmail.comwrote:
On 14 Mar., 07:05, "BSM" <senthilmuru...@angleritech.comwrote:
http://localhost:1245/WebServ1/Service.asmx
When I try to include this WebService in another app, I was in the
situation to include the Port number. Then only it works. Othewise it
doesn't sense the web service.
Anybody please help me.

Take a look athttp://weblogs.asp.net/scottgu/archive/2006/12/19/tip-trick-how-to-ru...

Mar 15 '07 #5

This discussion thread is closed

Replies have been disabled for this discussion.