By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
448,773 Members | 1,838 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 448,773 IT Pros & Developers. It's quick & easy.

Problems with application configuration (web.config)

P: n/a
To all,

I am experiencing difficulties with an asp.net web application and its
web.config file. No matter what I try I keep getting the following error:

Server Error in '/action' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrors> configuration tag to point to a custom error page URL.
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

Originally, I thought this was a configuration issue. I have performed the
following tasks, but nothing has worked:

1. Configured the application as a virtual directory and application under
IIS.
2. Modified the asp.net worker process under machine.config to give it full
system privleges (user="System")
3. Added the ASP.NET user account to my administrators group.

The same error still happens. I am running on a Windows 2000 Server, with
IIS 5.0, and on the 1.1 .NET Framework.

If anyone has a suggestion, I would greatly appreciate it.

Thanks,

Chris...
Nov 19 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Try reinstalling asp.net. Open a command prompt and type aspnet_regiis
-i.

Nov 19 '05 #2

P: n/a
Chris:

You really should set the custom errors mode to Off and get a detailed
exception message, otherwise it's impossible to guess at the possible
reason for the error.

--
Scott
http://www.OdeToCode.com/blogs/scott/

On Wed, 22 Dec 2004 11:49:02 -0800, "Chris_24"
<Ch******@discussions.microsoft.com> wrote:
To all,

I am experiencing difficulties with an asp.net web application and its
web.config file. No matter what I try I keep getting the following error:

Server Error in '/action' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrors> configuration tag to point to a custom error page URL.
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

Originally, I thought this was a configuration issue. I have performed the
following tasks, but nothing has worked:

1. Configured the application as a virtual directory and application under
IIS.
2. Modified the asp.net worker process under machine.config to give it full
system privleges (user="System")
3. Added the ASP.NET user account to my administrators group.

The same error still happens. I am running on a Windows 2000 Server, with
IIS 5.0, and on the 1.1 .NET Framework.

If anyone has a suggestion, I would greatly appreciate it.

Thanks,

Chris...


Nov 19 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.