By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,828 Members | 1,862 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,828 IT Pros & Developers. It's quick & easy.

Server Error in '/' Application. -> web.config

P: n/a
hello everbody,

i write a little asp-application with forms-authentication.
i copy my aspx-files with web.config to my webspace and i get the
error above...

i tried to set the custom-errors-tag ="off"
but nothing happens....

what is my failure????

could someone help me please?

thanks a lot

tommy

<?xml version="1.0" encoding="utf-8" ?>
<configuration>

<system.web>

<!-- DYNAMIC DEBUG COMPILATION
Set compilation debug="true" to insert debugging symbols
(.pdb information)
into the compiled page. Because this creates a larger file
that executes
more slowly, you should set this value to true only when
debugging and to
false at all other times. For more information, refer to the
documentation about
debugging ASP.NET files.
-->
<compilation defaultLanguage="vb" debug="true" />

<!-- CUSTOM ERROR MESSAGES
Set customErrors mode="On" or "RemoteOnly" to enable custom
error messages, "Off" to disable.
Add <error> tags for each of the errors you want to handle.
-->
<customErrors mode="off" />

<!-- AUTHENTICATION
This section sets the authentication policies of the
application. Possible modes are "Windows",
"Forms", "Passport" and "None"
-->
<authentication mode="Forms" >
<forms name="LogOnCookie" path="/" loginUrl="login.aspx"
protection="All" timeout="25">
<credentials passwordFormat="Clear">
<user name="tommy" password="sonja"/>
</credentials>
</forms>
</authentication>

<!-- AUTHORIZATION
This section sets the authorization policies of the
application. You can allow or deny access
to application resources by user or role. Wildcards: "*"
mean everyone, "?" means anonymous
(unauthenticated) users.
-->
<authorization>
<allow users="*" /> <!-- Allow all users -->

<!-- <allow users="[comma separated list of users]"
roles="[comma separated list of roles]"/>
<deny users="[comma separated list of users]"
roles="[comma separated list of roles]"/>
-->
</authorization>

<!-- APPLICATION-LEVEL TRACE LOGGING
Application-level tracing enables trace log output for every
page within an application.
Set trace enabled="true" to enable application trace
logging. If pageOutput="true", the
trace information will be displayed at the bottom of each
page. Otherwise, you can view the
application trace log by browsing the "trace.axd" page from
your web application
root.
-->
<trace enabled="false" requestLimit="10" pageOutput="false"
traceMode="SortByTime" localOnly="true" />
<!-- SESSION STATE SETTINGS
By default ASP.NET uses cookies to identify which requests
belong to a particular session.
If cookies are not available, a session can be tracked by
adding a session identifier to the URL.
To disable cookies, set sessionState cookieless="true".
-->
<sessionState
mode="InProc"
stateConnectionString="tcpip=127.0.0.1:42424"
sqlConnectionString="data source=127.0.0.1;user
id=sa;password="
cookieless="false"
timeout="20"
/>

<!-- GLOBALIZATION
This section sets the globalization settings of the
application.
-->
<globalization requestEncoding="utf-8" responseEncoding="utf-8" />

</system.web>

</configuration>
Nov 18 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Tommy,

What is the exact error message you are seeing?

Jim Cheshire, MCSE, MCSD [MSFT]
Microsoft Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
From: th***********@hannover-leasing.de (tommy)
Newsgroups: microsoft.public.dotnet.framework.aspnet
Subject: Server Error in '/' Application. -> web.config
Date: 31 Dec 2003 08:21:18 -0800
Organization: http://groups.google.com
Lines: 113
Message-ID: <8f**************************@posting.google.com >
NNTP-Posting-Host: 82.135.0.124
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 8bit
X-Trace: posting.google.com 1072887678 31017 127.0.0.1 (31 Dec 2003 16:21:18 GMT)X-Complaints-To: gr**********@google.com
NNTP-Posting-Date: Wed, 31 Dec 2003 16:21:18 +0000 (UTC)
Path: cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTN GP08.phx.gbl!newsfeed00.su
l.t-online.de!t-online.de!newsfeed.icl.net!newsfeed.fjserv.net!pro xad.net!ne
ws-out.visi.com!petbe.visi.com!newsfeed2.dallas1.leve l3.net!news.level3.com!
postnews1.google.com!not-for-mailXref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:199121
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

hello everbody,

i write a little asp-application with forms-authentication.
i copy my aspx-files with web.config to my webspace and i get the
error above...

i tried to set the custom-errors-tag ="off"
but nothing happens....

what is my failure????

could someone help me please?

thanks a lot

tommy

<?xml version="1.0" encoding="utf-8" ?>
<configuration>

<system.web>

<!-- DYNAMIC DEBUG COMPILATION
Set compilation debug="true" to insert debugging symbols
(.pdb information)
into the compiled page. Because this creates a larger file
that executes
more slowly, you should set this value to true only when
debugging and to
false at all other times. For more information, refer to the
documentation about
debugging ASP.NET files.
-->
<compilation defaultLanguage="vb" debug="true" />

<!-- CUSTOM ERROR MESSAGES
Set customErrors mode="On" or "RemoteOnly" to enable custom
error messages, "Off" to disable.
Add <error> tags for each of the errors you want to handle.
-->
<customErrors mode="off" />

<!-- AUTHENTICATION
This section sets the authentication policies of the
application. Possible modes are "Windows",
"Forms", "Passport" and "None"
-->
<authentication mode="Forms" >
<forms name="LogOnCookie" path="/" loginUrl="login.aspx"
protection="All" timeout="25">
<credentials passwordFormat="Clear">
<user name="tommy" password="sonja"/>
</credentials>
</forms>
</authentication>

<!-- AUTHORIZATION
This section sets the authorization policies of the
application. You can allow or deny access
to application resources by user or role. Wildcards: "*"
mean everyone, "?" means anonymous
(unauthenticated) users.
-->
<authorization>
<allow users="*" /> <!-- Allow all users -->

<!-- <allow users="[comma separated list of users]"
roles="[comma separated list of roles]"/>
<deny users="[comma separated list of users]"
roles="[comma separated list of roles]"/>
-->
</authorization>

<!-- APPLICATION-LEVEL TRACE LOGGING
Application-level tracing enables trace log output for every
page within an application.
Set trace enabled="true" to enable application trace
logging. If pageOutput="true", the
trace information will be displayed at the bottom of each
page. Otherwise, you can view the
application trace log by browsing the "trace.axd" page from
your web application
root.
-->
<trace enabled="false" requestLimit="10" pageOutput="false"
traceMode="SortByTime" localOnly="true" />
<!-- SESSION STATE SETTINGS
By default ASP.NET uses cookies to identify which requests
belong to a particular session.
If cookies are not available, a session can be tracked by
adding a session identifier to the URL.
To disable cookies, set sessionState cookieless="true".
-->
<sessionState
mode="InProc"
stateConnectionString="tcpip=127.0.0.1:42424"
sqlConnectionString="data source=127.0.0.1;user
id=sa;password="
cookieless="false"
timeout="20"
/>

<!-- GLOBALIZATION
This section sets the globalization settings of the
application.
-->
<globalization requestEncoding="utf-8" responseEncoding="utf-8" />

</system.web>

</configuration>


Nov 18 '05 #2

P: n/a
Hello Jim,

the exactly error-message:

Server Error in '/' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current
custom error settings for this application prevent the details of the
application error from being viewed remotely (for security reasons).
It could, however, be viewed by browsers running on the local server
machine.

Details: To enable the details of this specific error message to be
viewable on remote machines, please create a <customErrors> tag within
a "web.config" configuration file located in the root directory of the
current web application. This <customErrors> tag should then have its
"mode" attribute set to "Off".
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a
custom error page by modifying the "defaultRedirect" attribute of the
application's <customErrors> configuration tag to point to a custom
error page URL.
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly"
defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

on my local computer, all works fine.... but not on webspace
at the end --> my web.config

tommy
ja******@online.microsoft.com (Jim Cheshire [MSFT]) wrote in message news:<zA*************@cpmsftngxa07.phx.gbl>...
Tommy,

What is the exact error message you are seeing?

Jim Cheshire, MCSE, MCSD [MSFT]
Microsoft Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.


hello everbody,

i write a little asp-application with forms-authentication.
i copy my aspx-files with web.config to my webspace and i get the
error above...

i tried to set the custom-errors-tag ="off"
but nothing happens....

what is my failure????

could someone help me please?

thanks a lot

tommy

<?xml version="1.0" encoding="utf-8" ?>
<configuration>

<system.web>

<!-- DYNAMIC DEBUG COMPILATION
Set compilation debug="true" to insert debugging symbols
(.pdb information)
into the compiled page. Because this creates a larger file
that executes
more slowly, you should set this value to true only when
debugging and to
false at all other times. For more information, refer to the
documentation about
debugging ASP.NET files.
-->
<compilation defaultLanguage="vb" debug="true" />

<!-- CUSTOM ERROR MESSAGES
Set customErrors mode="On" or "RemoteOnly" to enable custom
error messages, "Off" to disable.
Add <error> tags for each of the errors you want to handle.
-->
<customErrors mode="off" />

<!-- AUTHENTICATION
This section sets the authentication policies of the
application. Possible modes are "Windows",
"Forms", "Passport" and "None"
-->
<authentication mode="Forms" >
<forms name="LogOnCookie" path="/" loginUrl="login.aspx"
protection="All" timeout="25">
<credentials passwordFormat="Clear">
<user name="tommy" password="sonja"/>
</credentials>
</forms>
</authentication>

<!-- AUTHORIZATION
This section sets the authorization policies of the
application. You can allow or deny access
to application resources by user or role. Wildcards: "*"
mean everyone, "?" means anonymous
(unauthenticated) users.
-->
<authorization>
<allow users="*" /> <!-- Allow all users -->

<!-- <allow users="[comma separated list of users]"
roles="[comma separated list of roles]"/>
<deny users="[comma separated list of users]"
roles="[comma separated list of roles]"/>
-->
</authorization>

<!-- APPLICATION-LEVEL TRACE LOGGING
Application-level tracing enables trace log output for every
page within an application.
Set trace enabled="true" to enable application trace
logging. If pageOutput="true", the
trace information will be displayed at the bottom of each
page. Otherwise, you can view the
application trace log by browsing the "trace.axd" page from
your web application
root.
-->
<trace enabled="false" requestLimit="10" pageOutput="false"
traceMode="SortByTime" localOnly="true" />
<!-- SESSION STATE SETTINGS
By default ASP.NET uses cookies to identify which requests
belong to a particular session.
If cookies are not available, a session can be tracked by
adding a session identifier to the URL.
To disable cookies, set sessionState cookieless="true".
-->
<sessionState
mode="InProc"
stateConnectionString="tcpip=127.0.0.1:42424"
sqlConnectionString="data source=127.0.0.1;user
id=sa;password="
cookieless="false"
timeout="20"
/>

<!-- GLOBALIZATION
This section sets the globalization settings of the
application.
-->
<globalization requestEncoding="utf-8" responseEncoding="utf-8" />

</system.web>

</configuration>

Nov 18 '05 #3

P: n/a
It looks like the case is incorrect for the mode attribute value. You need a
capital "O"

Yours:
<customErrors mode="off" />

Should be:
<customErrors mode="Off"/>
"tommy" <th***********@hannover-leasing.de> wrote in message
news:8f*************************@posting.google.co m...
Hello Jim,

the exactly error-message:

Server Error in '/' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current
custom error settings for this application prevent the details of the
application error from being viewed remotely (for security reasons).
It could, however, be viewed by browsers running on the local server
machine.

Details: To enable the details of this specific error message to be
viewable on remote machines, please create a <customErrors> tag within
a "web.config" configuration file located in the root directory of the
current web application. This <customErrors> tag should then have its
"mode" attribute set to "Off".
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a
custom error page by modifying the "defaultRedirect" attribute of the
application's <customErrors> configuration tag to point to a custom
error page URL.
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly"
defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

on my local computer, all works fine.... but not on webspace
at the end --> my web.config

tommy
ja******@online.microsoft.com (Jim Cheshire [MSFT]) wrote in message
news:<zA*************@cpmsftngxa07.phx.gbl>...
Tommy,

What is the exact error message you are seeing?

Jim Cheshire, MCSE, MCSD [MSFT]
Microsoft Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

>
>hello everbody,
>
>i write a little asp-application with forms-authentication.
>i copy my aspx-files with web.config to my webspace and i get the
>error above...
>
>i tried to set the custom-errors-tag ="off"
>but nothing happens....
>
>what is my failure????
>
>could someone help me please?
>
>thanks a lot
>
>tommy
>
><?xml version="1.0" encoding="utf-8" ?>
><configuration>
>
> <system.web>
>
> <!-- DYNAMIC DEBUG COMPILATION
> Set compilation debug="true" to insert debugging symbols
>(.pdb information)
> into the compiled page. Because this creates a larger file
>that executes
> more slowly, you should set this value to true only when
>debugging and to
> false at all other times. For more information, refer to the
>documentation about
> debugging ASP.NET files.
> -->
> <compilation defaultLanguage="vb" debug="true" />
>
> <!-- CUSTOM ERROR MESSAGES
> Set customErrors mode="On" or "RemoteOnly" to enable custom
>error messages, "Off" to disable.
> Add <error> tags for each of the errors you want to handle.
> -->
> <customErrors mode="off" />
>
> <!-- AUTHENTICATION
> This section sets the authentication policies of the
>application. Possible modes are "Windows",
> "Forms", "Passport" and "None"
> -->
> <authentication mode="Forms" >
> <forms name="LogOnCookie" path="/" loginUrl="login.aspx"
>protection="All" timeout="25">
> <credentials passwordFormat="Clear">
> <user name="tommy" password="sonja"/>
> </credentials>
> </forms>
> </authentication>
>
> <!-- AUTHORIZATION
> This section sets the authorization policies of the
>application. You can allow or deny access
> to application resources by user or role. Wildcards: "*"
>mean everyone, "?" means anonymous
> (unauthenticated) users.
> -->
> <authorization>
> <allow users="*" /> <!-- Allow all users -->
>
> <!-- <allow users="[comma separated list of users]"
> roles="[comma separated list of roles]"/>
> <deny users="[comma separated list of users]"
> roles="[comma separated list of roles]"/>
> -->
> </authorization>
>
> <!-- APPLICATION-LEVEL TRACE LOGGING
> Application-level tracing enables trace log output for every
>page within an application.
> Set trace enabled="true" to enable application trace
>logging. If pageOutput="true", the
> trace information will be displayed at the bottom of each
>page. Otherwise, you can view the
> application trace log by browsing the "trace.axd" page from
>your web application
> root.
> -->
> <trace enabled="false" requestLimit="10" pageOutput="false"
>traceMode="SortByTime" localOnly="true" />
>
>
> <!-- SESSION STATE SETTINGS
> By default ASP.NET uses cookies to identify which requests
>belong to a particular session.
> If cookies are not available, a session can be tracked by
>adding a session identifier to the URL.
> To disable cookies, set sessionState cookieless="true".
> -->
> <sessionState
> mode="InProc"
> stateConnectionString="tcpip=127.0.0.1:42424"
> sqlConnectionString="data source=127.0.0.1;user
>id=sa;password="
> cookieless="false"
> timeout="20"
> />
>
> <!-- GLOBALIZATION
> This section sets the globalization settings of the
>application.
> -->
> <globalization requestEncoding="utf-8" responseEncoding="utf-8" />
>
> </system.web>
>
></configuration>
>


Nov 18 '05 #4

P: n/a
That's exactly what it is. All config files are case sensitive.

Jim Cheshire, MCSE, MCSD [MSFT]
Microsoft Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

--------------------
From: "Ken Cox [Microsoft MVP]" <BA************@sympatico.ca>
References: <8f**************************@posting.google.com > <zA*************@cpmsftngxa07.phx.gbl>
<8f*************************@posting.google.com>Subject: Re: Server Error in '/' Application. -> web.config
Date: Thu, 1 Jan 2004 17:25:30 -0500
Lines: 197
MIME-Version: 1.0
Content-Type: text/plain;
format=flowed;
charset="Windows-1252";
reply-type=original
Content-Transfer-Encoding: 7bit
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2900.2055
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2055
Message-ID: <Oc**************@TK2MSFTNGP09.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
NNTP-Posting-Host: toronto-hse-ppp3665238.sympatico.ca 65.95.163.55
Path: cpmsftngxa07.phx.gbl!cpmsftngxa06.phx.gbl!TK2MSFTN GXS01.phx.gbl!TK2MSFTNGXA0
5.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTNGP09.phx.gb lXref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:199258
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

It looks like the case is incorrect for the mode attribute value. You need acapital "O"

Yours:
<customErrors mode="off" />

Should be:
<customErrors mode="Off"/>
"tommy" <th***********@hannover-leasing.de> wrote in message
news:8f*************************@posting.google.c om...
Hello Jim,

the exactly error-message:

Server Error in '/' Application.
----------------------------------------------------------------------------
----
Runtime Error
Description: An application error occurred on the server. The current
custom error settings for this application prevent the details of the
application error from being viewed remotely (for security reasons).
It could, however, be viewed by browsers running on the local server
machine.

Details: To enable the details of this specific error message to be
viewable on remote machines, please create a <customErrors> tag within
a "web.config" configuration file located in the root directory of the
current web application. This <customErrors> tag should then have its
"mode" attribute set to "Off".
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a
custom error page by modifying the "defaultRedirect" attribute of the
application's <customErrors> configuration tag to point to a custom
error page URL.
<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly"
defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

on my local computer, all works fine.... but not on webspace
at the end --> my web.config

tommy
ja******@online.microsoft.com (Jim Cheshire [MSFT]) wrote in message
news:<zA*************@cpmsftngxa07.phx.gbl>...
Tommy,

What is the exact error message you are seeing?

Jim Cheshire, MCSE, MCSD [MSFT]
Microsoft Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.

>
>hello everbody,
>
>i write a little asp-application with forms-authentication.
>i copy my aspx-files with web.config to my webspace and i get the
>error above...
>
>i tried to set the custom-errors-tag ="off"
>but nothing happens....
>
>what is my failure????
>
>could someone help me please?
>
>thanks a lot
>
>tommy
>
><?xml version="1.0" encoding="utf-8" ?>
><configuration>
>
> <system.web>
>
> <!-- DYNAMIC DEBUG COMPILATION
> Set compilation debug="true" to insert debugging symbols
>(.pdb information)
> into the compiled page. Because this creates a larger file
>that executes
> more slowly, you should set this value to true only when
>debugging and to
> false at all other times. For more information, refer to the
>documentation about
> debugging ASP.NET files.
> -->
> <compilation defaultLanguage="vb" debug="true" />
>
> <!-- CUSTOM ERROR MESSAGES
> Set customErrors mode="On" or "RemoteOnly" to enable custom
>error messages, "Off" to disable.
> Add <error> tags for each of the errors you want to handle.
> -->
> <customErrors mode="off" />
>
> <!-- AUTHENTICATION
> This section sets the authentication policies of the
>application. Possible modes are "Windows",
> "Forms", "Passport" and "None"
> -->
> <authentication mode="Forms" >
> <forms name="LogOnCookie" path="/" loginUrl="login.aspx"
>protection="All" timeout="25">
> <credentials passwordFormat="Clear">
> <user name="tommy" password="sonja"/>
> </credentials>
> </forms>
> </authentication>
>
> <!-- AUTHORIZATION
> This section sets the authorization policies of the
>application. You can allow or deny access
> to application resources by user or role. Wildcards: "*"
>mean everyone, "?" means anonymous
> (unauthenticated) users.
> -->
> <authorization>
> <allow users="*" /> <!-- Allow all users -->
>
> <!-- <allow users="[comma separated list of users]"
> roles="[comma separated list of roles]"/>
> <deny users="[comma separated list of users]"
> roles="[comma separated list of roles]"/>
> -->
> </authorization>
>
> <!-- APPLICATION-LEVEL TRACE LOGGING
> Application-level tracing enables trace log output for every
>page within an application.
> Set trace enabled="true" to enable application trace
>logging. If pageOutput="true", the
> trace information will be displayed at the bottom of each
>page. Otherwise, you can view the
> application trace log by browsing the "trace.axd" page from
>your web application
> root.
> -->
> <trace enabled="false" requestLimit="10" pageOutput="false"
>traceMode="SortByTime" localOnly="true" />
>
>
> <!-- SESSION STATE SETTINGS
> By default ASP.NET uses cookies to identify which requests
>belong to a particular session.
> If cookies are not available, a session can be tracked by
>adding a session identifier to the URL.
> To disable cookies, set sessionState cookieless="true".
> -->
> <sessionState
> mode="InProc"
> stateConnectionString="tcpip=127.0.0.1:42424"
> sqlConnectionString="data source=127.0.0.1;user
>id=sa;password="
> cookieless="false"
> timeout="20"
> />
>
> <!-- GLOBALIZATION
> This section sets the globalization settings of the
>application.
> -->
> <globalization requestEncoding="utf-8" responseEncoding="utf-8" />
>
> </system.web>
>
></configuration>
>



Nov 18 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.