By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,720 Members | 2,135 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,720 IT Pros & Developers. It's quick & easy.

Configuration error when adding an assembly

P: n/a
I have a web app that uses a third party assembly. I have been
transferring this assembly back-and-forth from my dev server "bin"
directory to my staging server "bin" directory many, many times
without error. Now I get this message on my staging server sfter
updating it:

Parser Error Message: Access is denied: 'ChilkatDotNet'.

BLAH
BLAH
BLAH

Source File: c:\windows\microsoft.net\framework\v1.1.4322\Confi g\machine.config
Line: 261

Assembly Load Trace: The following information can be helpful to
determine why the assembly 'ChilkatDotNet' could not be loaded.
=== Pre-bind state information ===
LOG: DisplayName = ChilkatDotNet
(Partial)
LOG: Appbase = file:///C:/Inetpub/IntranetStagingRoot/applications/supplyorder
LOG: Initial PrivatePath = bin
Calling assembly : (Unknown).
===

LOG: Policy not being applied to reference at this time (private,
custom, partial, or location-based assembly bind).
LOG: Post-policy reference: ChilkatDotNet
LOG: Attempting download of new URL
file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
Files/applications_supplyorder/15467a2d/5c8dfffd/ChilkatDotNet.DLL.
LOG: Attempting download of new URL
file:///C:/WINDOWS/Microsoft.NET/Framework/v1.1.4322/Temporary ASP.NET
Files/applications_supplyorder/15467a2d/5c8dfffd/ChilkatDotNet/ChilkatDotNet.DLL.
LOG: Attempting download of new URL
file:///C:/Inetpub/IntranetStagingRoot/applications/supplyorder/bin/ChilkatDotNet.DLL.
LOG: Publisher policy file is not found.
LOG: No redirect found in host configuration file
(C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspn et.config).
LOG: Using machine configuration file from
C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\confi g\machine.config.
LOG: Post-policy reference: ChilkatDotNet, Version=4.9.0.0,
Culture=neutral, PublicKeyToken=16dba5cb7b161beb

Please note, if I take the DLL out of the "bin" directory on the
staging server, no error. Any ideas on how to fix this?

Carlton
Nov 18 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Check out this article....
http://support.microsoft.com/default...kb;en-us;32906

I think this might solve your proble

-Hassan
Nov 18 '05 #2

P: n/a
cn******@hotmail.com (Carlton858) wrote in message news:<5e**************************@posting.google. com>...
I have a web app that uses a third party assembly. I have been
transferring this assembly back-and-forth from my dev server "bin"
directory to my staging server "bin" directory many, many times
without error. Now I get this message on my staging server sfter
updating it:

Parser Error Message: Access is denied: 'ChilkatDotNet'.

BLAH
BLAH
BLAH

Source File: c:\windows\microsoft.net\framework\v1.1.4322\Confi g\machine.config
Line: 261

Assembly Load Trace: The following information can be helpful to
determine why the assembly 'ChilkatDotNet' could not be loaded.

I found the solution to my problem. It seems that the aspnet_wp
process had got a hold on this DLL and would not let go. A restart of
the server was needed and the problem was cleared up.

Carlton
Nov 18 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.