By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,434 Members | 2,902 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,434 IT Pros & Developers. It's quick & easy.

Can't create new project on local server

P: n/a
Hello.

I'm having trouble creating a new Web project using VS .NET 2003 on
the local default web. I've done a lot of research about this and
found a lot of suggestions, but none of them seem to have worked in my
case so far. I'd appreciate any help anyone can offer!

Here's the problem:

When attempting to create a new ASP.NET Web project on my *local*
server (i.e. IIS is on the same machine as VS.NET) I always get two
error msgs, the first being:

"The Web was created successfully, but an error occurred when trying
to configure the application root for this Web. Web projects may not
operate correctly without an application root. The returned error
was:
A possible cause of this error is insufficient access rights to
perform the operation. You can manually configure the application
root using the Internet Services Manager."

That error is always followed by:

"Unable to set permissions on the 'bin' folder to restrict browse
access.
A possible cause of this error is insufficient access rights to
perform the operation. You can manually configure the permissions on
this folder using the Internet Services Manager."

My environment is: OS = Win 2003 Server, IIS = v6.0, VS .NET 2003.

I've read all Usenet postings and MS knowledge base articles I could
find. The things I've tried/checked include the following:

1. Tried logging on as Administrator...same error happens.
2. Tried setting Execute permissions on the Default Web Site to
"Scripts only" and "Scripts and Executables"...same error either way.
3. Ensure "VS Developers" group exists and I am a member.
4. Checked permissions on home directory (C:\Inetpub\wwwroot)...VS
Developers group has all permissions except Full Control.
5. Reregistered aspnet_isapi.dll
6. Ran aspnet_regiis -i
I do not believe that Front Page Extensions have been installed on
this box, but in VS.NET under "Tools->Options->Projects->Web
Settings", I have the "Preferred Access Method" set to "File Share",
so FPE aren't needed, right?

In Internet Security settings, both "http://localhost" and
"https://localhost" are members of the "Local intranet" zone. In the
custom security settings for that zone, under "User Authentication",
I've tried the "Logon" setting at "Automatic logon only in Intranet
zone" and "Automatic logon with current username and password". Both
give same error.

Further information that is perhaps not relevant, but I'm listing just
in case...

- A previous version of the .NET Framework coexists on this machine.

- I can successfully run a simple ASP.NET application on this box
"manually" (without using VS.NET).

- As mentioned Front Page Server Extensions are not installed.

- There is no client/server box involved, all this happens on a single
machine.

- Active Directory does not appear to be installed (I do not see any
items for it in the "Administrative Tools" menu group.)
Thanks VERY much to anyone who can help!
Nov 18 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.