By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,154 Members | 1,031 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,154 IT Pros & Developers. It's quick & easy.

"Unable to create Web project... The file path... does not correspond to the URL..." error using VSS with VS2003 in a Team Developemt environment

P: n/a
The problem started when the Working Folder for a project was somehow set to
the folder of another project. I set the correct working folder in VSS and
deleted the .vbproj files that had been created in the wrong folder on the
hard drive. Before I discovered these files, .NET kept trying to create a
new project with _1 following the project name. Deleting those files
corrected that problem.

I deleted the Virtual Directory, rebooted, and then recreated the Virtual
Directory for the project so that the folder structure in VSS matched the
folder structure on the hard drive. After rebooting (must reboot or else
..NET will not recognize the Virtual Directory), I created a new blank
solution and tried to add the projects from source control.

The file path is correct in the "Create local project from SourceSafe"
dialog.

In the "Set Project Location" dialog, the "Source Control Server Location"
is correct and the "Enter working copy Location Here" URL is correct (that
URL is mapped to the same folder in IIS as what is set as a Working Folder
in VSS).

Before deleting the .vbproj files that had been created in the wrong folder,
this is where the URL kept being changed to _1, etc.

Once I click the OK button in the "Set Project Location" dialog, I get the
following error:

"Unable to create Web project 'http://localhost/TeamCorpApp'. The file path
'C:\Projects\HALO2\PowerStreamII\TeamCorpApp' does not correspond to the URL
'http://localhhost/TeamCorpApp'. The two need to map to the same server
location. HTTP Error 404: Object Not Found."

The project name is TeamCorpApp and the project location is
C:\Projects\TeamCorpSolution\TeamCorpApp.

The erroneous .vbproj files were created in C:\Projects\HALO2\PowerStreamII
which was caused by that being set as the Working Folder in VSS.

Two other team developers have successfully created projects from source
control but I have not been able to.

Please help.

David Webb
Senior Application Developer
National Health Insurance Company
Jul 21 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
We had a similar problem but was able to resolve it via MS's recommendations
at the following page:

http://support.microsoft.com/default...b;en-us;327283
"David Webb" wrote:
The problem started when the Working Folder for a project was somehow set to
the folder of another project. I set the correct working folder in VSS and
deleted the .vbproj files that had been created in the wrong folder on the
hard drive. Before I discovered these files, .NET kept trying to create a
new project with _1 following the project name. Deleting those files
corrected that problem.

I deleted the Virtual Directory, rebooted, and then recreated the Virtual
Directory for the project so that the folder structure in VSS matched the
folder structure on the hard drive. After rebooting (must reboot or else
..NET will not recognize the Virtual Directory), I created a new blank
solution and tried to add the projects from source control.

The file path is correct in the "Create local project from SourceSafe"
dialog.

In the "Set Project Location" dialog, the "Source Control Server Location"
is correct and the "Enter working copy Location Here" URL is correct (that
URL is mapped to the same folder in IIS as what is set as a Working Folder
in VSS).

Before deleting the .vbproj files that had been created in the wrong folder,
this is where the URL kept being changed to _1, etc.

Once I click the OK button in the "Set Project Location" dialog, I get the
following error:

"Unable to create Web project 'http://localhost/TeamCorpApp'. The file path
'C:\Projects\HALO2\PowerStreamII\TeamCorpApp' does not correspond to the URL
'http://localhhost/TeamCorpApp'. The two need to map to the same server
location. HTTP Error 404: Object Not Found."

The project name is TeamCorpApp and the project location is
C:\Projects\TeamCorpSolution\TeamCorpApp.

The erroneous .vbproj files were created in C:\Projects\HALO2\PowerStreamII
which was caused by that being set as the Working Folder in VSS.

Two other team developers have successfully created projects from source
control but I have not been able to.

Please help.

David Webb
Senior Application Developer
National Health Insurance Company

Jul 21 '05 #2

P: n/a
Thanks for the response.

However, I am using .NET 2003 and that Q article states " This problem does
not occur when you use Visual Studio .NET 2003 because this version uses a
file that has the .htm file name extension for this process. "

I have created projects on a third computer without any problems so that
pretty much narrows the search to IIS and .NET on my computer. I've searched
registry on both the VSS server and my development server with no matches
for "Projects\HALO2\PowerStreamII" which is where the .vbproj files were
being placed before I corrected the Working Folder path in VSS.

Still no luck!
"sze tan" <sze ta*@discussions.microsoft.com> wrote in message
news:5D**********************************@microsof t.com...
We had a similar problem but was able to resolve it via MS's recommendations at the following page:

http://support.microsoft.com/default...b;en-us;327283
"David Webb" wrote:
The problem started when the Working Folder for a project was somehow set to the folder of another project. I set the correct working folder in VSS and deleted the .vbproj files that had been created in the wrong folder on the hard drive. Before I discovered these files, .NET kept trying to create a new project with _1 following the project name. Deleting those files
corrected that problem.

I deleted the Virtual Directory, rebooted, and then recreated the Virtual Directory for the project so that the folder structure in VSS matched the folder structure on the hard drive. After rebooting (must reboot or else
..NET will not recognize the Virtual Directory), I created a new blank
solution and tried to add the projects from source control.

The file path is correct in the "Create local project from SourceSafe"
dialog.

In the "Set Project Location" dialog, the "Source Control Server Location" is correct and the "Enter working copy Location Here" URL is correct (that URL is mapped to the same folder in IIS as what is set as a Working Folder in VSS).

Before deleting the .vbproj files that had been created in the wrong folder, this is where the URL kept being changed to _1, etc.

Once I click the OK button in the "Set Project Location" dialog, I get the following error:

"Unable to create Web project 'http://localhost/TeamCorpApp'. The file path 'C:\Projects\HALO2\PowerStreamII\TeamCorpApp' does not correspond to the URL 'http://localhhost/TeamCorpApp'. The two need to map to the same server
location. HTTP Error 404: Object Not Found."

The project name is TeamCorpApp and the project location is
C:\Projects\TeamCorpSolution\TeamCorpApp.

The erroneous .vbproj files were created in C:\Projects\HALO2\PowerStreamII which was caused by that being set as the Working Folder in VSS.

Two other team developers have successfully created projects from source
control but I have not been able to.

Please help.

David Webb
Senior Application Developer
National Health Insurance Company

Jul 21 '05 #3

P: n/a
That's a bummer that my suggestion did not fix your problem. I've read that
some installs of Sharepoint Portal Server may mess up your IIS settings to
cause the problem you're experiencing.... perhaps, you could look into your
IIS logs to determine what VS.NET is trying to access that throwing the 404
not found error.

Sorry I can't be of more help!

"David Webb" wrote:
Thanks for the response.

However, I am using .NET 2003 and that Q article states " This problem does
not occur when you use Visual Studio .NET 2003 because this version uses a
file that has the .htm file name extension for this process. "

I have created projects on a third computer without any problems so that
pretty much narrows the search to IIS and .NET on my computer. I've searched
registry on both the VSS server and my development server with no matches
for "Projects\HALO2\PowerStreamII" which is where the .vbproj files were
being placed before I corrected the Working Folder path in VSS.

Still no luck!
"sze tan" <sze ta*@discussions.microsoft.com> wrote in message
news:5D**********************************@microsof t.com...
We had a similar problem but was able to resolve it via MS's

recommendations
at the following page:

http://support.microsoft.com/default...b;en-us;327283
"David Webb" wrote:
The problem started when the Working Folder for a project was somehow set to the folder of another project. I set the correct working folder in VSS and deleted the .vbproj files that had been created in the wrong folder on the hard drive. Before I discovered these files, .NET kept trying to create a new project with _1 following the project name. Deleting those files
corrected that problem.

I deleted the Virtual Directory, rebooted, and then recreated the Virtual Directory for the project so that the folder structure in VSS matched the folder structure on the hard drive. After rebooting (must reboot or else
..NET will not recognize the Virtual Directory), I created a new blank
solution and tried to add the projects from source control.

The file path is correct in the "Create local project from SourceSafe"
dialog.

In the "Set Project Location" dialog, the "Source Control Server Location" is correct and the "Enter working copy Location Here" URL is correct (that URL is mapped to the same folder in IIS as what is set as a Working Folder in VSS).

Before deleting the .vbproj files that had been created in the wrong folder, this is where the URL kept being changed to _1, etc.

Once I click the OK button in the "Set Project Location" dialog, I get the following error:

"Unable to create Web project 'http://localhost/TeamCorpApp'. The file path 'C:\Projects\HALO2\PowerStreamII\TeamCorpApp' does not correspond to the URL 'http://localhhost/TeamCorpApp'. The two need to map to the same server
location. HTTP Error 404: Object Not Found."

The project name is TeamCorpApp and the project location is
C:\Projects\TeamCorpSolution\TeamCorpApp.

The erroneous .vbproj files were created in C:\Projects\HALO2\PowerStreamII which was caused by that being set as the Working Folder in VSS.

Two other team developers have successfully created projects from source
control but I have not been able to.

Please help.

David Webb
Senior Application Developer
National Health Insurance Company


Jul 21 '05 #4

P: n/a
Nothing is logged in the IIS log file.

So, the question is; where is that folder path being cached? It's not in the
registry on the VSS or development machine.

One peculiar thing though; when VSS had the incorrect folder set as the
Working Folder, .NET created the .vbproj file in the folder that was
specified in VSS instead of using the Virtual Directory folder that was
setup in IIS. In otherwords, .NET wasn't using the file folder that was
mapped to the URL of the project but instead was using the Working Folder
path in VSS.

What's even stranger is that the two development workstations that I setup,
which is before I discovered the incorrect Working Folder, didn't have the
problem. .NET used the Virtual Directory folder that mapped to the URL as it
should have even though the Working Folder in VSS was probably not correct
(I never checked at that time).

I have tried to add the project by logging into VSS as one of the other
developers but I get the same results. That pretty much eliminates VSS.

Since IIS is not logging anything at all when I try to add the project and
VSS displays all of the correct paths in the VSS dialogs using different
logins; then the problem must be with .NET!

I really don't want to reinstall .net since there are a lot of preferences
that will be reset when I do but it is looking like that might be a last
resort.

But if the problem exists with .NET or IIS, then there MUST be the text
string "C:\Projects\HALO2\PowerStreamII" somewhere on my hard drive. But if
it is in a binary file, that would be impossible to locate.

David
"sze tan" <sze ta*@discussions.microsoft.com> wrote in message
news:51**********************************@microsof t.com...
That's a bummer that my suggestion did not fix your problem. I've read that some installs of Sharepoint Portal Server may mess up your IIS settings to
cause the problem you're experiencing.... perhaps, you could look into your IIS logs to determine what VS.NET is trying to access that throwing the 404 not found error.

Sorry I can't be of more help!

"David Webb" wrote:
Thanks for the response.

However, I am using .NET 2003 and that Q article states " This problem does not occur when you use Visual Studio .NET 2003 because this version uses a file that has the .htm file name extension for this process. "

I have created projects on a third computer without any problems so that
pretty much narrows the search to IIS and .NET on my computer. I've searched registry on both the VSS server and my development server with no matches for "Projects\HALO2\PowerStreamII" which is where the .vbproj files were
being placed before I corrected the Working Folder path in VSS.

Still no luck!
"sze tan" <sze ta*@discussions.microsoft.com> wrote in message
news:5D**********************************@microsof t.com...
We had a similar problem but was able to resolve it via MS's

recommendations
at the following page:

http://support.microsoft.com/default...b;en-us;327283
"David Webb" wrote:

> The problem started when the Working Folder for a project was somehow
set to
> the folder of another project. I set the correct working folder in
VSS and
> deleted the .vbproj files that had been created in the wrong folder
on the
> hard drive. Before I discovered these files, .NET kept trying to
create a
> new project with _1 following the project name. Deleting those files
> corrected that problem.
>
> I deleted the Virtual Directory, rebooted, and then recreated the

Virtual
> Directory for the project so that the folder structure in VSS
matched the
> folder structure on the hard drive. After rebooting (must reboot or
else > ..NET will not recognize the Virtual Directory), I created a new blank > solution and tried to add the projects from source control.
>
> The file path is correct in the "Create local project from SourceSafe" > dialog.
>
> In the "Set Project Location" dialog, the "Source Control Server

Location"
> is correct and the "Enter working copy Location Here" URL is correct

(that
> URL is mapped to the same folder in IIS as what is set as a Working

Folder
> in VSS).
>
> Before deleting the .vbproj files that had been created in the wrong

folder,
> this is where the URL kept being changed to _1, etc.
>
> Once I click the OK button in the "Set Project Location" dialog, I get the
> following error:
>
> "Unable to create Web project 'http://localhost/TeamCorpApp'. The
file path
> 'C:\Projects\HALO2\PowerStreamII\TeamCorpApp' does not correspond to
the URL
> 'http://localhhost/TeamCorpApp'. The two need to map to the same

server > location. HTTP Error 404: Object Not Found."
>
> The project name is TeamCorpApp and the project location is
> C:\Projects\TeamCorpSolution\TeamCorpApp.
>
> The erroneous .vbproj files were created in

C:\Projects\HALO2\PowerStreamII
> which was caused by that being set as the Working Folder in VSS.
>
> Two other team developers have successfully created projects from source > control but I have not been able to.
>
> Please help.
>
> David Webb
> Senior Application Developer
> National Health Insurance Company
>
>
>


Jul 21 '05 #5

P: n/a
Correction, I was looking at the modified date of the log file which
apparently doesn't change when new events are added. This is an example of
an event that occurs when I try to add a project:

2005-02-04 20:01:39 127.0.0.1 - 127.0.0.1 80 GET
/TeamCorpApp/vs145240086429690612_tmp.htm - 404
Microsoft-Visual-Studio.NET/7.10.3077

If I place a simple html file in the project folder that is mapped to
http://localhost/teamcorpapp and browse to that file in IE, the web page is
displayed which proves that the virtual folder is mapped to that location.

Note the extension of the file that is not found in that log record
"...90612_tmp.htm" which might be what that article that you sent the link
to was mentioning.

David
"David Webb" <strangecargo> wrote in message
news:eE**************@TK2MSFTNGP12.phx.gbl...
Nothing is logged in the IIS log file.

So, the question is; where is that folder path being cached? It's not in the registry on the VSS or development machine.

One peculiar thing though; when VSS had the incorrect folder set as the
Working Folder, .NET created the .vbproj file in the folder that was
specified in VSS instead of using the Virtual Directory folder that was
setup in IIS. In otherwords, .NET wasn't using the file folder that was
mapped to the URL of the project but instead was using the Working Folder
path in VSS.

What's even stranger is that the two development workstations that I setup, which is before I discovered the incorrect Working Folder, didn't have the
problem. .NET used the Virtual Directory folder that mapped to the URL as it should have even though the Working Folder in VSS was probably not correct
(I never checked at that time).

I have tried to add the project by logging into VSS as one of the other
developers but I get the same results. That pretty much eliminates VSS.

Since IIS is not logging anything at all when I try to add the project and
VSS displays all of the correct paths in the VSS dialogs using different
logins; then the problem must be with .NET!

I really don't want to reinstall .net since there are a lot of preferences
that will be reset when I do but it is looking like that might be a last
resort.

But if the problem exists with .NET or IIS, then there MUST be the text
string "C:\Projects\HALO2\PowerStreamII" somewhere on my hard drive. But if it is in a binary file, that would be impossible to locate.

David
"sze tan" <sze ta*@discussions.microsoft.com> wrote in message
news:51**********************************@microsof t.com...
That's a bummer that my suggestion did not fix your problem. I've read that
some installs of Sharepoint Portal Server may mess up your IIS settings to
cause the problem you're experiencing.... perhaps, you could look into

your
IIS logs to determine what VS.NET is trying to access that throwing the

404
not found error.

Sorry I can't be of more help!

"David Webb" wrote:
Thanks for the response.

However, I am using .NET 2003 and that Q article states " This problem does not occur when you use Visual Studio .NET 2003 because this version
uses
a file that has the .htm file name extension for this process. "

I have created projects on a third computer without any problems so
that pretty much narrows the search to IIS and .NET on my computer. I've
searched registry on both the VSS server and my development server with no matches for "Projects\HALO2\PowerStreamII" which is where the .vbproj files were being placed before I corrected the Working Folder path in VSS.

Still no luck!
"sze tan" <sze ta*@discussions.microsoft.com> wrote in message
news:5D**********************************@microsof t.com...
> We had a similar problem but was able to resolve it via MS's
recommendations
> at the following page:
>
> http://support.microsoft.com/default...b;en-us;327283
>
>
> "David Webb" wrote:
>
> > The problem started when the Working Folder for a project was somehow set to
> > the folder of another project. I set the correct working folder in VSS and
> > deleted the .vbproj files that had been created in the wrong folder on
the
> > hard drive. Before I discovered these files, .NET kept trying to create a
> > new project with _1 following the project name. Deleting those
files > > corrected that problem.
> >
> > I deleted the Virtual Directory, rebooted, and then recreated the
Virtual
> > Directory for the project so that the folder structure in VSS
matched the
> > folder structure on the hard drive. After rebooting (must reboot or else
> > ..NET will not recognize the Virtual Directory), I created a new blank > > solution and tried to add the projects from source control.
> >
> > The file path is correct in the "Create local project from SourceSafe" > > dialog.
> >
> > In the "Set Project Location" dialog, the "Source Control Server
Location"
> > is correct and the "Enter working copy Location Here" URL is
correct (that
> > URL is mapped to the same folder in IIS as what is set as a Working Folder
> > in VSS).
> >
> > Before deleting the .vbproj files that had been created in the wrong folder,
> > this is where the URL kept being changed to _1, etc.
> >
> > Once I click the OK button in the "Set Project Location" dialog, I
get the
> > following error:
> >
> > "Unable to create Web project 'http://localhost/TeamCorpApp'. The file path
> > 'C:\Projects\HALO2\PowerStreamII\TeamCorpApp' does not correspond
to the URL
> > 'http://localhhost/TeamCorpApp'. The two need to map to the same server > > location. HTTP Error 404: Object Not Found."
> >
> > The project name is TeamCorpApp and the project location is
> > C:\Projects\TeamCorpSolution\TeamCorpApp.
> >
> > The erroneous .vbproj files were created in
C:\Projects\HALO2\PowerStreamII
> > which was caused by that being set as the Working Folder in VSS.
> >
> > Two other team developers have successfully created projects from source > > control but I have not been able to.
> >
> > Please help.
> >
> > David Webb
> > Senior Application Developer
> > National Health Insurance Company
> >
> >
> >


Jul 21 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.