By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,423 Members | 1,601 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,423 IT Pros & Developers. It's quick & easy.

2nd Request on error "Unable to Start Debugging on the Web Server."

P: n/a
This is my 2nd request. Is the question too vague? Or, too difficult to
answer. I'm really a newbie at this VS.NET stuff and do appreciate some help
on this problem.---I keep getting the error "Unable to Start Debugging on
the Web Server."

I am on a standalone, non networked computer running XP Professonal and
VS.net, and doing my development using VS.C#.

I "think" I have gone through eveything listed in help for this error, but
obviouly, I'm doing something wrong.

- Are you running a version of Wndows that allows the Visual Studio
debugger..... I'm running XP Professiona.

- Does your Web application have a Web.Config? ... I "assume" VS.C# does all
this????

- Are you a member of the Debuggers Users group? .... I have NO idea how I
check this. Since I'm the only user of the machcine, I would "Hope" that I
am..

- Did you create the project by specific IP.... ? Not I and I assume VB.C#
didn't either..

- Does the machine running IIS server hav eVS.Net Remote Componts Installer?
...... Yes..

- Was IIS installed on the local machine after VS.NET was Installed? .....
I'm not sure, so I ran the repaie option...

- Is the URL for the project start page propery specified? ..... I "Assume"
VS.C# constructed thsi correctly,,,

- Are the IIS security Settings setup properly?... I can't find an
"Administrative Tools." on my system to check this...
Okay, folks.. Do I have someone out there who can help me? Thanks...

Bruce A. Julseth
Nov 13 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Lee
>- Does your Web application have a Web.Config? ...
I "assume" VS.C# does all
this????
It should, check in your solution explorer pane (the upper
left hand corner of the IDE) and look for a file called
web.config.
- Are you a member of the Debuggers Users group? .... I have NO idea how Icheck this. Since I'm the only user of the machcine, I would "Hope" that Iam..
Right click on your "My Computer" Icon and click "Manage"
Expand the "Local Users and Groups" List and click on
Groups. Double Click the "Debugger Users" group and make
sure that the name that you login with is listed there, if
not, click "Add" and select it from the list.
- Is the URL for the project start page propery specified? ..... I "Assume"VS.C# constructed thsi correctly,,,
To make sure, right click on the page that you want to be
the start page and click "Set as start page"
- Are the IIS security Settings setup properly?... I can't find an"Administrative Tools." on my system to check this...


It should be under your control panel (you will have to
switch to classic mode in order to see it on XP) Also, if
you have recently run the IIS Lockdown tool, this can
prevent you from debugging.

Hope that this helps,

-Lee
Nov 13 '05 #2

P: n/a


Thanks, Lee.. I'll try your suggestions and get back.

Bruce

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Nov 13 '05 #3

P: n/a
If one (namely me) ran the IIS Lock Down Tool, what can one do to allow
debugging but still protect yourself from the outside world?..

"Lee" <le******@hotmail.com> wrote in message
news:03****************************@phx.gbl...
- Does your Web application have a Web.Config? ...

I "assume" VS.C# does all
this????


It should, check in your solution explorer pane (the upper
left hand corner of the IDE) and look for a file called
web.config.
- Are you a member of the Debuggers Users group? .... I

have NO idea how I
check this. Since I'm the only user of the machcine, I

would "Hope" that I
am..


Right click on your "My Computer" Icon and click "Manage"
Expand the "Local Users and Groups" List and click on
Groups. Double Click the "Debugger Users" group and make
sure that the name that you login with is listed there, if
not, click "Add" and select it from the list.
- Is the URL for the project start page propery

specified? ..... I "Assume"
VS.C# constructed thsi correctly,,,


To make sure, right click on the page that you want to be
the start page and click "Set as start page"
- Are the IIS security Settings setup properly?... I

can't find an
"Administrative Tools." on my system to check this...


It should be under your control panel (you will have to
switch to classic mode in order to see it on XP) Also, if
you have recently run the IIS Lockdown tool, this can
prevent you from debugging.

Hope that this helps,

-Lee

Nov 13 '05 #4

P: n/a
"Bruce A. Julseth" <br*****@attglobal.net> wrote in message news:<eb**************@TK2MSFTNGP10.phx.gbl>...
This is my 2nd request. Is the question too vague? Or, too difficult to
answer. I'm really a newbie at this VS.NET stuff and do appreciate some help
on this problem.---I keep getting the error "Unable to Start Debugging on
the Web Server."

I am on a standalone, non networked computer running XP Professonal and
VS.net, and doing my development using VS.C#.

I "think" I have gone through eveything listed in help for this error, but
obviouly, I'm doing something wrong.

- Are you running a version of Wndows that allows the Visual Studio
debugger..... I'm running XP Professiona.

- Does your Web application have a Web.Config? ... I "assume" VS.C# does all
this????

- Are you a member of the Debuggers Users group? .... I have NO idea how I
check this. Since I'm the only user of the machcine, I would "Hope" that I
am..

- Did you create the project by specific IP.... ? Not I and I assume VB.C#
didn't either..

- Does the machine running IIS server hav eVS.Net Remote Componts Installer?
..... Yes..

- Was IIS installed on the local machine after VS.NET was Installed? .....
I'm not sure, so I ran the repaie option...

- Is the URL for the project start page propery specified? ..... I "Assume"
VS.C# constructed thsi correctly,,,

- Are the IIS security Settings setup properly?... I can't find an
"Administrative Tools." on my system to check this...
Okay, folks.. Do I have someone out there who can help me? Thanks...

Bruce A. Julseth


////////////////////////////////////////////
//////////MY THOUGHTS///////////////////////
////////////////////////////////////////////
The first thing I would try is to uninstall IIS, VS.NET and every
other component that you installed. Then reinstall it. I assume you
have already tried this. So on to the next thing.
1. The "Administrative Tools" are under the control panel. Third icon
over. Then click on the "Computer Management" icon and go to local
users and groups. You have to make sure that the ASPNET user is part
of the administrators group.

2. Once you have the Project open in VS.NET go to the Solution
Explorer window, right click your project, go to properties, web
settings, and make sure that you have
C:/Inetpub/wwwroot/yourprojectname under path.

3. Make sure that Internet explorer is not set to "Work Offline" that
will throw you off too.

I could keep going with this but it would take me too long. There are
a lot of things that could be causing that to happen. Email me at
sl******@yahoo.com if you need more help. If you do send me the full
message that you are being presented with.
Nov 15 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.