By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
445,771 Members | 1,741 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 445,771 IT Pros & Developers. It's quick & easy.

ASPNET user missing from Windows 2003?

P: n/a
Windows Server 2003 is supposed to include Framework 1.1 right. I don't
have it here but have reports that the web is not running.
The users say that the %COMPUTERNAME%\ASPNET user doesn't exist.

Questions:
1. is this user replaced by the %COMPUTERNAME%\NETWORK SERVICE user in
Windows 2003 Server (IIS6)?
2. if the ASPNET user still needed to run .NET apps and it's missing, how
would you add to a Windows 2003 Server box?

TIA

Harry
Nov 18 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Harry,

ASPNET will be missing from Windows Server 2003 unless you are running IIS
6 in IIS 5.0 isolation mode. The default application pool will run under
Network Service, but you can change that or create a new app pool to run
under a different user.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.
--------------------
From: "Harry Simpson" <hs*******@nospamphgt.net>
Subject: ASPNET user missing from Windows 2003?
Date: Wed, 19 Nov 2003 16:11:01 -0600
Lines: 15
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Message-ID: <uM**************@TK2MSFTNGP12.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
NNTP-Posting-Host: 66.89.73.130.ptr.us.xo.net 66.89.73.130
Path: cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFTN GXA05.phx.gbl!TK2MSFTNGP08
.phx.gbl!TK2MSFTNGP12.phx.gblXref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:191410
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Windows Server 2003 is supposed to include Framework 1.1 right. I don't
have it here but have reports that the web is not running.
The users say that the %COMPUTERNAME%\ASPNET user doesn't exist.

Questions:
1. is this user replaced by the %COMPUTERNAME%\NETWORK SERVICE user in
Windows 2003 Server (IIS6)?
2. if the ASPNET user still needed to run .NET apps and it's missing, how
would you add to a Windows 2003 Server box?

TIA

Harry


Nov 18 '05 #2

P: n/a
Thanks Jim,

Wanna run an existing ASPNET web app developed in VS2003. I need to get the
application directory rights to write etc within the website's root
directory. Before, i did this by granting the ASPNET user directory
priviledges. How do i enable these same priviledges now? %MACHINE
NAME%\NETWORK SERVICES ?

Some clients running Windows 2003 are not able to get the web site up and
running.

Thanks,
Harry Simpson, MCSD

"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in message
news:8R**************@cpmsftngxa07.phx.gbl...
Harry,

ASPNET will be missing from Windows Server 2003 unless you are running IIS
6 in IIS 5.0 isolation mode. The default application pool will run under
Network Service, but you can change that or create a new app pool to run
under a different user.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.
--------------------
From: "Harry Simpson" <hs*******@nospamphgt.net>
Subject: ASPNET user missing from Windows 2003?
Date: Wed, 19 Nov 2003 16:11:01 -0600
Lines: 15
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Message-ID: <uM**************@TK2MSFTNGP12.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
NNTP-Posting-Host: 66.89.73.130.ptr.us.xo.net 66.89.73.130
Path:

cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFTN GXA05.phx.gbl!TK2MSFTNGP08 phx.gbl!TK2MSFTNGP12.phx.gbl
Xref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:191410X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Windows Server 2003 is supposed to include Framework 1.1 right. I don't
have it here but have reports that the web is not running.
The users say that the %COMPUTERNAME%\ASPNET user doesn't exist.

Questions:
1. is this user replaced by the %COMPUTERNAME%\NETWORK SERVICE user in
Windows 2003 Server (IIS6)?
2. if the ASPNET user still needed to run .NET apps and it's missing, how
would you add to a Windows 2003 Server box?

TIA

Harry

Nov 18 '05 #3

P: n/a
Harry,

You can use the IIS_WPG group. You can also explicitly add NETWORK SERVICE
(which would actually be NT AUTHORITY\NETWORK SERVICE), but the IIS_WPG
group was created for that purpose.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.
--------------------
From: "Harry Simpson" <ha***@nofrigginspammicroworksinc.com>
References: <uM**************@TK2MSFTNGP12.phx.gbl> <8R**************@cpmsftngxa07.phx.gbl>Subject: Re: ASPNET user missing from Windows 2003?
Date: Wed, 19 Nov 2003 21:28:25 -0600
Lines: 70
X-Priority: 3
X-MSMail-Priority: Normal
X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
Message-ID: <eb*************@TK2MSFTNGP11.phx.gbl>
Newsgroups: microsoft.public.dotnet.framework.aspnet
NNTP-Posting-Host: dialup-67.30.212.29.dial1.atlanta1.level3.net 67.30.212.29Path: cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFTN GXA05.phx.gbl!TK2MSFTNGP08
.phx.gbl!TK2MSFTNGP11.phx.gblXref: cpmsftngxa07.phx.gbl microsoft.public.dotnet.framework.aspnet:191463
X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet

Thanks Jim,

Wanna run an existing ASPNET web app developed in VS2003. I need to get theapplication directory rights to write etc within the website's root
directory. Before, i did this by granting the ASPNET user directory
priviledges. How do i enable these same priviledges now? %MACHINE
NAME%\NETWORK SERVICES ?

Some clients running Windows 2003 are not able to get the web site up and
running.

Thanks,
Harry Simpson, MCSD

"Jim Cheshire [MSFT]" <ja******@online.microsoft.com> wrote in message
news:8R**************@cpmsftngxa07.phx.gbl...
Harry,

ASPNET will be missing from Windows Server 2003 unless you are running IIS
6 in IIS 5.0 isolation mode. The default application pool will run under
Network Service, but you can change that or create a new app pool to run
under a different user.

Jim Cheshire, MCSE, MCSD [MSFT]
Developer Support
ASP.NET
ja******@online.microsoft.com

This post is provided as-is with no warranties and confers no rights.
--------------------
>From: "Harry Simpson" <hs*******@nospamphgt.net>
>Subject: ASPNET user missing from Windows 2003?
>Date: Wed, 19 Nov 2003 16:11:01 -0600
>Lines: 15
>X-Priority: 3
>X-MSMail-Priority: Normal
>X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
>X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
>Message-ID: <uM**************@TK2MSFTNGP12.phx.gbl>
>Newsgroups: microsoft.public.dotnet.framework.aspnet
>NNTP-Posting-Host: 66.89.73.130.ptr.us.xo.net 66.89.73.130
>Path:

cpmsftngxa07.phx.gbl!cpmsftngxa10.phx.gbl!TK2MSFT NGXA05.phx.gbl!TK2MSFTNGP0

8
phx.gbl!TK2MSFTNGP12.phx.gbl
>Xref: cpmsftngxa07.phx.gbl

microsoft.public.dotnet.framework.aspnet:191410 >X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet
>
>Windows Server 2003 is supposed to include Framework 1.1 right. I don't
>have it here but have reports that the web is not running.
>The users say that the %COMPUTERNAME%\ASPNET user doesn't exist.
>
>Questions:
>1. is this user replaced by the %COMPUTERNAME%\NETWORK SERVICE user in
>Windows 2003 Server (IIS6)?
>2. if the ASPNET user still needed to run .NET apps and it's missing, how >would you add to a Windows 2003 Server box?
>
>TIA
>
>Harry
>
>
>



Nov 18 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.