473,889 Members | 1,674 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

tomcat apache not working

3 New Member
Just loaded tomcat apache for the first time and I can't seem to get it to work.
Is there something special about my config that won't allow me to use tomcat?

vista business
jre 1.6.0_07
jdk 1.6.0_07
tomcat 6.0

thank you
Kevin
Aug 15 '08 #1
4 10893
krraleigh
3 New Member
Found the log that tomcat created and there are some files that weren't created. Does this information help any?


[2008-08-15 18:17:52] [info] Procrun (2.0.4.0) started

[2008-08-15 18:17:52] [info] Service Tomcat6 name Apache Tomcat

[2008-08-15 18:17:52] [info] Service Tomcat6 installed

[2008-08-15 18:17:52] [info] Procrun finished.

[2008-08-15 18:17:53] [info] Procrun (2.0.4.0) started

[2008-08-15 18:17:53] [info] Updating service...

[2008-08-15 18:17:54] [info] Service Tomcat6 updated

[2008-08-15 18:17:54] [info] Update service finished.

[2008-08-15 18:17:54] [info] Procrun finished.

[2008-08-15 18:17:55] [info] Procrun (2.0.4.0) started

[2008-08-15 18:17:55] [info] Updating service...

[2008-08-15 18:17:55] [info] Service Tomcat6 updated

[2008-08-15 18:17:55] [info] Update service finished.

[2008-08-15 18:17:55] [info] Procrun finished.

[2008-08-15 18:17:58] [info] Procrun (2.0.4.0) started

[2008-08-15 18:17:58] [info] Running Service...

2008-08-15 18:17:58] [info] Starting service...

[2008-08-15 18:17:58] [174 javajni.c] [error] The specified module could not be found.
[2008-08-15 18:17:58] [994 prunsrv.c] [error] Failed creating java C:\Program Files\Java\jre1 .6.0_07\bin\cli ent\jvm.dll

[2008-08-15 18:17:58] [1269 prunsrv.c] [error] ServiceStart returned 1

[2008-08-15 18:17:58] [info] Run service finished.
[2008-08-15 18:17:58] [info] Procrun finished.

thank you
Kevin
Aug 16 '08 #2
krraleigh
3 New Member
found the problem by first finding the log located in the bin.
Then searching on the errors listed

good luck
Kevin
Aug 16 '08 #3
rr09
1 New Member
Hi,

I have the same problem - Tomcat refuses to start. I get the following in the log file:

Files\Java\jre6 \bin\client\jvm .dll

[2010-06-01 14:02:12] [1280 runsrv.c] [error] ServiceStart returned 1

[2010-06-01 14:02:12] [info] Run service finished.

[2010-06-01 14:02:12] [info] Commons Daemon procrun finished.


Any suggestions anyone?
Jun 1 '10 #4
Go to apache tomcat properties.
Try setting the recovery options under the recovery tab to restart the service for all the failures.Now start the service.
Nov 15 '10 #5

Sign in to post your reply or Sign up for a free account.

Similar topics

0
3297
by: Kevin Sagon | last post by:
I am running a J2EE Web App under Tomcat 4.1 with Apache 2.0 proxying requests. Everything is configured and working appropriately however I ran into a problem after configuring J2EE Form Authentication. I have a security constraint restricting access to the application so that when I attempt to access the app I am redirected to the login page. This works as expected both when accessing the application via the Apache proxy or hitting...
5
6482
by: Tom Martin | last post by:
I'm a Java Web developer NEWBIE that has inherited a website that fails every 2 hours due to poor connection pooling between Tomcat 4.0.6 and mySQL. In efforts to resolve this problem, I've created another replica DEVELOPMENT website and upgraded it to Tomcat 4.1.27. I was told this version of Tomcat supports Database Connection Pooling (DBCP) better than previous versions. I followed the instructions as listed at:...
0
2775
by: - e - | last post by:
Hi everybody! I download and installed Tomcat 4.1.3 on HP-UX 11.11, I think everything was OK on the installation process. Tomcat is working, first page (http://my-ip-address:8080/index.jsp) is responding, Tomcat Web Application Manager page is responding too, but when I try to get access to the Tomcat's Administration application (Tomcat Administration link on first page) I just get an 500 error page with the following text:
1
6927
by: ptaz | last post by:
Hi I'm trying to run a web page but I get the following error. Ca anyone please tell me a solution to this. Thanks Ptaz HTTP Status 500 - type Exception report
2
12879
by: Wired Earp | last post by:
I don't get it. First of all, it claims to run on a JRE. This is obviously a fraud, it even says so when you attempt to start it: "The JAVA_HOME variable should point to a JDK and not a JRE". I can accept that, being new to it all and not really caring, but things are going downhill rather fast from here. I'm installing a simple webapp in the the the webapps folder, complete with a context.xml in the conf folder. My servlet behaves just as...
12
12599
by: brew82 | last post by:
I am trying to get connection pooling working with Tomcat 5.5 and DB2 v8.1. This was working under Websphere Studio Application Developer 5.x but we are trying to move onto Eclipse and Tomcat. The datasources seem to get created correctly but I get an error when I try to get the connection from the datasource: org.apache.tomcat.dbcp.dbcp.SQLNestedException: Cannot create JDBC driver of class 'COM.ibm.db2.jdbc.app.DB2Driver' for...
1
4381
by: kommaraju | last post by:
iam a starter to db2 & jdbc.i have a servlet program which connects to ibm db2 using jdbc.when i run this using apache tomcat 4.1.34 , it is showing a error message of HTTP STATUS 500 my jdbc program is as follows import java.sql.*; import java.lang.*; import java.io.*; import java.util.*;
0
2725
ak1dnar
by: ak1dnar | last post by:
Hi Guys, I am using a virtual private server which runs Linux OS in it. On the server Apache and Tomcat has installed and to the best of my knowledge mod_jk also installed and working perfectly. In other words Apache is on Port and 80 and Tomcat is on 8080. but when I type http://mydomain.com/MyWebContext/a_file_name.jsp I can see the jsp pages inside tomcat webapps Dir, and If I need to access my phpmyadmin app which is inside Apache doc...
0
4229
by: Arun21084 | last post by:
Hi, Recently I installed an application HP SIP(Service Information Portal) on a Windows 2000 server.The application comes along with an installation of Tomcat 5.0.19. Already there was an Apache 2 running on the server used by other application. Once after installation of the product(HP SIP), I tried to restart the Tomcat 5.0.19 process using below methods(errors reported below respectively) 1) services.msc console Could not start...
10
12579
by: swethak | last post by:
Hi, i am first installing the tomcat 5.5 in my hosting server system and created the one folder(like test) in webapps and place all the jsp files.And also created the another folder(like test2) and place all related files in that. Now i give the url as http://localhost:8080/test/sample.jsp http://localhost:8080/test1/home.jsp Both are working fine.
0
9969
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main usage, and What is the difference between ONU and Router. Let’s take a closer look ! Part I. Meaning of...
1
10896
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
0
10443
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
0
9612
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project—planning, coding, testing, and deployment—without human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then launch it, all on its own.... Now, this would greatly impact the work of software developers. The idea...
1
7999
isladogs
by: isladogs | last post by:
The next Access Europe User Group meeting will be on Wednesday 1 May 2024 starting at 18:00 UK time (6PM UTC+1) and finishing by 19:30 (7.30PM). In this session, we are pleased to welcome a new presenter, Adolph Dupré who will be discussing some powerful techniques for using class modules. He will explain when you may want to use classes instead of User Defined Types (UDT). For example, to manage the data in unbound forms. Adolph will...
0
5830
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in the same network. But I'm wondering if it's possible to do the same thing, with 2 Pfsense firewalls...
0
6029
by: adsilva | last post by:
A Windows Forms form does not have the event Unload, like VB6. What one acts like?
1
4650
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system
2
4251
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.