By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,657 Members | 1,682 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,657 IT Pros & Developers. It's quick & easy.

Recordset is not updateable

P: 42
Hi guys

I have a little problem

i have a small database with 2 formrs

First form displays all the records and i also have a search button which allow the user to search for a specific record .
When the search buton is clicked then a macro runs wich consists of running the query and displaying the second form with the records found .
The only problem i have is that when the records are displayed i CAN''T modify the fields .
On the macro sttings there is an option when the form is opened to be ( edit mode, addmode , read only mode) and it is set to edit mode but still doesn't allow to modify the fields.

Thanks
May 19 '09 #1
Share this Question
Share on Google+
7 Replies


NeoPa
Expert Mod 15k+
P: 31,712
Check out the query that the form is bound to. You'll probably find that too, is not updatable.

Reasons for a Query to be Non-Updatable.
May 19 '09 #2

P: 42
Thnks for the Link .

I didn't know that if i'm using a union query , then the records are not updateable.

Is there any way around this to make it updateable.

All i'm doing is basically to allow the user to serach for different fields on the same search , if u understand me . ( like i have one textbox to serach for and i want to be able to serach by first name , by city ..etc) .

thanks
May 19 '09 #3

NeoPa
Expert Mod 15k+
P: 31,712
@onyris
It?

What does this refer to? You haven't posted any SQL for a query.
May 19 '09 #4

P: 42
Sorry i forgot to put the query

this is the query i'am using at the moment

Expand|Select|Wrap|Line Numbers
  1. SELECT *
  2. FROM [names]
  3. WHERE (((names.fisrt_name) Like "*" & [forms]![names_form]![txtname] & "*"));
  4. UNION SELECT *
  5. FROM [names]
  6. WHERE (((names.cemetery) Like "*" & [forms]![names_form]![txtname] & "*"));
when i run the query , it returns the record set that i want , but i can display it on the form , but i can't modify it . .
May 19 '09 #5

NeoPa
Expert Mod 15k+
P: 31,712
Ah, that makes more sense now.

You need just a little work on the WHERE clause instead :
Expand|Select|Wrap|Line Numbers
  1. SELECT * 
  2.  
  3. FROM [Names] 
  4.  
  5. WHERE ([First_Name] Like '*' & [Forms]![Names_Form]![txtName] & '*') 
  6.    OR ([Cemetery] Like '*' & [Forms]![Names_Form]![txtName] & '*')
NB. I re-spelled your field name which was mis-spelled.
May 19 '09 #6

P: 42
Thanks a lot , is working now and i can edit the fields .

Thanks again!!
May 19 '09 #7

NeoPa
Expert Mod 15k+
P: 31,712
You're welcome & I'm very pleased to hear it :)
May 20 '09 #8

Post your reply

Sign in to post your reply or Sign up for a free account.