By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
464,342 Members | 1,178 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 464,342 IT Pros & Developers. It's quick & easy.

Database corrupted? - Doing compact & repair, get error 'record is deleted'

100+
P: 167
I have an Access 2000 database (running on Windows XP) that is used as a model and each user grabs a copy of this and puts onto their own drive. I have had 2 folks have issues with it lately. When they try to open it, the application does not fully open. What you see is a blank grey form with the dark blue title bar at the top with the appliation title. The 'main' form that is set on the startup properties does not come up. Everything is blank. When I click the 'x' in the on the upper right to close it, I get the standard MS error stating the an error has been encountered, do you want to send it to MS.
I have gone into the database in design mode, tried to compact & repair but an error pop-up box comes up with the blue title bar 'Microsoft Access' and an error stating 'Record is deleted'.
I have also gone into the code for the event 'form open' for the main form and tried to put a debug statement and it when I close the form, I get the same 'Record is deleted' error.
I had the user get a new copy of the database and it works. However, I had the same thing happen to the another user today so it has become a re-occuring event I need to resolve. Any ideas???????
Nov 21 '07 #1
Share this Question
Share on Google+
1 Reply

P: 42
It sounds like one of the system tables might be corrupted, but maybe not. Can you create a new blank database & import all the objects from a fully-working copy into the new one? If that succeeds, it was the system. If that fails, it will most likely stop on whichever of your Access objects is corrupted. If the import doesn't work at all, you'll need to find a known-good copy & use that as your new master.

If the preceding "works", but it continues to malfunction, another thing to look at is - if you are using Memo fields anywhere, see if you find #Error displayed in a Memo field. Access 2000 sometimes has trouble with those fields. If that's the case, you would need to copy that record (without the memo field) into a temp table, delete the bad record, and then re-append from the temp table. The contents of the Memo would be lost.

Hope that helps.
Nov 22 '07 #2

Post your reply

Sign in to post your reply or Sign up for a free account.