By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,985 Members | 1,863 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,985 IT Pros & Developers. It's quick & easy.

a multi user ACCESS 200 database not allowing more than two users

P: 1
database not allowing multiusers
--------------------------------------------------------------------------------

Background

An ACCESS database containing two tables and three forms has been installed on the network drive. Using the Tools Menu (Security Sub Menu), five users have been added to the USERS group in the database. The Users group has been assigned OPEN/RUN permission for the database object. The DEFAULT RECORD LOCKING property in the OPTIONS DIALOG BOX, and the FORM Property Record Locks are both set to edited record. The OPEN DATA BASE USING RECORD-LEVEL LOCKING is clicked in the OPTIONS DIALOG BOX.

Ms ACCESS 2000 program is loaded on each workstation which is connected to the network drive.

All the workstation did have the FULL verion of ACCESS 2000; and a runtime version of ACCESS 2000. At installation the runtime version was removed using the Add/Remove feature of WINDOWS Xp.

Problem

The database worked fine when installed, and ran fine for two days.
After a couple of days, it does not allow more than two users to access the system. If more than two persons are in it and another one tries to
open it, it will say 'locked by machine number XXX' and doesn't allow
additional users to use it at the same time.

Question

Is this some type of bug and if so, how can i fix it? or
Did I not activate some feature which I should have to allow multiuser access or
Did I cause some inconsistencies between the OPTION /SECURITY/FORM SETTINGS.

Appreciation

I am still a novice when it comes to ACCESS. Thanks in advance for any help!
Mar 8 '07 #1
Share this Question
Share on Google+
2 Replies


NeoPa
Expert Mod 15k+
P: 31,347
I can't see what your problem would be here. But that's not unusual as if you'd known enough to know what information to post, you'd probably have resolved the problem anyway. What you did post was all good stuff, but unfortunately didn't contain any clue (at least for me) as to what your problem may be.
I can only suggest that you think about what may have happened differently after the first two days when it stopped working.
Mar 9 '07 #2

MMcCarthy
Expert Mod 10K+
P: 14,534
Check these settings in the advanced tab of the options box on all the computers using the database.

Default Open Mode = Shared
Default Record Locking = Edited Record
Mar 10 '07 #3

Post your reply

Sign in to post your reply or Sign up for a free account.