By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,952 Members | 909 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,952 IT Pros & Developers. It's quick & easy.

False row selection in subreport

P: n/a
I have a Report and subreport where the rows in the Report are selected
on a three part primary key. ID,YEAR,PERIOD.
The subreport has a data select statement on a second table related to
the first with the same
three columns ID,YEAR,PERIOD

I have an problem when there is no data for the subreport on PERIOD but
there is data for ID,YEAR but the previous PERIOD this is selected.
When data exists for the correct PERIOD the previous PERIOD data is not
reported (correctly).

I wonder if this might be to do with the underlying relationship in the
SQLServer database.
I found this did not pre-exist the report creation on my production
system (though it exists now)?

Any clues?

Aug 4 '06 #1
Share this Question
Share on Google+
1 Reply


P: n/a

Richard wrote:
I have a Report and subreport where the rows in the Report are selected
on a three part primary key. ID,YEAR,PERIOD.
The subreport has a data select statement on a second table related to
the first with the same
three columns ID,YEAR,PERIOD

I have an problem when there is no data for the subreport on PERIOD but
there is data for ID,YEAR but the previous PERIOD this is selected.
When data exists for the correct PERIOD the previous PERIOD data is not
reported (correctly).

I wonder if this might be to do with the underlying relationship in the
SQLServer database.
I found this did not pre-exist the report creation on my production
system (though it exists now)?

Any clues?
I found that the report creation wizard had only used the first part of
the key in childlinkfield/masterlinkfield.

Aug 7 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.