By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,835 Members | 1,959 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,835 IT Pros & Developers. It's quick & easy.

Win 98 to Win XP conversion - date format problem in mail merge

P: n/a
Since upgrading from old laptop (Windows 98) to new laptop (Windows XP), my
mail-merge letters are doing strange things with date formats. For
instance, my reminder letter for lapsed subs carries the 'expiry' date as a
merge field from the database, and this previously was shown as dd/mm/yy (UK
format). Now it persists in showing as mm/dd/yy. I've gone to the Windows
Control Panel and made sure that my Regional settings show UK format, even
deleted the option for US format! On the database the date format inputs
correctly, but the mail merge doesn't!

I can't send letters out with this format, as we don't read dates this way
in UK. For instance, someone whose subs expired on 1st October 2003
(01/10/03 in UK format) would get a letter saying their subs expired on 10th
January 2003 (10/01/03 in US format!)

I've even tried amending the input mask for dates, but the mail merge letter
still shows 'expiry' as mm/dd/yy.

Can anyone help me sort this out?

Many thanks

Ishbel Kargar
Nov 12 '05 #1
Share this Question
Share on Google+
8 Replies


P: n/a
Waste of time asking for subs from someone who has expired :-(

"Ishbel Kargar" <ik@radmid.demon.co.uk> wrote in message
news:bq*******************@news.demon.co.uk...
Since upgrading from old laptop (Windows 98) to new laptop (Windows XP), my mail-merge letters are doing strange things with date formats. For
instance, my reminder letter for lapsed subs carries the 'expiry' date as a merge field from the database, and this previously was shown as dd/mm/yy (UK format). Now it persists in showing as mm/dd/yy. I've gone to the Windows Control Panel and made sure that my Regional settings show UK format, even
deleted the option for US format! On the database the date format inputs
correctly, but the mail merge doesn't!

I can't send letters out with this format, as we don't read dates this way
in UK. For instance, someone whose subs expired on 1st October 2003
(01/10/03 in UK format) would get a letter saying their subs expired on 10th January 2003 (10/01/03 in US format!)

I've even tried amending the input mask for dates, but the mail merge letter still shows 'expiry' as mm/dd/yy.

Can anyone help me sort this out?

Many thanks

Ishbel Kargar

Nov 12 '05 #2

P: n/a
Dear Phil
Waste of time asking for subs from someone who has expired :-(


Thanks for your comment, quite logical I suppose, unless you know the people
I'm dealing with.

We are a small organisation and most of us know each other. Subs reminders
usually prompt an apologetic 'sorry I forgot to renew', together with a
cheque!

The letter I gave as an example was just one of several mail-merge letters,
and I really do need help with the date format problem.

So I still hope someone can help with the problem.

Regards to all

Ishbel

Nov 12 '05 #3

P: n/a
Two thoughts

1) Is the Control Panel Regional and language Options set correctly
2) Might be worth trying to show the date Format as Medium Date in the
underlying query

Phil
"Ishbel Kargar" <ik@radmid.demon.co.uk> wrote in message
news:bq*******************@news.demon.co.uk...
Dear Phil
Waste of time asking for subs from someone who has expired :-(

Thanks for your comment, quite logical I suppose, unless you know the

people I'm dealing with.

We are a small organisation and most of us know each other. Subs reminders usually prompt an apologetic 'sorry I forgot to renew', together with a
cheque!

The letter I gave as an example was just one of several mail-merge letters, and I really do need help with the date format problem.

So I still hope someone can help with the problem.

Regards to all

Ishbel

Nov 12 '05 #4

P: n/a

"Phil Stanton" <di********@stantonfamily.co.uk> wrote in message
news:3f***********************@mercury.nildram.net ...
Two thoughts

1) Is the Control Panel Regional and language Options set correctly
Yes, I've checked everything there, even deleted the option for USA format!
2) Might be worth trying to show the date Format as Medium Date in the
underlying query


Tried this, even converted the 'expiry' field in the main table to 'medium
date format', but it hasn't solved the problem. The Members Form also now
has 'medium date format', but the mail merge still produces the 'expiry'
date in mm/dd/yy - I'm puzzled! Not looking forward to altering all the
letters by hand!

Ishbel
Nov 12 '05 #5

P: n/a
One last idea, Ishbel, after this I give up

Try

In your query for the mail merge try the date for your letter
DateOut: Format$([ExpireyDate],"dd\/mm\/yyyy")

I am assuming your table holding the ExpireyDate is defined as a Date/Time
and not text

Phil
"Ishbel Kargar" <ik@radmid.demon.co.uk> wrote in message
news:bq******************@news.demon.co.uk...

"Phil Stanton" <di********@stantonfamily.co.uk> wrote in message
news:3f***********************@mercury.nildram.net ...
Two thoughts

1) Is the Control Panel Regional and language Options set correctly
Yes, I've checked everything there, even deleted the option for USA

format!
2) Might be worth trying to show the date Format as Medium Date in the underlying query


Tried this, even converted the 'expiry' field in the main table to 'medium
date format', but it hasn't solved the problem. The Members Form also now
has 'medium date format', but the mail merge still produces the 'expiry'
date in mm/dd/yy - I'm puzzled! Not looking forward to altering all the
letters by hand!

Ishbel

Nov 12 '05 #6

P: n/a
"Phil Stanton" wrote:
One last idea, Ishbel, after this I give up
Try
In your query for the mail merge try the date for your letter
DateOut: Format$([ExpireyDate],"dd\/mm\/yyyy")

I am assuming your table holding the ExpireyDate is defined as a Date/Time
and not text

Phil


Dear Phil

I'm grateful for all your help, but I've finally solved the problem in a
completely different way.

I began to wonder if the problem was not with Access, but with Word, because
all the lists, labels, reports, etc. produced by Access showed the dates in
the UK format. And yes, all date fields were already set as Date/Time and
not as Text.

My new laptop has brought with it Word 2002, whereas all my reminder letters
were prepared using Word 2000. In spite of adjusting the date format in
Word 2002 to 'English UK format - dd/mm/yy' the problem persisted, so I took
the plunge, deleted Word 2002 (with some regret because I liked some of the
new facilities), and re-installed Word 2000 from my Office 200 Premium disk.

Hurray!! The date fields in the letters now show the dd/mm.yy format once
more and I can get on with my mailshot.

I did try your (one last try) suggestion before I took the drastic step
described above, and it was because that didn't work that I began to look at
the problem from a different angle, and realised that the culprit was Word
2002! My faith in Access has been restored!

Thanks again

Best wishes
Ishbel


Nov 12 '05 #7

P: n/a
All good fun.

You would have thought Microsoft would have got that right. Or do you know
them better?????
Phil

"Ishbel Kargar" <ik@radmid.demon.co.uk> wrote in message
news:bq*******************@news.demon.co.uk...
"Phil Stanton" wrote:
One last idea, Ishbel, after this I give up
Try
In your query for the mail merge try the date for your letter
DateOut: Format$([ExpireyDate],"dd\/mm\/yyyy")

I am assuming your table holding the ExpireyDate is defined as a Date/Time and not text

Phil
Dear Phil

I'm grateful for all your help, but I've finally solved the problem in a
completely different way.

I began to wonder if the problem was not with Access, but with Word,

because all the lists, labels, reports, etc. produced by Access showed the dates in the UK format. And yes, all date fields were already set as Date/Time and
not as Text.

My new laptop has brought with it Word 2002, whereas all my reminder letters were prepared using Word 2000. In spite of adjusting the date format in
Word 2002 to 'English UK format - dd/mm/yy' the problem persisted, so I took the plunge, deleted Word 2002 (with some regret because I liked some of the new facilities), and re-installed Word 2000 from my Office 200 Premium disk.
Hurray!! The date fields in the letters now show the dd/mm.yy format once
more and I can get on with my mailshot.

I did try your (one last try) suggestion before I took the drastic step
described above, and it was because that didn't work that I began to look at the problem from a different angle, and realised that the culprit was Word
2002! My faith in Access has been restored!

Thanks again

Best wishes
Ishbel

Nov 12 '05 #8

P: n/a
Dear Phil
All good fun.
I see your point, it does sound like good fun, though I was almost at my
wit's end, and didn't see it as funny as the days went by with no solution.

However, the fun side is definitely there, in the form of having solved yet
another problem, in my 'love-hate' relationship with my computer.
Especially as I was also trying to get help from my teenage grandson (who
knows 'everything there is to know' about computers?). It's given me quite
a buzz to be able to say that a 74 year old grandmother still has the edge!
You would have thought Microsoft would have got that right. Or do you know
them better?????


I do now!

Thanks again

Regards
Ishbel

Nov 12 '05 #9

This discussion thread is closed

Replies have been disabled for this discussion.