By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,301 Members | 1,766 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,301 IT Pros & Developers. It's quick & easy.

Mail merge date problem with Word 2002 using Access as data source

P: n/a
I have a table of data in Access 2002 which is used as the source table for
a mail merge document using Word 2002 on my clients PC. The data is
transferred OK but I've noticed that any dates which fall between
1stday/anymonth/any year and 12thday/anymonth/any year are rearranged in the
wrong format. For example 4th July 2005 from the database would be displayed
as 07/05/2005 in the merged document. In addition blank date fields from the
source table are shown as the current date for that particular day. This
strange anomaly does not occur for any dates where the day goes beyond 12!?

However, when I run the same document and source on my own PC using Word
2003 the dates in the merged document are shown correctly and in the correct
format and blank date data is not shown. As a stab in the dark I'm using
Microsoft Word 11.0 Object library as the reference setting. Should this be
changed for Word 2002 to a lower reference? Or could there be a bug in Word
2002?

Any help or feedback would be much appreciated. At present my client would
have to check the document for all those dates <12th/month and edit them.
Obviously not very efficient.

Many thanks in advance
Dawn Davis
Nov 13 '05 #1
Share this Question
Share on Google+
7 Replies


P: n/a
Rog
Could it be one of the pc's has a different regional setting? Try
formatting the dates the way you want them in a query and use that as
your source.

Nov 13 '05 #2

P: n/a
Thanks for that. Have already set the date format in the query but no
change.

Thanks again

"Rog" <ro************@hotmail.com> wrote in message
news:11**********************@g49g2000cwa.googlegr oups.com...
Could it be one of the pc's has a different regional setting? Try
formatting the dates the way you want them in a query and use that as
your source.

Nov 13 '05 #3

P: n/a
"Andy Davis" <ad******@westnet.com.au> wrote in message
news:42********@quokka.wn.com.au...
Thanks for that. Have already set the date format in the query but no
change.

Thanks again

"Rog" <ro************@hotmail.com> wrote in message
news:11**********************@g49g2000cwa.googlegr oups.com...
Could it be one of the pc's has a different regional setting? Try
formatting the dates the way you want them in a query and use that as
your source.


You can force Word to use your preferred date format by using what Word
calls 'field switches' and are set up from the Word document or template.
You can get full details from the help file but in your case you simply need
to make sure your merge field says something like: { MERGEFIELD MyDate \@
"dd/MM/yyyy" }

Note you must use capital M for month - lower case m is for minute.

Nov 13 '05 #4

P: n/a
Justin

Many thanks but have already tried this but still did not work.

Dawn

"Justin Hoffman" <j@b.com> wrote in message
news:d9**********@nwrdmz03.dmz.ncs.ea.ibs-infra.bt.com...
"Andy Davis" <ad******@westnet.com.au> wrote in message
news:42********@quokka.wn.com.au...
Thanks for that. Have already set the date format in the query but no
change.

Thanks again

"Rog" <ro************@hotmail.com> wrote in message
news:11**********************@g49g2000cwa.googlegr oups.com...
Could it be one of the pc's has a different regional setting? Try
formatting the dates the way you want them in a query and use that as
your source.


You can force Word to use your preferred date format by using what Word
calls 'field switches' and are set up from the Word document or template.
You can get full details from the help file but in your case you simply
need
to make sure your merge field says something like: { MERGEFIELD MyDate \@
"dd/MM/yyyy" }

Note you must use capital M for month - lower case m is for minute.

Nov 13 '05 #5

P: n/a
"Andy Davis" <ad******@westnet.com.au> wrote in message
news:42********@quokka.wn.com.au...
Justin

Many thanks but have already tried this but still did not work.

Dawn

"Justin Hoffman" <j@b.com> wrote in message
news:d9**********@nwrdmz03.dmz.ncs.ea.ibs-infra.bt.com...
"Andy Davis" <ad******@westnet.com.au> wrote in message
news:42********@quokka.wn.com.au...
Thanks for that. Have already set the date format in the query but no
change.

Thanks again

"Rog" <ro************@hotmail.com> wrote in message
news:11**********************@g49g2000cwa.googlegr oups.com...
Could it be one of the pc's has a different regional setting? Try
formatting the dates the way you want them in a query and use that as
your source.


You can force Word to use your preferred date format by using what Word
calls 'field switches' and are set up from the Word document or template.
You can get full details from the help file but in your case you simply
need
to make sure your merge field says something like: { MERGEFIELD MyDate
\@
"dd/MM/yyyy" }

Note you must use capital M for month - lower case m is for minute.


I have never seen the MS Word field switches overridden - whenever date or
currency issues have occurred between machines, I have found this to work.
When you say you tried it, you mean that it worked on your machine but not
on your client's? Did you do this personally on site or just receive
feedback from the client?
The only things that occur to me are:
Make sure the field in Access is a real date field (not for example a text
field where someone is filling in a date) Perhaps you could check the
client's dataset.
Make sure you avoid reserved words like 'name' and 'date' for field names.
It may be worthwhile getting the client to check his references and make
sure none are missing.
If this is still a problem, you could go through the Windows control panel
settings with your client and try and replicate the problem.

Nov 13 '05 #6

P: n/a
I tested the merge document on my machine using Word 2003 and then I
personally tested it on their machine, they use Word 2002. This makes me
suspect it may be a bug with Word as I have tried using the field switch
formats and making sure the date format in my Access query is correct both
on my machine and my clients. I'm going to check the regional settings as a
stab in the dark so to speak and will let you know if i have any success.

Dawn
"Justin Hoffman" <j@b.com> wrote in message
news:d9*********@nwrdmz01.dmz.ncs.ea.ibs-infra.bt.com...
"Andy Davis" <ad******@westnet.com.au> wrote in message
news:42********@quokka.wn.com.au...
Justin

Many thanks but have already tried this but still did not work.

Dawn

"Justin Hoffman" <j@b.com> wrote in message
news:d9**********@nwrdmz03.dmz.ncs.ea.ibs-infra.bt.com...
"Andy Davis" <ad******@westnet.com.au> wrote in message
news:42********@quokka.wn.com.au...
Thanks for that. Have already set the date format in the query but no
change.

Thanks again

"Rog" <ro************@hotmail.com> wrote in message
news:11**********************@g49g2000cwa.googlegr oups.com...
> Could it be one of the pc's has a different regional setting? Try
> formatting the dates the way you want them in a query and use that as
> your source.

You can force Word to use your preferred date format by using what Word
calls 'field switches' and are set up from the Word document or
template.
You can get full details from the help file but in your case you simply
need
to make sure your merge field says something like: { MERGEFIELD MyDate
\@
"dd/MM/yyyy" }

Note you must use capital M for month - lower case m is for minute.


I have never seen the MS Word field switches overridden - whenever date or
currency issues have occurred between machines, I have found this to work.
When you say you tried it, you mean that it worked on your machine but not
on your client's? Did you do this personally on site or just receive
feedback from the client?
The only things that occur to me are:
Make sure the field in Access is a real date field (not for example a text
field where someone is filling in a date) Perhaps you could check the
client's dataset.
Make sure you avoid reserved words like 'name' and 'date' for field names.
It may be worthwhile getting the client to check his references and make
sure none are missing.
If this is still a problem, you could go through the Windows control panel
settings with your client and try and replicate the problem.

Nov 13 '05 #7

P: n/a
Have posted this query to a Word newsgroup and from the replies I'm getting
it appears to be a bug with Word 2002. In case anyone out there gets a
similar problem and is interested the following website aricle may shed some
light.
http://homepage.swissonline.ch/cindy...r/MergFram.htm

Click the link for Merge in Word 2002 and then select link Numeric and date
formatting under Connection Methods article.

Thanks for all the help everyone and I'll keep you posted how it goes.

Dawn
"Justin Hoffman" <j@b.com> wrote in message
news:d9*********@nwrdmz01.dmz.ncs.ea.ibs-infra.bt.com...
"Andy Davis" <ad******@westnet.com.au> wrote in message
news:42********@quokka.wn.com.au...
Justin

Many thanks but have already tried this but still did not work.

Dawn

"Justin Hoffman" <j@b.com> wrote in message
news:d9**********@nwrdmz03.dmz.ncs.ea.ibs-infra.bt.com...
"Andy Davis" <ad******@westnet.com.au> wrote in message
news:42********@quokka.wn.com.au...
Thanks for that. Have already set the date format in the query but no
change.

Thanks again

"Rog" <ro************@hotmail.com> wrote in message
news:11**********************@g49g2000cwa.googlegr oups.com...
> Could it be one of the pc's has a different regional setting? Try
> formatting the dates the way you want them in a query and use that as
> your source.

You can force Word to use your preferred date format by using what Word
calls 'field switches' and are set up from the Word document or
template.
You can get full details from the help file but in your case you simply
need
to make sure your merge field says something like: { MERGEFIELD MyDate
\@
"dd/MM/yyyy" }

Note you must use capital M for month - lower case m is for minute.


I have never seen the MS Word field switches overridden - whenever date or
currency issues have occurred between machines, I have found this to work.
When you say you tried it, you mean that it worked on your machine but not
on your client's? Did you do this personally on site or just receive
feedback from the client?
The only things that occur to me are:
Make sure the field in Access is a real date field (not for example a text
field where someone is filling in a date) Perhaps you could check the
client's dataset.
Make sure you avoid reserved words like 'name' and 'date' for field names.
It may be worthwhile getting the client to check his references and make
sure none are missing.
If this is still a problem, you could go through the Windows control panel
settings with your client and try and replicate the problem.

Nov 13 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.