By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
426,107 Members | 1,323 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 426,107 IT Pros & Developers. It's quick & easy.

Access & Mysql properties problem

P: n/a
Hi,

I have a question regarding autonumbering . I'm using linked tables between
msql and MS Access. Quite a few linked tables exist with relationships. The
auto increment fields once linked loose thier autonumber property and come
up as numbers.

I have developed a form interface and when I press the next record the next
number does not come as the autonumber property has been lost. Thier are
quite a few relationships with linked tables to the mysql database and I
need the primary numbers of those tables within the forms to appear
automatically.

I would really appreciate you help with this problem.

Looking forward to hearing from you.

Smriti

Nov 12 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

In Access (JET db engine) when a record is "started" in a form, the
AutoNumber is created. In some other db engine's the AutoNumber (or
Identity number) is created after the record is "finished" in the form
(just before it is saved to the table).

- --
MGFoster:::mgf
Oakland, CA (USA)

-----BEGIN PGP SIGNATURE-----
Version: PGP for Personal Privacy 5.0
Charset: noconv

iQA/AwUBP5IJXYechKqOuFEgEQJQGwCg1YeWGPzX2An+fLUToKM/FIS3NY8An1ks
tnkJbVjf74KqOt5sZVXIpCFV
=36gA
-----END PGP SIGNATURE-----

Smriti Dev wrote:
Hi,

I have a question regarding autonumbering . I'm using linked tables between
msql and MS Access. Quite a few linked tables exist with relationships. The
auto increment fields once linked loose thier autonumber property and come
up as numbers.

I have developed a form interface and when I press the next record the next
number does not come as the autonumber property has been lost. Thier are
quite a few relationships with linked tables to the mysql database and I
need the primary numbers of those tables within the forms to appear
automatically.

I would really appreciate you help with this problem.

Looking forward to hearing from you.

Smriti


Nov 12 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.