By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,333 Members | 1,843 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,333 IT Pros & Developers. It's quick & easy.

p.start() after installing win2003 sp1

P: n/a
I wrote a program to copy files from lots of different remote servers
to a centrally based server. It uses robocopy, but is written in
vb.net to add extra features, eg it records how long it to to copy, and
keeps a record of all the files it has copied. As the network
connection at the central site is way faster that the remote sites, it
launches up to 40 processes (of robocopy) at the same time.
This worked fine under windows 2003, but after installing sp1 - it
would only launch about 10 processes before it would not open any more.
The program still worked, but it now waits until one of the processes
ended before it would open another one. (Which has resulted in it
taking too long to copy all the files over) It demonstrates the same
behaviour in Windows XP SP2 as well (only it will only launch 5
processes), however I originially wrote it on Windows XP SP1 - and it
was fine on that too. It opens the process using p.start() (where p is
a new process) - but it pauses if it tries to open the 6th one (on
WinXP SP2).

Does anyone have any suggestions how I could return it to its pre SP1
behaviour? (without uninstalling SP1).
Thanks.

Nov 21 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.