By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,759 Members | 1,727 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,759 IT Pros & Developers. It's quick & easy.

Installer isn't removing previous version

P: n/a
I've created a Windows setup project in VS.NET 2003. The first setup ran
fine minus creating the Program's group. I made some changes and rebuilt
the MSI and setup.exe files. Now when I run the setup.exe, I get this
popup:

Windows Installer:
Another version of this product is already installed.
Installation of this version cannot continue. To
configure or remove the existing version of this product,
use Add/Remove Programs on the Control Panel.

In Project Deployment Properties, I have remove previous versions set to
True. Why doesn't this work? How else can I install without having the
user do add/remove programs? Most installers will remove previous versions
or just install without asking.

Thanks,
Brett
Nov 21 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
I have had the same problem for over a year with Windows Installer too

You set it to remove previous & it doesn't

There are a few bugs in Windows Installer. Another is adding your own icon
to the add/remove group. If you say you want it, it creates a folder. If you
say you don't want it then it creates the icon.

If you find the solution to this then let me know please, not that I create
that many Windows Installer projects any more.

Crouchie1998
BA (HONS) MCP MCSE
Nov 21 '05 #2

P: n/a
I'm only using it for av EXE, couple of DLLs, and CHM files. Wouldn't a
ZipEXE work just as good? It won't create all the directory structure but
at least it doesn't require more work than the Win Installer bug.

Brett
"Crouchie1998" <cr**********@discussions.microsoft.com> wrote in message
news:%2****************@TK2MSFTNGP15.phx.gbl...
I have had the same problem for over a year with Windows Installer too

You set it to remove previous & it doesn't

There are a few bugs in Windows Installer. Another is adding your own icon
to the add/remove group. If you say you want it, it creates a folder. If
you
say you don't want it then it creates the icon.

If you find the solution to this then let me know please, not that I
create
that many Windows Installer projects any more.

Crouchie1998
BA (HONS) MCP MCSE

Nov 21 '05 #3

P: n/a
Make sure the the directories you've creates are set to 'Always Create =
True'

Crouchie1998
BA (HONS) MCP MCSE
Nov 21 '05 #4

P: n/a
Is there a better free installer available?

Thanks,
Brett
"Crouchie1998" <cr**********@spamcop.net> wrote in message
news:uj**************@TK2MSFTNGP14.phx.gbl...
Make sure the the directories you've creates are set to 'Always Create =
True'

Crouchie1998
BA (HONS) MCP MCSE

Nov 21 '05 #5

P: n/a
Try incrementing the version of your installer in the project. I did that
on my machine here and it works. Going to try it on the machine tomorrow
that's giving me the error.

Let me know if it works for you.

Also, the program group is created in the Start | Programs menu. But the
folder is empty. How do I tell the installer to put a short cut to the
program in the folder?

thanks,
Brett
"Crouchie1998" <cr**********@spamcop.net> wrote in message
news:uj**************@TK2MSFTNGP14.phx.gbl...
Make sure the the directories you've creates are set to 'Always Create =
True'

Crouchie1998
BA (HONS) MCP MCSE

Nov 21 '05 #6

P: n/a
To create an icon in the Start | Programs menu, you need to view the file
system within the installer project by right clicking the installer project
and selecting View > File System.

You will see a list of directories you can update, one of which will be
"Users Programs Menu". Create a sub-folder under that for your program
group (the name of this folder will be the name of your program group).
Then select this foler and then in the right hand "pane", right click and
select "Create New Shortcut". A list of folders will be displayed, find
"application folder" and there should be a short cut to your project
executeable displayed. This will create a shortcut to your executeable
within this program group.

The properties of the shortcut include the icon you wish to give it It
doesn't appear to default to any icon within your project or startup form,
you will need to include the icon manually in the files uploaded and then
link it here.

I hope that this answers the question you were asking and that I've not
insulted your intelligence by making step by step notes! I too have
struggled with the Installer, which although in the main appears to work,
doesn't appear to be very well documented!

Hope this helps.

Regards

Simon
"Brett" <no@spam.net> wrote in message
news:eA**************@TK2MSFTNGP10.phx.gbl...
Try incrementing the version of your installer in the project. I did that
on my machine here and it works. Going to try it on the machine tomorrow
that's giving me the error.

Let me know if it works for you.

Also, the program group is created in the Start | Programs menu. But the
folder is empty. How do I tell the installer to put a short cut to the
program in the folder?

thanks,
Brett
"Crouchie1998" <cr**********@spamcop.net> wrote in message
news:uj**************@TK2MSFTNGP14.phx.gbl...
Make sure the the directories you've creates are set to 'Always Create =
True'

Crouchie1998
BA (HONS) MCP MCSE


Nov 21 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.