By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,222 Members | 2,478 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,222 IT Pros & Developers. It's quick & easy.

How to install PIL on Mac OS 10.5.8?

P: 1
Hello all,

I'm new to python and Macs in general, and I'm having a heck of a time installing PIL (or getting Python to recognize it). First some background (not sure how much of this will be pertinent):

I'm using OS 10.5.8. In installing python I may have botched things up from the start since I didn't know what I was doing. OS 10.5.8 comes with some version of python (2.5 I think?) but everyone recommends updating so I installed 2.7. Unfortunately when I tried to install numpy and scipy I found that this is not possible on 2.7 without a significant amount of rigamarole. So I've downloaded 2.6.6 and now have three versions of python. 2.6.6 is the default one in bash. I'm also fairly certain I have some kind of a fortran compiler because once upon a time I did compile a single piece of fortran code, however I'm not sure if it's setup correctly.

I'm now trying to install PIL 1.1.7, following the instructions in the readme. When I type
Expand|Select|Wrap|Line Numbers
  1. python setup.py install
the installation seems to start and I get a whole bunch of troubling messages.
Here's a sampling of them:
Expand|Select|Wrap|Line Numbers
  1. /usr/include/architecture/ppc/math.h:675: warning: conflicting types for built-in function 'scalb'
  2. _imaging.c:2907: warning: initialization from incompatible pointer type
it concludes with the following:
Expand|Select|Wrap|Line Numbers
  1. ld warning: in /sw/lib/libjpeg.dylib, file is not of required architecture
  2. ld: in /Developer/SDKs/MacOSX10.4u.sdk/usr/local/lib/libgcc_s.1.dylib, missing required architecture ppc in file for architecture ppc
  3. collect2: ld returned 1 exit status
  4. lip: can't open input file: /car/folders/-0/-0LrikNVFoq8-dU1w90elIE+++TI/-Tmp-//ccLF4Kkn.out (No such file or directory)
  5. error: command 'gcc-4.0' failed with exit status 1
I've tried following the suggestions in the readme of trying to make sure i have necessary libraries and installing stuff with fink, but to no avail. I have a feeling numerous things are messed up: compilers, file locations, bash file, etc. what's the easiest way to get things going? I'm definitely willing to reinstall python, edit my bash, whatever needs to be done to get things going. The caveat is of course that I could really use detailed directions of how to do these things.

Your time and advice is much appreciated!
Jan 7 '11 #1
Share this question for a faster answer!
Share on Google+

Post your reply

Sign in to post your reply or Sign up for a free account.