473,225 Members | 1,310 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 473,225 software developers and data experts.

Python 2.4.4, Segmentation fault

Program terminated with signal 11, Segmentation fault.
Environment: FreeBSD 6.2, Python 2.4.4, MySQLdb 1.2.2, SQLObject 0.9.1

I faced with an error in our multithreaded, network oriented application, wich interacts actively with MySQL database. Brief information from core dump is below (more detailed one is in the file attached).

Though I am not very experienced with FreeBSD and gdb, I have still tried to collect information about the error. As far as I understand there is recursion in thread 14, which is a reason of the error. Even though I tried to track it down I didn't manage to do it.

I'll be happy to hear any comments, suggestions and any support to my assumption.

TIA

Here is a link to the full gdb info: http://paste-it.net/5038

...

#0 0x0000000800b5356c in pthread_testcancel () from /lib/libpthread.so.2
[New Thread 0x2a6f800 (sleeping)]
[New Thread 0x1786800 (sleeping)]
[New Thread 0x1739000 (sleeping)]
[New Thread 0x1792400 (runnable)]
[New Thread 0x1791800 (sleeping)]
[New Thread 0x1791400 (sleeping)]
[New Thread 0x1791000 (sleeping)]
[New Thread 0x178cc00 (sleeping)]
[New Thread 0x178c400 (sleeping)]
[New Thread 0x1731400 (sleeping)]
[New Thread 0x1690c00 (sleeping)]
[New Thread 0x14f8800 (sleeping)]
[New Thread 0x14f8400 (LWP 100180)]
[New Thread 0x639000 (runnable)]
[New LWP 100087]
(gdb)

...

(gdb) bt
#0 0x0000000800b5352c in pthread_testcancel () from /lib/libpthread.so.2
#1 0x0000000800b42000 in sigaction () from /lib/libpthread.so.2
#2 0x0000000800b4bf1a in pthread_mutexattr_init () from /lib/libpthread.so.2
#3 0x0000000000000000 in ?? ()
Cannot access memory at address 0x7fffffbff000

...

(gdb) info threads
* 15 LWP 100087 0x0000000800b5356c in pthread_testcancel ()
from /lib/libpthread.so.2
14 Thread 0x639000 (runnable) 0x0000000802b33858 in seq2set (seq=0x5e7520,
set=0x7fffffff1850, fd2obj=0x7fffffff5960)
at /usr/local/ports/distfiles/python/Python-2.4.4/Modules/selectmodule.c:100
13 Thread 0x14f8400 (LWP 100180) 0x0000000800b5352c in pthread_testcancel ()
from /lib/libpthread.so.2
12 Thread 0x14f8800 (sleeping) 0x0000000800b4bfdf in pthread_mutexattr_init
() from /lib/libpthread.so.2
11 Thread 0x1690c00 (sleeping) 0x0000000800b4bfdf in pthread_mutexattr_init
() from /lib/libpthread.so.2
10 Thread 0x1731400 (sleeping) 0x0000000800b4bfdf in pthread_mutexattr_init
() from /lib/libpthread.so.2
9 Thread 0x178c400 (sleeping) 0x0000000800b4bfdf in pthread_mutexattr_init
() from /lib/libpthread.so.2
8 Thread 0x178cc00 (sleeping) 0x0000000800b4bfdf in pthread_mutexattr_init
() from /lib/libpthread.so.2
7 Thread 0x1791000 (sleeping) 0x0000000800b4bfdf in pthread_mutexattr_init
() from /lib/libpthread.so.2
6 Thread 0x1791400 (sleeping) 0x0000000800b4bfdf in pthread_mutexattr_init
() from /lib/libpthread.so.2
5 Thread 0x1791800 (sleeping) 0x0000000800b4bfdf in pthread_mutexattr_init
() from /lib/libpthread.so.2
4 Thread 0x1792400 (runnable) 0x0000000800b4bfdf in pthread_mutexattr_init
() from /lib/libpthread.so.2
3 Thread 0x1739000 (sleeping) 0x0000000800b4bfdf in pthread_mutexattr_init
() from /lib/libpthread.so.2
2 Thread 0x1786800 (sleeping) 0x0000000800b4bfdf in pthread_mutexattr_init
() from /lib/libpthread.so.2
1 Thread 0x2a6f800 (sleeping) 0x0000000800b4bfdf in pthread_mutexattr_init
() from /lib/libpthread.so.2
Dec 5 '07 #1
0 1148

Sign in to post your reply or Sign up for a free account.

Similar topics

2
by: satish | last post by:
Hello all, I have a shared object executable viz. *cable* which I execute as follows : $ ansyscust71 -custom cable -p ANSYSRF **ansyscust71 is a shell script and is a part of a software...
5
by: Fra-it | last post by:
Hi everybody, I'm trying to make the following code running properly, but I can't get rid of the "SEGMENTATION FAULT" error message when executing. Reading some messages posted earlier, I...
99
by: Shi Mu | last post by:
Got confused by the following code: >>> a >>> b >>> c {1: , ], 2: ]} >>> c.append(b.sort()) >>> c {1: , ], 2: , None]}
18
by: Digital Puer | last post by:
Hi, I'm coming over from Java to C++, so please bear with me. In C++, is there a way for me to use exceptions to catch segmentation faults (e.g. when I access a location off the end of an array)?...
27
by: Paminu | last post by:
I have a wierd problem. In my main function I print "test" as the first thing. But if I run the call to node_alloc AFTER the printf call I get a segmentation fault and test is not printed! ...
2
by: robert | last post by:
When employing complex UI libs (wx, win32ui, ..) and other extension libs, nice "only Python stack traces" remain a myth. Currently I'm hunting again a rare C-level crash bug of a Python based...
3
by: madunix | last post by:
My Server is suffering bad lag (High Utlization) I am running on that server Oracle10g with apache_1.3.35/ php-4.4.2 Web visitors retrieve data from the web by php calls through oci cobnnection...
3
by: ShambhuHubli | last post by:
Hi all!! .. I am New member to this group. And also new to C/PYTHON API coding. I am trying to have two way communication i,e i am calling from python to C and then from C to python. I have no...
1
by: nimitsis | last post by:
Hello everyone I try to extend Python using a simple C wrapped module . This module includes embedded python code and it is product of Swig . The corresponding files follows : //main.c #include...
9
by: Randy.Galbraith | last post by:
I'm investigating the possible use of Mecurial SCM as a replacement for CVS. Mecurial is written in Python. I have a background in GNU/ Linux, Solaris, sparc and Perl. However AIX, powerpc and...
0
by: VivesProcSPL | last post by:
Obviously, one of the original purposes of SQL is to make data query processing easy. The language uses many English-like terms and syntax in an effort to make it easy to learn, particularly for...
3
isladogs
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 3 Jan 2024 starting at 18:00 UK time (6PM UTC) and finishing at about 19:15 (7.15PM). For other local times, please check World Time Buddy In...
0
by: mar23 | last post by:
Here's the situation. I have a form called frmDiceInventory with subform called subfrmDice. The subform's control source is linked to a query called qryDiceInventory. I've been trying to pick up the...
0
by: abbasky | last post by:
### Vandf component communication method one: data sharing ​ Vandf components can achieve data exchange through data sharing, state sharing, events, and other methods. Vandf's data exchange method...
2
isladogs
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 7 Feb 2024 starting at 18:00 UK time (6PM UTC) and finishing at about 19:30 (7.30PM). In this month's session, the creator of the excellent VBE...
0
by: fareedcanada | last post by:
Hello I am trying to split number on their count. suppose i have 121314151617 (12cnt) then number should be split like 12,13,14,15,16,17 and if 11314151617 (11cnt) then should be split like...
0
by: stefan129 | last post by:
Hey forum members, I'm exploring options for SSL certificates for multiple domains. Has anyone had experience with multi-domain SSL certificates? Any recommendations on reliable providers or specific...
1
by: davi5007 | last post by:
Hi, Basically, I am trying to automate a field named TraceabilityNo into a web page from an access form. I've got the serial held in the variable strSearchString. How can I get this into the...
0
by: MeoLessi9 | last post by:
I have VirtualBox installed on Windows 11 and now I would like to install Kali on a virtual machine. However, on the official website, I see two options: "Installer images" and "Virtual machines"....

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.