By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,532 Members | 1,483 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,532 IT Pros & Developers. It's quick & easy.

simple script - Tkinter question.

P: n/a
Hi everyone,

Here is my simple Tkinter script:

## start of entry.py
from Tkinter import *
root=Tk()
e1=Entry(root, width=16)
e1.pack()
e2=Entry(root, width=16)
e2.pack()
mainloop()
## end

First, it works on win2k. When I run it as 'python entry.py' on linux,
both 'e1' and 'e2' appear perfectly except I cannot enter any
character in 'e1' entry, but 'e2' entry is ok.

Second, when I run it in python interactive shell LINE BY LINE, then
'e1' and 'e2' entry both can accept user input, no problem! But when I
copy and paste it into interactive shell, then the first situation
happens again.

So..., has anyone ever run into this problem like me? and how do you
fix it? I use python2.3.4 now.
Thank you!


Jul 4 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.