473,837 Members | 1,598 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

Problems installing cvs / errno?

Hi ng,

i have a problem installing cvs module from:
http://www.object-craft.com.au/projects/csv/

My Python version is: Python 2.1.3
(Not the latest, but i need this version for running Zope Application
Server)

I downloaded the package (csv-1.0) and tried to install with python
setup.py install. But i got following errormessages:

-snip-
running install
running build
running build_ext
building 'csv' extension
skipping csv.c (build/temp.freebsd-4.8-RELEASE-i386-2.1/csv.o up-to-date)
cc -shared -pthread build/temp.freebsd-4.8-RELEASE-i386-2.1/csv.o -o
build/lib.freebsd-4.8-RELEASE-i386-2.1/csv.so
Traceback (most recent call last):
File "setup.py", line 63, in ?
license = 'BSD - see file LICENCE',
File "/usr/local/lib/python2.1/distutils/core.py", line 138, in setup
dist.run_comman ds()
File "/usr/local/lib/python2.1/distutils/dist.py", line 899, in
run_commands
self.run_comman d(cmd)
File "/usr/local/lib/python2.1/distutils/dist.py", line 919, in
run_command
cmd_obj.run()
File "/usr/local/lib/python2.1/distutils/command/install.py", line
480, in run
self.run_comman d('build')
File "/usr/local/lib/python2.1/distutils/cmd.py", line 328, in
run_command
self.distributi on.run_command( command)
File "/usr/local/lib/python2.1/distutils/dist.py", line 919, in
run_command
cmd_obj.run()
File "/usr/local/lib/python2.1/distutils/command/build.py", line 106,
in run
self.run_comman d(cmd_name)
File "/usr/local/lib/python2.1/distutils/cmd.py", line 328, in
run_command
self.distributi on.run_command( command)
File "/usr/local/lib/python2.1/distutils/dist.py", line 919, in
run_command
cmd_obj.run()
File "/usr/local/lib/python2.1/distutils/command/build_ext.py", line
256, in run
self.build_exte nsions()
File "/usr/local/lib/python2.1/distutils/command/build_ext.py", line
383, in build_extension s
self.build_exte nsion(ext)
File "/usr/local/lib/python2.1/distutils/command/build_ext.py", line
475, in build_extension
build_temp=self .build_temp)
File "/usr/local/lib/python2.1/distutils/ccompiler.py", line 663, in
link_shared_obj ect
extra_preargs, extra_postargs, build_temp)
File "/usr/local/lib/python2.1/distutils/unixccompiler.p y", line 235,
in link
self.spawn(self .linker_so + ld_args)
File "/usr/local/lib/python2.1/distutils/ccompiler.py", line 826, in
spawn
spawn (cmd, verbose=self.ve rbose, dry_run=self.dr y_run)
File "/usr/local/lib/python2.1/distutils/spawn.py", line 38, in spawn
_spawn_posix(cm d, search_path, verbose, dry_run)
File "/usr/local/lib/python2.1/distutils/spawn.py", line 108, in
_spawn_posix
exec_fn(cmd[0], cmd)
File "/usr/local/lib/python2.1/os.py", line 291, in execvp
_execvpe(file, args)
File "/usr/local/lib/python2.1/os.py", line 305, in _execvpe
from errno import ENOENT, ENOTDIR
ImportError: No module named errno
error: command 'cc' failed with exit status 1
-snip-

Is there a problem with the errno module? Can i install the module
manually. I can compile the csv.c code manual to a csv.o object. How can
i compile the source to a python object?

Any other ideas?

Thanks and forgive my bad english, ;)
Alex

Jul 18 '05 #1
0 2098

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

3
5588
by: Narayan Appachar | last post by:
Hi, We were able to build stored procedures without any problems till now. Now while building procedures, we are getting the following errors ------------------------------------------ Create stored procedure returns -7032. SQL7032N SQL procedure "TESTMD5_1" not created. Diagnostic file is "P7374587.log". SQLSTATE=42904
33
3037
by: wespvp | last post by:
When I try to run thread_test.c from the CVS tip, it hangs in an infinite CPU loop on both linux (RedHat AS 3.0, gcc 3.2.3) and Mac OS X 10.3.3 (gcc 3.3). I've also tried down to gcc 2.96 on Mac OS X. If I compile it with -g instead of -O2 on linux, it runs to completion and gives me: Add this to your template/$port file: STRERROR_THREADSAFE=yes
27
2165
by: G Patel | last post by:
Hello, I'm having trouble with floating point problems. I'm trying to write a function that calculates the distance between two cartesian points (integer coordinates). I have the function working, but it fails on one test case. Here is my function:
1
2697
by: Skeets | last post by:
i'm having some php problems. i have the following code on my main page: ------------ $fp = fsockopen("127.0.0.1", 49152, $errno, $errrstr, 30); if (!$fp) { echo "socket error: $errstr ($errno)<br />\n"; die;
1
3608
by: Michael Yanowitz | last post by:
Hello: Below I have included a stripped down version of the GUI I am working on. It contains 2 dialog boxes - one main and one settings. It has the following problems, probably all related, that I am hoping someone knows what I am doing wrong: 1) Pressing the Settings.. Button multiple times, brings up many instances of the Settings Panel. I just want it to bring up one. Is there an easy way to do that?
3
1986
by: Thomas Ploch | last post by:
Hello folks, Since this is my first post on the list, a brief introduction of myself. My name is Thomas, I am 26 years old, I am a student of Computational Linguistics and I am a python user. :-) Now my problem: I have Tcl/Tk 8.4.4 installed:
15
2971
by: John Nagle | last post by:
I've been installing Python and its supporting packages on a dedicated server with Fedora Core 6 for about a day now. This is a standard dedicated rackmount server in a colocation facility, controlled via Plesk control panel, and turned over to me with Fedora Core 6 in an empty state. This is the standard way you get a server in a colo today. Bringing Python up in this completely clean environment is a huge hassle, and it doesn't...
9
5460
by: mhearne808[insert-at-sign-here]gmail[insert-dot-he | last post by:
I'm having a number of problems with the fcntl module. First off, my system info: Mac OS X Darwin igskcicglthearn.cr.usgs.gov 8.10.1 Darwin Kernel Version 8.10.1: Wed May 23 16:33:00 PDT 2007; root:xnu-792.22.5~1/RELEASE_I386 i386 i386 Python 2.5.1 (built from source) OK, the weirdness:
0
2162
by: trihaitran | last post by:
I am reading chapter two of the Pylons book. In the text I am told to run: $ python virtualenv.py --no-site-packages env This is what I got back: $ python virtualenv.py --no-site-packages env New python executable in env/bin/python Installing setuptools........... Complete output from command env/bin/python -c "#!python
0
9678
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language synchronization. With a Microsoft account, language settings sync across devices. To prevent any complications,...
0
10863
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
1
10609
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
0
10263
tracyyun
by: tracyyun | last post by:
Dear forum friends, With the development of smart home technology, a variety of wireless communication protocols have appeared on the market, such as Zigbee, Z-Wave, Wi-Fi, Bluetooth, etc. Each protocol has its own unique characteristics and advantages, but as a user who is planning to build a smart home system, I am a bit confused by the choice of these technologies. I'm particularly interested in Zigbee because I've heard it does some...
1
7798
isladogs
by: isladogs | last post by:
The next Access Europe User Group meeting will be on Wednesday 1 May 2024 starting at 18:00 UK time (6PM UTC+1) and finishing by 19:30 (7.30PM). In this session, we are pleased to welcome a new presenter, Adolph Dupré who will be discussing some powerful techniques for using class modules. He will explain when you may want to use classes instead of User Defined Types (UDT). For example, to manage the data in unbound forms. Adolph will...
0
5663
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in the same network. But I'm wondering if it's possible to do the same thing, with 2 Pfsense firewalls...
1
4468
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system
2
4034
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.
3
3120
bsmnconsultancy
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating effective websites that not only look great but also perform exceptionally well. In this comprehensive...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.