469,090 Members | 1,187 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,090 developers. It's quick & easy.

Postgresql 7.3 And Redhat Enterprise 3

Hello,

I've installed redhat enterprise 3 on a system to use as a db server.
Manually I can install and run postgresql 7.3 (the one on the extras
CD). The problem is when you try to add postgres as a service, it
might add it, but it will not start it. To do this, we got a
postgresql script, placed it in the init.d folder with all the other
service shell scripts, and then went into services, add service, and
typed postgres. The specific error received is:

env: /etc/init.d/postgres no directory or file found

Is there some environment variable that needs to be set in some file
somewhere. I read a lot of documentation online, and modified whatever
files that people mentioned, but maybe I'm missing something?

Just to clarify, the server pgsql components are installed. I've done
several fresh installs with all kinds of options either selected or
de-selected. For example, I've installed all client, and server
components at one point.

What baffles me as well is that on Redhat 9.0 it sets up postgres for
you on an install, and automatically adds, and configures it under
services so that it auto starts postgres on a server reboot.

Any help is appreciated. Thanks.
Jul 19 '05 #1
2 1972

Ah obviously you need to check that execute priveliges are set ..
root

$ chmod +x /etc/init.d/postgresq

Unregistered
-----------------------------------------------------------------------
Posted via http://www.webservertalk.co
-----------------------------------------------------------------------
View this thread: http://www.webservertalk.com/message107110.htm

Jul 19 '05 #2

1 check you have postgres user and group
2 put export PGDATA=/var/lib/pgsql/data or similar in postgres user
.bash_profile
3 as postgres user run createdb

now does it work?
as root
$ service postgresql start

no ?
in /etc/init.d/postgresql file
check PGVERSION is set to 7.3
explicitly define PGDATA variable as -D parameter

edit $PGDATA/postgresql.conf
you probably neet to set
tcpip_socket = tru

Unregistered
-----------------------------------------------------------------------
Posted via http://www.webservertalk.co
-----------------------------------------------------------------------
View this thread: http://www.webservertalk.com/message107110.htm

Jul 19 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

5 posts views Thread by Carlos Moreno | last post: by
4 posts views Thread by D. Dante Lorenso | last post: by
3 posts views Thread by hrishy | last post: by
14 posts views Thread by Manuel Tejada | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.