By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,377 Members | 3,052 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,377 IT Pros & Developers. It's quick & easy.

Installing PostgreSQL 8.1 on VISTA

P: 26
I'm trying to install PostGres8.1 on VISTA but at the end of the installation it's saying that "can not create user postgres:Access denied" and roles back. Any Ideas how to fix this issue???
ANY HELP????!!!!!
Apr 10 '07 #1
Share this Question
Share on Google+
11 Replies


Expert 100+
P: 534
What kind of privileges you have with your user account?
I did not work with Vista, but I think you need to look at User Account Control , and perhaps run a quick test - see if you can manually create a new user on this PC.
Apr 10 '07 #2

P: 26
I created a user called postgres but it didn't work either.
Apr 11 '07 #3

Expert 100+
P: 534
Actually I meant "try to create some user", just to see if you have enough privileges for that. Postgres may not be able to complete installation if specified user already exists. I would delete this user before attempting another install.

What you experiencing is a compatibility issue with installation, (you can call it a bug; looks like it will be fixed in version 8.3)
This problem is documented here
along with some hints on how to work around it and make install work.

You may also find some practical help in this article

They make a couple of interesting comments relevant to your problem:

Prior to version 8.2, PostgreSQL refused to run with administrative privileges as a security precaution designed to limit the damage caused by a security incident involving this software.
... ... ... ...
Notes on Vista:
The install on Vista is similar to other Windows installs but to install on Vista, you must turn off User Account Control first.
Apr 11 '07 #4

P: 26
My Vista is Home Basic. I can not disable UAC. Is there a way that I can disable the UAC?
Apr 12 '07 #5

Expert 100+
P: 534
Disable User Account Control from prompting for credentials to install applications - read this section here
(actually, it may help to read the entire article)

Alternatively you can try a workaround described in the pgFoundry
I referred to in my previous post:

... run a Command Prompt as Administrator, then directly execute the postgresql-8.2.msi from that command prompt.
Apr 12 '07 #6

P: 1
Enable your Administrator account. Login as the administrator and the install program will then be able to create the user.

Being logged in as an administrative user is NOT the same as being logged in as the Administrator.
May 11 '07 #7

P: 1
Simpler solution:

1. Start/All Programs/Accessories
2. Right-click on Command Prompt
3. Select "Run as Administrator"
4. Click OK on the dialog that appears
5. cd \[The directory where you put the install files]
6. Run the installer .msi from the command line.

This worked fine for me.
May 23 '07 #8

P: 20
very very thanks.This way working fine for me.I am very happy about your posting.Because i am held up on last 15 days for instaling postgres in vista.

Kindly Regards
Siva
Jun 2 '07 #9

P: 1
Simpler solution:

1. Start/All Programs/Accessories
2. Right-click on Command Prompt
3. Select "Run as Administrator"
4. Click OK on the dialog that appears
5. cd \[The directory where you put the install files]
6. Run the installer .msi from the command line.

This worked fine for me.
Very Thanks....Yes! it worked for me.

Regards
A.Salam
Jul 19 '07 #10

P: 24
Thanks alot for Davidturner reply !!! Thanks Much
Nov 20 '07 #11

P: 1
Mr. Turner, I have tried to do what you have suggested but still I cannot finish the installation.

I got the message "The user account already exist.!"

Is there another way that Vista users can do this one easily?

Please help!

Thanks!
Aug 14 '08 #12

This discussion thread is closed

Replies have been disabled for this discussion.