469,593 Members | 1,901 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,593 developers. It's quick & easy.

PG_HBA.conf still keeps complaining. I've done all I could imagine.

Hi,

I've just setup postgreSQL on my Fedora Core1 box. I installed
postgresql from rpm files.
When I try to connect to the postgresql server in pgmanage, or through
an ODBC from other windows machines I get a message:
"missing or erroneous pg_hba.conf file"

I set tcpip_socket = true in var/lib/pgsql/data/postgresql.conf
I added '-i' optin to etc/rc.d/init.d/postgresql as follows
su -l postgres -s /bin/sh -c "/usr/bin/pg_ctl -D $PGDATA -o '-i '
-p
/usr/bin/postmaster start > /dev/null 2>&1
Here is my pg_hba.conf:

local all trust
host 10.1.9.0 255.255.255.0 trust
host 127.0.0.1 255.255.255.255 trust

Here is my /etc/hosts file:
127.0.0.1 localhost.localdomain localhost
127.0.0.1 TESTBOX localhost.localdomain localhost
10.1.9.XX TESTBOX.localdomain TESTBOX

When I go Systems Settings -> Network in the Hosts tab I see
IP Name Alias
10.1.9.XX TESTBOX.localdomain TESTBOX

Where am I going wrong? I've looked at multiple postings and there is
always something about extra characters and such but I'm using vi
editor on a Fedora machine so it should be fine.
Please let me know if you have any ideas.
THanks in advance.
N.K.
Nov 23 '05 #1
2 1711
nk*****@optonline.net (Liza) writes:
When I try to connect to the postgresql server in pgmanage, or through
an ODBC from other windows machines I get a message:
"missing or erroneous pg_hba.conf file" Here is my pg_hba.conf: local all trust
host 10.1.9.0 255.255.255.0 trust
host 127.0.0.1 255.255.255.255 trust


What PG version was this? Recent versions expect an additional column
(username) in pg_hba.conf.

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend

Nov 23 '05 #2
tg*@sss.pgh.pa.us (Tom Lane) wrote in message news:<24**************@sss.pgh.pa.us>...
nk*****@optonline.net (Liza) writes:
When I try to connect to the postgresql server in pgmanage, or through
an ODBC from other windows machines I get a message:
"missing or erroneous pg_hba.conf file"

Here is my pg_hba.conf:

local all trust
host 10.1.9.0 255.255.255.0 trust
host 127.0.0.1 255.255.255.255 trust


What PG version was this? Recent versions expect an additional column
(username) in pg_hba.conf.

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend



Thank you! You are right there is one more column. It all works now.
Thanks again.
N.K.
Nov 23 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

11 posts views Thread by Angel Todorov | last post: by
6 posts views Thread by David Nedrow | last post: by
reply views Thread by Tom Allison | last post: by
5 posts views Thread by Raymond O'Donnell | last post: by
1 post views Thread by David Parker | last post: by
4 posts views Thread by yashgt | last post: by
2 posts views Thread by K. | last post: by
reply views Thread by suresh191 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.