By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,372 Members | 1,906 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,372 IT Pros & Developers. It's quick & easy.

pg_hba.conf change in 7.4

P: n/a
Hi,

In 7.4, I noticed there is this ::1 and ffff: (x8 of them)
for IPv6.

I looked at the documentation and there is nothing that says
what the ::1 is for.

Commenting out that line will prevent access to PostgreSQL
from psql unless I put trust for that line.

This is what I had in 7.3.4:
host all all 127.0.0.1 255.255.255.255
ident pspmap
local all all password
host all all 0.0.0.0 0.0.0.0 reject

But in 7.4, it does not work anymore. It seems to want ::1 to be somewhere.
If I change the line with ::1 from trust to ident pspmap, it complains that
the user cannot be found. But it is in the pspmap. Message fromm psql:

psql: FATAL: IDENT authentication failed for user "postgres"

Right now, I have it set to trust to work around.
Any idea what to do about this ?

host all all 127.0.0.1 255.255.255.255
ident pspmap
local all all password
host all all 0.0.0.0 0.0.0.0 reject
# IPv4-style local connections:
#host all all 127.0.0.1 255.255.255.255 trust
# IPv6-style local connections:
host all all ::1
ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff trust

Thanks.

Gan
--
+--------------------------------------------------------+
| Seum-Lim GAN email : sl***@lucent.com |
| Lucent Technologies |
| 2000 N. Naperville Road, 6B-403F tel : (630)-713-6665 |
| Naperville, IL 60566, USA. fax : (630)-713-7272 |
| web : http://inuweb.ih.lucent.com/~slgan |
+--------------------------------------------------------+

---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 12 '05 #1
Share this Question
Share on Google+
9 Replies


P: n/a
Seum-Lim Gan wrote:
Hi,

In 7.4, I noticed there is this ::1 and ffff: (x8 of them)
for IPv6.

I looked at the documentation and there is nothing that says
what the ::1 is for.
The ::1 is a IPv6 shorthand for 127.0.0.1 (localhost).
Commenting out that line will prevent access to PostgreSQL
from psql unless I put trust for that line.

This is what I had in 7.3.4:
host all all 127.0.0.1 255.255.255.255
ident pspmap
local all all password
host all all 0.0.0.0 0.0.0.0 reject

But in 7.4, it does not work anymore. It seems to want ::1 to be somewhere.
If I change the line with ::1 from trust to ident pspmap, it complains that
the user cannot be found. But it is in the pspmap. Message fromm psql:
Seems you have an OS that makes all connections IPv6, even IPv4 ones.
That is why we had to have that line in there. Seems ::1 controls your
local connections on that platform. Some platforms have distinct IPv4
and IPv6 connections, so we have to include both lines in the file.
Right now, I have it set to trust to work around.
Any idea what to do about this ?

host all all 127.0.0.1 255.255.255.255
ident pspmap
local all all password
host all all 0.0.0.0 0.0.0.0 reject
# IPv4-style local connections:
#host all all 127.0.0.1 255.255.255.255 trust
# IPv6-style local connections:
host all all ::1
ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff trust


Yea, that's about it. My guess is that nothing is coming in via IPv4 on
your machine so 127.0.0.1 does nothing. Perhaps netstat will show the
IP address family used.

--
Bruce Momjian | http://candle.pha.pa.us
pg***@candle.pha.pa.us | (610) 359-1001
+ If your life is a hard drive, | 13 Roberts Road
+ Christ can be your backup. | Newtown Square, Pennsylvania 19073

---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org

Nov 12 '05 #2

P: n/a
Hi Bruce,

Thanks for the info.
I captured the netstat output below.

Looks like there is a bunch of IPv4 being used.

Any idea how this can be resolved ?

Thanks.

Gan

UDP: IPv6
Local Address Remote Address
State If
--------------------------------- ---------------------------------
---------- -----
localhost.35847 localhost.35847 Connected

TCP: IPv4
Local Address Remote Address Swind Send-Q Rwind Recv-Q State
-------------------- -------------------- ----- ------ ----- ------ -------
localhost.32906 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32906 49152 0 49152 0 ESTABLISHED
localhost.32908 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32908 49152 0 49152 0 ESTABLISHED
localhost.32910 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32910 49152 0 49152 0 ESTABLISHED
localhost.32911 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32911 49152 0 49152 0 ESTABLISHED
localhost.32913 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32913 49152 0 49152 0 ESTABLISHED
localhost.32915 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32915 49152 0 49152 0 ESTABLISHED
localhost.32917 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32917 49152 0 49152 0 ESTABLISHED
localhost.32919 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32919 49152 0 49152 0 ESTABLISHED
localhost.32920 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32920 49152 0 49152 0 ESTABLISHED
localhost.32922 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32922 49152 0 49152 0 ESTABLISHED
localhost.32923 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32923 49152 0 49152 0 ESTABLISHED
localhost.32924 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32924 49152 0 49152 0 ESTABLISHED
localhost.32926 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32926 49152 0 49152 0 ESTABLISHED
localhost.32927 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32927 49152 0 49152 0 ESTABLISHED
localhost.33086 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.33086 49152 0 49152 0 ESTABLISHED
localhost.33087 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.33087 49152 0 49152 0 ESTABLISHED
localhost.50882 localhost.14502 49152 0 49152 0 ESTABLISHED
localhost.14502 localhost.50882 49152 0 49152 0 ESTABLISHED
localhost.50883 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.50883 49152 0 49152 0 ESTABLISHED

At 12:11 pm -0500 2003/11/20, Bruce Momjian wrote:
Seum-Lim Gan wrote:
Hi,

In 7.4, I noticed there is this ::1 and ffff: (x8 of them)
for IPv6.

I looked at the documentation and there is nothing that says
what the ::1 is for.


The ::1 is a IPv6 shorthand for 127.0.0.1 (localhost).
Commenting out that line will prevent access to PostgreSQL
from psql unless I put trust for that line.

This is what I had in 7.3.4:
host all all 127.0.0.1 255.255.255.255
> ident pspmap
local all all password
host all all 0.0.0.0 0.0.0.0 reject

But in 7.4, it does not work anymore. It seems to want ::1 to be somewhere.
If I change the line with ::1 from trust to ident pspmap, it complains that
the user cannot be found. But it is in the pspmap. Message fromm psql:


Seems you have an OS that makes all connections IPv6, even IPv4 ones.
That is why we had to have that line in there. Seems ::1 controls your
local connections on that platform. Some platforms have distinct IPv4
and IPv6 connections, so we have to include both lines in the file.
Right now, I have it set to trust to work around.
Any idea what to do about this ?

host all all 127.0.0.1 255.255.255.255
ident pspmap
local all all password
host all all 0.0.0.0 0.0.0.0 reject
# IPv4-style local connections:
#host all all 127.0.0.1 255.255.255.255 trust
# IPv6-style local connections:
host all all ::1
ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff trust


Yea, that's about it. My guess is that nothing is coming in via IPv4 on
your machine so 127.0.0.1 does nothing. Perhaps netstat will show the
IP address family used.

--
Bruce Momjian | http://candle.pha.pa.us
pg***@candle.pha.pa.us | (610) 359-1001
+ If your life is a hard drive, | 13 Roberts Road
+ Christ can be your backup. | Newtown Square, Pennsylvania 19073

--
+--------------------------------------------------------+
| Seum-Lim GAN email : sl***@lucent.com |
| Lucent Technologies |
| 2000 N. Naperville Road, 6B-403F tel : (630)-713-6665 |
| Naperville, IL 60566, USA. fax : (630)-713-7272 |
| web : http://inuweb.ih.lucent.com/~slgan |
+--------------------------------------------------------+

---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

Nov 12 '05 #3

P: n/a

I think what happens is that when we listen on IPv4 and IPv6, that all
connections get IPv6. What OS are you using?

---------------------------------------------------------------------------

Seum-Lim Gan wrote:
Hi Bruce,

Thanks for the info.
I captured the netstat output below.

Looks like there is a bunch of IPv4 being used.

Any idea how this can be resolved ?

Thanks.

Gan

UDP: IPv6
Local Address Remote Address
State If
--------------------------------- ---------------------------------
---------- -----
localhost.35847 localhost.35847 Connected

TCP: IPv4
Local Address Remote Address Swind Send-Q Rwind Recv-Q State
-------------------- -------------------- ----- ------ ----- ------ -------
localhost.32906 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32906 49152 0 49152 0 ESTABLISHED
localhost.32908 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32908 49152 0 49152 0 ESTABLISHED
localhost.32910 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32910 49152 0 49152 0 ESTABLISHED
localhost.32911 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32911 49152 0 49152 0 ESTABLISHED
localhost.32913 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32913 49152 0 49152 0 ESTABLISHED
localhost.32915 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32915 49152 0 49152 0 ESTABLISHED
localhost.32917 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32917 49152 0 49152 0 ESTABLISHED
localhost.32919 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32919 49152 0 49152 0 ESTABLISHED
localhost.32920 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32920 49152 0 49152 0 ESTABLISHED
localhost.32922 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32922 49152 0 49152 0 ESTABLISHED
localhost.32923 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32923 49152 0 49152 0 ESTABLISHED
localhost.32924 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32924 49152 0 49152 0 ESTABLISHED
localhost.32926 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32926 49152 0 49152 0 ESTABLISHED
localhost.32927 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.32927 49152 0 49152 0 ESTABLISHED
localhost.33086 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.33086 49152 0 49152 0 ESTABLISHED
localhost.33087 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.33087 49152 0 49152 0 ESTABLISHED
localhost.50882 localhost.14502 49152 0 49152 0 ESTABLISHED
localhost.14502 localhost.50882 49152 0 49152 0 ESTABLISHED
localhost.50883 localhost.14500 49152 0 49152 0 ESTABLISHED
localhost.14500 localhost.50883 49152 0 49152 0 ESTABLISHED

At 12:11 pm -0500 2003/11/20, Bruce Momjian wrote:
Seum-Lim Gan wrote:
Hi,

In 7.4, I noticed there is this ::1 and ffff: (x8 of them)
for IPv6.

I looked at the documentation and there is nothing that says
what the ::1 is for.


The ::1 is a IPv6 shorthand for 127.0.0.1 (localhost).
Commenting out that line will prevent access to PostgreSQL
from psql unless I put trust for that line.

This is what I had in 7.3.4:
host all all 127.0.0.1 255.255.255.255
> ident pspmap
local all all password
host all all 0.0.0.0 0.0.0.0 reject

But in 7.4, it does not work anymore. It seems to want ::1 to be somewhere.
If I change the line with ::1 from trust to ident pspmap, it complains that
the user cannot be found. But it is in the pspmap. Message fromm psql:


Seems you have an OS that makes all connections IPv6, even IPv4 ones.
That is why we had to have that line in there. Seems ::1 controls your
local connections on that platform. Some platforms have distinct IPv4
and IPv6 connections, so we have to include both lines in the file.
Right now, I have it set to trust to work around.
Any idea what to do about this ?

host all all 127.0.0.1 255.255.255.255
ident pspmap
local all all password
host all all 0.0.0.0 0.0.0.0 reject
# IPv4-style local connections:
#host all all 127.0.0.1 255.255.255.255 trust
# IPv6-style local connections:
host all all ::1
ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff trust


Yea, that's about it. My guess is that nothing is coming in via IPv4 on
your machine so 127.0.0.1 does nothing. Perhaps netstat will show the
IP address family used.

--
Bruce Momjian | http://candle.pha.pa.us
pg***@candle.pha.pa.us | (610) 359-1001
+ If your life is a hard drive, | 13 Roberts Road
+ Christ can be your backup. | Newtown Square, Pennsylvania 19073

--
+--------------------------------------------------------+
| Seum-Lim GAN email : sl***@lucent.com |
| Lucent Technologies |
| 2000 N. Naperville Road, 6B-403F tel : (630)-713-6665 |
| Naperville, IL 60566, USA. fax : (630)-713-7272 |
| web : http://inuweb.ih.lucent.com/~slgan |
+--------------------------------------------------------+


--
Bruce Momjian | http://candle.pha.pa.us
pg***@candle.pha.pa.us | (610) 359-1001
+ If your life is a hard drive, | 13 Roberts Road
+ Christ can be your backup. | Newtown Square, Pennsylvania 19073

---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

Nov 12 '05 #4

P: n/a
Hi Bruce,

We are using Sun Solaris 9 on Sparc. uname -a :

SunOS test01 5.9 Generic_112233-04 sun4u sparc SUNW,Ultra-80

Gan

At 12:29 pm -0500 2003/11/20, Bruce Momjian wrote:
I think what happens is that when we listen on IPv4 and IPv6, that all
connections get IPv6. What OS are you using?

---------------------------------------------------------------------------

Seum-Lim Gan wrote:
Hi Bruce,

Thanks for the info.
I captured the netstat output below.

Looks like there is a bunch of IPv4 being used.

Any idea how this can be resolved ?

Thanks.

Gan

UDP: IPv6
Local Address Remote Address
State If
--------------------------------- ---------------------------------
---------- -----
localhost.35847 localhost.35847
Connected

TCP: IPv4
Local Address Remote Address Swind Send-Q Rwind Recv-Q State
-------------------- -------------------- ----- ------ ----- ------ -------
localhost.32906 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32906 49152 0 49152
0 ESTABLISHED
localhost.32908 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32908 49152 0 49152
0 ESTABLISHED
localhost.32910 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32910 49152 0 49152
0 ESTABLISHED
localhost.32911 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32911 49152 0 49152
0 ESTABLISHED
localhost.32913 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32913 49152 0 49152
0 ESTABLISHED
localhost.32915 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32915 49152 0 49152
0 ESTABLISHED
localhost.32917 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32917 49152 0 49152
0 ESTABLISHED
localhost.32919 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32919 49152 0 49152
0 ESTABLISHED
localhost.32920 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32920 49152 0 49152
0 ESTABLISHED
localhost.32922 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32922 49152 0 49152
0 ESTABLISHED
localhost.32923 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32923 49152 0 49152
0 ESTABLISHED
localhost.32924 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32924 49152 0 49152
0 ESTABLISHED
localhost.32926 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32926 49152 0 49152
0 ESTABLISHED
localhost.32927 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32927 49152 0 49152
0 ESTABLISHED
localhost.33086 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.33086 49152 0 49152
0 ESTABLISHED
localhost.33087 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.33087 49152 0 49152
0 ESTABLISHED
localhost.50882 localhost.14502 49152 0 49152
0 ESTABLISHED
localhost.14502 localhost.50882 49152 0 49152
0 ESTABLISHED
localhost.50883 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.50883 49152 0 49152
0 ESTABLISHED
>
At 12:11 pm -0500 2003/11/20, Bruce Momjian wrote:
>Seum-Lim Gan wrote:
>> Hi,
>>
>> In 7.4, I noticed there is this ::1 and ffff: (x8 of them)
>> for IPv6.
>>
>> I looked at the documentation and there is nothing that says
>> what the ::1 is for.
>
>The ::1 is a IPv6 shorthand for 127.0.0.1 (localhost).
>
>> Commenting out that line will prevent access to PostgreSQL
>> from psql unless I put trust for that line.
>>
>> This is what I had in 7.3.4:
>> host all all 127.0.0.1 255.255.255.255
> > ident pspmap
>> local all all

password
>> host all all 0.0.0.0 0.0.0.0 reject
>>
>> But in 7.4, it does not work anymore. It seems to want ::1 to

be somewhere.
>> If I change the line with ::1 from trust to ident pspmap, it

complains that
>> the user cannot be found. But it is in the pspmap. Message fromm psql:
>
>Seems you have an OS that makes all connections IPv6, even IPv4 ones.
>That is why we had to have that line in there. Seems ::1 controls your
>local connections on that platform. Some platforms have distinct IPv4
>and IPv6 connections, so we have to include both lines in the file.
>
>> Right now, I have it set to trust to work around.
>> Any idea what to do about this ?
>>
>> host all all 127.0.0.1 255.255.255.255
>> ident pspmap
>> local all all

password
>> host all all 0.0.0.0 0.0.0.0 reject
>> # IPv4-style local connections:
>> #host all all 127.0.0.1

255.255.255.255 trust
>> # IPv6-style local connections:
>> host all all ::1
>> ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff trust
>
>Yea, that's about it. My guess is that nothing is coming in via IPv4 on
>your machine so 127.0.0.1 does nothing. Perhaps netstat will show the
> >IP address family used.


--
+--------------------------------------------------------+
| Seum-Lim GAN email : sl***@lucent.com |
| Lucent Technologies |
| 2000 N. Naperville Road, 6B-403F tel : (630)-713-6665 |
| Naperville, IL 60566, USA. fax : (630)-713-7272 |
| web : http://inuweb.ih.lucent.com/~slgan |
+--------------------------------------------------------+

---------------------------(end of broadcast)---------------------------
TIP 6: Have you searched our list archives?

http://archives.postgresql.org

Nov 12 '05 #5

P: n/a
Hi Bruce,

I wonder if there is any recommendation to this ?
Is there a way to configure PostgreSQL to not use
IPv6 ?

We are also wonder if there is a version of Ident server
that the PostgreSQL community knows that will work
with IPv6.

Thanks.

Gan

At 11:37 am -0600 2003/11/20, Seum-Lim Gan wrote:
Hi Bruce,

We are using Sun Solaris 9 on Sparc. uname -a :

SunOS test01 5.9 Generic_112233-04 sun4u sparc SUNW,Ultra-80

Gan

At 12:29 pm -0500 2003/11/20, Bruce Momjian wrote:
I think what happens is that when we listen on IPv4 and IPv6, that all
connections get IPv6. What OS are you using?

---------------------------------------------------------------------------

Seum-Lim Gan wrote:
Hi Bruce,

Thanks for the info.
I captured the netstat output below.

Looks like there is a bunch of IPv4 being used.

Any idea how this can be resolved ?

Thanks.

Gan

UDP: IPv6
Local Address Remote Address
State If
--------------------------------- ---------------------------------
---------- -----
localhost.35847 localhost.35847
Connected

TCP: IPv4
Local Address Remote Address Swind Send-Q Rwind Recv-Q State
-------------------- -------------------- ----- ------ ----- ------ -------
localhost.32906 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32906 49152 0 49152
0 ESTABLISHED
localhost.32908 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32908 49152 0 49152
0 ESTABLISHED
localhost.32910 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32910 49152 0 49152
0 ESTABLISHED
localhost.32911 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32911 49152 0 49152
0 ESTABLISHED
localhost.32913 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32913 49152 0 49152
0 ESTABLISHED
localhost.32915 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32915 49152 0 49152
0 ESTABLISHED
localhost.32917 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32917 49152 0 49152
0 ESTABLISHED
localhost.32919 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32919 49152 0 49152
0 ESTABLISHED
localhost.32920 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32920 49152 0 49152
0 ESTABLISHED
localhost.32922 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32922 49152 0 49152
0 ESTABLISHED
localhost.32923 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32923 49152 0 49152
0 ESTABLISHED
localhost.32924 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32924 49152 0 49152
0 ESTABLISHED
localhost.32926 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32926 49152 0 49152
0 ESTABLISHED
localhost.32927 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.32927 49152 0 49152
0 ESTABLISHED
localhost.33086 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.33086 49152 0 49152
0 ESTABLISHED
localhost.33087 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.33087 49152 0 49152
0 ESTABLISHED
> localhost.50882 localhost.14502 49152 0 49152

0 ESTABLISHED
localhost.14502 localhost.50882 49152 0 49152
0 ESTABLISHED
localhost.50883 localhost.14500 49152 0 49152
0 ESTABLISHED
localhost.14500 localhost.50883 49152 0 49152
0 ESTABLISHED

At 12:11 pm -0500 2003/11/20, Bruce Momjian wrote:
>Seum-Lim Gan wrote:
>> Hi,
>>
>> In 7.4, I noticed there is this ::1 and ffff: (x8 of them)
>> for IPv6.
>>
>> I looked at the documentation and there is nothing that says
>> what the ::1 is for.
>
>The ::1 is a IPv6 shorthand for 127.0.0.1 (localhost).
>
>> Commenting out that line will prevent access to PostgreSQL
>> from psql unless I put trust for that line.
>>
>> This is what I had in 7.3.4:
>> host all all 127.0.0.1 255.255.255.255
> > ident pspmap
>> local all all
password
>> host all all 0.0.0.0 0.0.0.0 reject
>>
>> But in 7.4, it does not work anymore. It seems to want ::1 to
be somewhere.
>> If I change the line with ::1 from trust to ident pspmap, it
complains that
>> the user cannot be found. But it is in the pspmap. Message fromm psql:
>
>Seems you have an OS that makes all connections IPv6, even IPv4 ones.
>That is why we had to have that line in there. Seems ::1 controls your
>local connections on that platform. Some platforms have distinct IPv4
>and IPv6 connections, so we have to include both lines in the file.
>
>> Right now, I have it set to trust to work around.
>> Any idea what to do about this ?
>>
>> host all all 127.0.0.1 255.255.255.255
>> ident pspmap
>> local all all
password
>> host all all 0.0.0.0 0.0.0.0 reject
>> # IPv4-style local connections:
>> #host all all 127.0.0.1
255.255.255.255 trust
>> # IPv6-style local connections:
>> host all all ::1
>> ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff trust
>
>Yea, that's about it. My guess is that nothing is coming in via IPv4 on
>your machine so 127.0.0.1 does nothing. Perhaps netstat will show the
> >IP address family used.


--
+--------------------------------------------------------+
| Seum-Lim GAN email : sl***@lucent.com |
| Lucent Technologies |
| 2000 N. Naperville Road, 6B-403F tel : (630)-713-6665 |
| Naperville, IL 60566, USA. fax : (630)-713-7272 |
| web : http://inuweb.ih.lucent.com/~slgan |
+--------------------------------------------------------+

--
+--------------------------------------------------------+
| Seum-Lim GAN email : sl***@lucent.com |
| Lucent Technologies |
| 2000 N. Naperville Road, 6B-403F tel : (630)-713-6665 |
| Naperville, IL 60566, USA. fax : (630)-713-7272 |
| web : http://inuweb.ih.lucent.com/~slgan |
+--------------------------------------------------------+
Nov 12 '05 #6

P: n/a
Seum-Lim Gan wrote:
Hi Bruce,

I wonder if there is any recommendation to this ?
Is there a way to configure PostgreSQL to not use
IPv6 ?


One idea is to edit include/pg_config.h and comment out HAVE_IPV6 and
recompile and see if it works. That will disable the postmaster from
listening on IPv6.

--
Bruce Momjian | http://candle.pha.pa.us
pg***@candle.pha.pa.us | (610) 359-1001
+ If your life is a hard drive, | 13 Roberts Road
+ Christ can be your backup. | Newtown Square, Pennsylvania 19073

---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

Nov 12 '05 #7

P: n/a
Hi Bruce,

Thanks for the recommendation.

I will edit the pg_config.h file and comment out the
HAVE_IPV6 #define.
It is now defined as 0.

Earlier on, I tried to set IPV6 to no or 0 in configure.ih
and then configure and rebuild but that did not work.

Will let you know if commenting out the HAVE_IPV6 will work.

Thanks.

Gan

At 11:28 am -0500 2003/12/6, Bruce Momjian wrote:
Seum-Lim Gan wrote:
Hi Bruce,

I wonder if there is any recommendation to this ?
Is there a way to configure PostgreSQL to not use
IPv6 ?


One idea is to edit include/pg_config.h and comment out HAVE_IPV6 and
recompile and see if it works. That will disable the postmaster from
listening on IPv6.

--
Bruce Momjian | http://candle.pha.pa.us
pg***@candle.pha.pa.us | (610) 359-1001
+ If your life is a hard drive, | 13 Roberts Road
+ Christ can be your backup. | Newtown Square, Pennsylvania 19073

---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

--
+--------------------------------------------------------+
| Seum-Lim GAN email : sl***@lucent.com |
| Lucent Technologies |
| 2000 N. Naperville Road, 6B-403F tel : (630)-713-6665 |
| Naperville, IL 60566, USA. fax : (630)-713-7272 |
| web : http://inuweb.ih.lucent.com/~slgan |
+--------------------------------------------------------+

---------------------------(end of broadcast)---------------------------
TIP 8: explain analyze is your friend

Nov 12 '05 #8

P: n/a
Hello,

Also solaris has an option to not use IPV6 at least with Solaris 9.
When we installed
it it asked us if we wanted IPV6 support. We just said no.

Sincerely,

Joshua D. Drake
Seum-Lim Gan wrote:
Hi Bruce,

Thanks for the recommendation.

I will edit the pg_config.h file and comment out the
HAVE_IPV6 #define.
It is now defined as 0.

Earlier on, I tried to set IPV6 to no or 0 in configure.ih
and then configure and rebuild but that did not work.

Will let you know if commenting out the HAVE_IPV6 will work.

Thanks.

Gan

At 11:28 am -0500 2003/12/6, Bruce Momjian wrote:
Seum-Lim Gan wrote:
Hi Bruce,

I wonder if there is any recommendation to this ?
Is there a way to configure PostgreSQL to not use
IPv6 ?

One idea is to edit include/pg_config.h and comment out HAVE_IPV6 and
recompile and see if it works. That will disable the postmaster from
listening on IPv6.

--
Bruce Momjian | http://candle.pha.pa.us
pg***@candle.pha.pa.us | (610) 359-1001
+ If your life is a hard drive, | 13 Roberts Road
+ Christ can be your backup. | Newtown Square,
Pennsylvania 19073

---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly



--
Command Prompt, Inc., home of Mammoth PostgreSQL - S/ODBC - S/JDBC
Postgresql support, programming, shared hosting and dedicated hosting.
+1-503-222-2783 - jd@commandprompt.com - http://www.commandprompt.com

---------------------------(end of broadcast)---------------------------
TIP 9: the planner will ignore your desire to choose an index scan if your
joining column's datatypes do not match

Nov 12 '05 #9

P: n/a

Yes, I am not suspecting that there is something strange with that
Solaris installation. Maybe everything is IPv6. We certainly have lots
of Solaris users.

Are all Solaris connections coming in as IPv6? That seems impossible
because we didn't support IPv6 in PostgreSQL 7.3 and it worked fine.
Now, I can see Solaris favoring IPv6 if we listen on IPv4 and IPv6, but
if you compiled with IPv6 disabled, we don't listen on that port and I
can't see how the connection could be coming in on IPv6.

I think you need to dig into Solaris to see what netstat shows and how
your localhost is mapped on your machine.

---------------------------------------------------------------------------

Joshua D. Drake wrote:
Hello,

Also solaris has an option to not use IPV6 at least with Solaris 9.
When we installed
it it asked us if we wanted IPV6 support. We just said no.

Sincerely,

Joshua D. Drake
Seum-Lim Gan wrote:
Hi Bruce,

Thanks for the recommendation.

I will edit the pg_config.h file and comment out the
HAVE_IPV6 #define.
It is now defined as 0.

Earlier on, I tried to set IPV6 to no or 0 in configure.ih
and then configure and rebuild but that did not work.

Will let you know if commenting out the HAVE_IPV6 will work.

Thanks.

Gan

At 11:28 am -0500 2003/12/6, Bruce Momjian wrote:
Seum-Lim Gan wrote:

Hi Bruce,

I wonder if there is any recommendation to this ?
Is there a way to configure PostgreSQL to not use
IPv6 ?
One idea is to edit include/pg_config.h and comment out HAVE_IPV6 and
recompile and see if it works. That will disable the postmaster from
listening on IPv6.

--
Bruce Momjian | http://candle.pha.pa.us
pg***@candle.pha.pa.us | (610) 359-1001
+ If your life is a hard drive, | 13 Roberts Road
+ Christ can be your backup. | Newtown Square,
Pennsylvania 19073

---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly



--
Command Prompt, Inc., home of Mammoth PostgreSQL - S/ODBC - S/JDBC
Postgresql support, programming, shared hosting and dedicated hosting.
+1-503-222-2783 - jd@commandprompt.com - http://www.commandprompt.com


--
Bruce Momjian | http://candle.pha.pa.us
pg***@candle.pha.pa.us | (610) 359-1001
+ If your life is a hard drive, | 13 Roberts Road
+ Christ can be your backup. | Newtown Square, Pennsylvania 19073

---------------------------(end of broadcast)---------------------------
TIP 6: Have you searched our list archives?

http://archives.postgresql.org

Nov 12 '05 #10

This discussion thread is closed

Replies have been disabled for this discussion.