By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,663 Members | 1,375 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,663 IT Pros & Developers. It's quick & easy.

Fwd: installing postgres7.3.4 problem II

P: n/a
Please, disregard my last message. I've discovered that in "password" file it
was mentioned a path '/var/lib/psql' where Mandrake distro installed postres
previously. I've solved it.

But I still have another problem:

A later step in Postgres installation instructions says:
"/usr/local/pgsql/bin/postmaster -D /usr/local/pgsql/data >logfile 2>&1 &"
and with this I obtain:
"bash: logfile: Dennied permission"

I don't know bash either, so I can't understand the problem.

Could you give me a hand?

Javier

------------------------------------------------------
---------- Mensaje reenviado ----------

Subject: installing postgres7.3.4 problem
Date: Tue, 26 Aug 2003 18:10:10 +0200
From: javier garcia - CEBAS <rn***@cebas.csic.es>
To: pg***********@postgresql.org

Hi all.
(I'm a newby. I recognize it)
At the moment I had postgres running on my Linux machine with no problem.
I had version 7.2 installed, and this version came along with my Mandrake
distribution.
Now, I want to install a contribution package (postgis extensions), and
previously I would like to install a newer postgres version.
So, I've downloaded the postgres-7.3.4 source code and compiled it. But,
following the guidelines in the documentation, after "make install", I've
typed:
# su - postgres
(I don't know the meaning of a "login shell", but this is not my problem)
And then appears the message (in spanish):
"su: atention: we can't change to the directory /var/lib/pgsql: the directory
or file doesn't exists"

Previously I had postgres databases in /var/lib/pgsql. But I've uninstalled
the previously the 7.2 version and I don't know why this happens.

Could anyone guide me with this?

thanks and regards

Javier

-------------------------------------------------------

---------------------------(end of broadcast)---------------------------
TIP 6: Have you searched our list archives?

http://archives.postgresql.org

Nov 11 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
javier garcia - CEBAS wrote:
Please, disregard my last message. I've discovered that in "password" file it
was mentioned a path '/var/lib/psql' where Mandrake distro installed postres
previously. I've solved it.

But I still have another problem:

A later step in Postgres installation instructions says:
"/usr/local/pgsql/bin/postmaster -D /usr/local/pgsql/data >logfile 2>&1 &"
and with this I obtain:
"bash: logfile: Dennied permission"

I don't know bash either, so I can't understand the problem.

Could you give me a hand?

Javier


Javier,
What user are you when installing postgres?
You might try to do the following:
--
/usr/local/pgsql/bin/postmaster -D /usr/local/pgsql/data -l
/tmp/pgsql.log start

--

Basically, the problem you are having is that the user that you are
currently logged intot he shell as, doesn't have permission to
create/write to the 'logfile' in the current directory. My suggestion
would write your log to the /tmo directory. (which most users should
have access to write to)

-Robby

--
Robby Russell, | Sr. Administrator / Lead Programmer
Command Prompt, Inc. | http://www.commandprompt.com
rr******@commandprompt.com | Telephone: (503) 222.2783
---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org

Nov 11 '05 #2

P: n/a
On Tue, Aug 26, 2003 at 18:40:12 +0200,
javier garcia - CEBAS <rn***@cebas.csic.es> wrote:
Please, disregard my last message. I've discovered that in "password" file it
was mentioned a path '/var/lib/psql' where Mandrake distro installed postres
previously. I've solved it.

But I still have another problem:

A later step in Postgres installation instructions says:
"/usr/local/pgsql/bin/postmaster -D /usr/local/pgsql/data >logfile 2>&1 &"
and with this I obtain:
"bash: logfile: Dennied permission"

I don't know bash either, so I can't understand the problem.


You don't have access to create or write 'logfile' in the current directory.
You might want to use a full path to wherever you want the logfille to be.

---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

Nov 11 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.